NetWorker: Åtgärda inkonsekvent NSR-peer-information

Summary: Fel med NSR-peerinformation under säkerhetskopiering och återställning. Det finns redan en dator med namnet (client_name). Välj antingen ett annat namn för datorn eller ta bort posten "NSR peer information" för (client_name) på värden: (host_name) ' ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Säkerhetskopiering, återställning och kommunikation misslyckas på klienten med följande fel:
 

'nsrexecd: SYSTEM error: There is already a machine using the name (client_name). Either choose a different name for your machine, or delete the "NSR peer information" entry for (client_name) on host: (host_name)'
'nsrexecd: SYSTEM error: Connection reset by peer'

 nsrexecd.exe kan orsaka programfel på en eller flera klienter, inklusive servern eller lagringsnoderna.

Cause

Mappen res\nsrladb är hemvist för den nya certifikatbaserade värdautentiseringen (nsrauth). Den innehåller både den enskilda klientens lokala certifikat och en cachelagrad kopia av alla värdar som den har kommunicerat med.

Vid den första anslutningen begär och tar en värd emot certifikatet för den värd som den ansluter till, och cachelagrar värdcertifikatet för framtida jämförelser. Med undantag för riktade återställningar och lagringsnoder skulle varje klientcertifikat cachelagras på NetWorker-servern och lagringsnoderna i en standardmiljö, och serverns certifikat cachelagras på varje klient och lagringsnod. Dessa cachelagrade certifikat återspeglas i grenen Lokala värdar i konfigurationsträdet

När en klient installeras om genereras certifikatet på nytt lokalt på klienten. Detta gör att serverns cachelagrade kopia av klientens certifikat ogiltigförklaras, vilket orsakar felen. Samma villkor resulterar genom att helt enkelt byta namn på nsrladb på klienten.
 

Resolution

NSR-peerinformationen anges på klientnivå, inte på servernivå. Med andra ord: du måste ansluta till NSRLA, inte NSR-databasen. För att göra detta måste du ansluta via "nsradmin -p nsrexec" eller "nsradmin -p nsrexecd". "nsradmin" ansluter till NetWorker-servern.

Ta bort det icke-matchande/cachelagrade gamla certifikatet för klienten (client_name) på den NetWorker-värd som genererar felmeddelandet (host_name). Om NetWorker-servern uppgraderas/ominstalleras måste servercertifikatet tas bort från varje klient med hjälp av nsrauth stark autentisering. I båda fallen är den korrigerande åtgärden densamma och något av följande:

  1. Ta bort certifikatet för klienten som har uppdaterats från valfri värd med en kopia av den gamla via Lokala värdar i NMC
  2. Ta bort det gamla/cachelagrade certifikatet från den berörda klienten med hjälp av kommandoraden

Så här rensar du peer-informationen för klientdatorn (från servern)
 

nsradmin -s <host_name> -p nsrexec
nsradmin> delete type: nsr peer information; peer hostname: <client_name>

 

Så här rensar du peer-informationen på klientdatorn
 

nsradmin -p nsrexec
nsradmin> print type: nsr peer information
delete 

 
För ytterligare support, se: 

Additional Information

Du kan ta bort alla certifikat på ett säkert sätt, eftersom de ändå kommer att uppdateras vid nästa anslutning. Eftersom det kan finnas peer-information för både långt namn (FQDN) och kortnamn. Observera att cachelagring av certifikat endast är aktiverat för klienter vars autentiseringsmetod inkluderar nsrauth som en del av dess värde.

Lösning beroende på version:
  1. Om du endast inaktiverar nsrauth på server- och lagringsnoder (och startar om NW) åtgärdas problemet för gott.
  2. Ställ in NetWorker-servern på nsrauth- eller nsrauth/oldauth-läge.
Oldauth-läget kan inte användas för NetWorker-servern om den används med NMC 8.0.

En NetWorker 7.5.x-, 7.6.x- eller 8.0-server i oldauth-läge kan inte användas med NMC 8.0, som som standard är i nsrauth/oldauth-läge.

Affected Products

NetWorker

Products

NetWorker, NetWorker Series
Article Properties
Article Number: 000024312
Article Type: Solution
Last Modified: 25 Apr 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.