Avamar: Cómo establecer el Avamar Server en un estado controlado conocido
Summary: En este artículo, se explica cómo poner un Avamar Server en un estado controlado conocido.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Hay muchas tareas automatizadas en un servidor Avamar que pueden afectar los esfuerzos de solución de problemas y resolución.
En este procedimiento, se documenta cómo poner Avamar en lo que se denomina un "estado controlado conocido" para evitar que se produzca una actividad inesperada o no deseada.
La siguiente lista de comprobación se debe seguir cuando se realizan tareas de mantenimiento manuales y avanzadas. Por ejemplo:
Esta NO es una solución de evaluación del estado. Se supone que el servidor Avamar no está en buen estado.
En este procedimiento, se documenta cómo poner Avamar en lo que se denomina un "estado controlado conocido" para evitar que se produzca una actividad inesperada o no deseada.
La siguiente lista de comprobación se debe seguir cuando se realizan tareas de mantenimiento manuales y avanzadas. Por ejemplo:
- Reconstrucción de franjas
- Reconstrucción de nodos
- Reinicio de nodos offline
Esta NO es una solución de evaluación del estado. Se supone que el servidor Avamar no está en buen estado.
Cause
Las tareas de mantenimiento manuales o avanzadas se deben ejecutar en un servidor Avamar.
Resolution
Advertencia: Si se usan incorrectamente, algunos de los comandos a los que se hace referencia a continuación pueden causar problemas de integridad de datos o pérdida de datos. Si no comprende un comando o las consecuencias de ejecutarlo, solicite ayuda al soporte de Dell o a su representante local de partners de Dell.
Requisitos previos:
Requisitos previos:
- Todos los comandos se deben ejecutar como administrador con las claves SSH cargadas según el artículo Avamar: Cómo iniciar sesión en Avamar Server y cargar varias claves.
- Es posible que algunos comandos no proporcionen comentarios o no surtan efecto de inmediato; No debe ser necesario ejecutar un comando más de una vez.
- Para cualquier
avmaint config --avacomandos, siempre confirme que el cambio surta efecto. Ejecute el comando:
avmaint config --ava | grep <setting>
- Se debe evitar el mantenimiento manual. Permita que el programador de mantenimiento administre las tareas de mantenimiento siempre que sea posible.
- Las siguientes preguntas se deben responder mediante estos comandos para comprender el estado general de Avamar Server antes de trabajar en cualquier sistema:
- ¿Qué antigüedad tiene el último punto de control validado?
cplist
- ¿Están todas las secciones en línea? ¿Están todos los nodos en línea?
status.dpn
- ¿Están todos los servicios activos?
dpnctl status
- Compruebe si hay mantenimiento en ejecución y cancélelo si es necesario:
- Suspenda las actividades de mantenimiento mediante el programador de mantenimiento para asegurarse de que no se vuelvan a iniciar después de detenerlas.
avmaint sched suspend cp --ava avmaint sched suspend hfscheck --ava
No suspenda la recolección de elementos no utilizados (GC), ya que puede resultar en una reversión innecesaria.
- Ejecute el siguiente comando y compruebe si existen actividades de mantenimiento en ejecución.
status.dpn
- Si se está ejecutando un punto de control, deje que se complete.
- Si HFScheck está en ejecución, se puede detener si el servidor no está en modo de administrador (fase waitcgsan) o si HFScheck casi se ha completado:
avmaint hfscheckstop --ava
- Si se está ejecutando un GC, se puede terminar:
avmaint gckill --ava
Esto puede tardar algún tiempo en completarse, ya que el pase actual debe finalizar.
- Una vez que no haya más mantenimiento en ejecución, el programador de mantenimiento se debe detener:
dpnctl stop maint
- Detenga el programador de respaldos, deje de ejecutar respaldos o restauraciones y suspenda las conexiones nuevas:
- Evite que MCS inicie respaldos nuevos:
dpnctl stop sched
- Enumere todos los respaldos en ejecución:
avmaint sessions --ava | grep sessionid
Si se está ejecutando una restauración distinta de la replicación, consulte con el usuario para determinar si se debe permitir que se complete la restauración.
- Una vez que se recibe la aprobación del usuario de que los respaldos se pueden eliminar de forma limpia (se crean respaldos parciales) mediante la interfaz de usuario o de forma no limpia mediante:
avmaint kill -waittime=0 <sessionid>
- Enumere los respaldos adicionales no enumerados por el comando anterior:
avmaint sessions --full
- Según la operación que se vaya a realizar, es posible que no sea aceptable la ejecución de operaciones de tipo respaldo (es decir, avmaint getrefby). Por lo tanto, suspenda los distribuidores para no permitir respaldos manuales:
avmaint suspend
- Detenga la replicación (origen o destino de replicación).
- En el caso del origen de replicación (restauración), utilice la interfaz de usuario o EM o finalice el proceso para detener la replicación.
- Para el destino de replicación (respaldo), verifique si la replicación está en ejecución:
avmaint sessions | grep path
- Busque el dominio /REPLICATE en la ruta. Detenga la replicación en la cuadrícula de origen mediante los métodos del paso 4a.
- Desactive el crunching con el comando:
avmaint config --ava asynccrunching=false
El procesamiento puede tardar hasta 15 minutos en detenerse. Revise los registros de GSAN de los nodos de datos para ver si hay mensajes de "compresión".
- Desactivar el balanceo
- Compruebe si el balanceo está en ejecución:
avmaint config --ava | grep balancemin
Por lo general, el balanceo no debe estar habilitado (cualquier valor que no sea 0), pero aun así es importante comprobarlo.
- Para desactivar el balanceo:
avmaint config --ava balancemin=0
El balanceo puede tardar hasta 15 minutos en detenerse, compruebe status.dpn para ver si se están migrando fracciones y confirmar que el balanceo finalizó.
- Compruebe la capacidad:
- Compruebe la capacidad del SO:
avmaint nodelist --ava | grep fs-perc
- Compruebe el tamaño de los puntos de control:
mapall copy ~/cps # only if cps does not exist on the data nodes mapall --noerror './cps'
- Compruebe la lista de puntos de comprobación para determinar qué puntos de comprobación DEBEN conservarse (el último punto de comprobación validado en todos los nodos):
cplist
En función de los resultados anteriores, determine cuántos puntos de control se pueden mantener, cuáles son críticos y cuántos puntos de control nuevos se pueden crear.
Para obtener información sobre la capacidad, consulte el artículo Avamar: Conceptos y capacitación de administración de capacidad
- Tenga en cuenta el orden de los nodos y las diferencias entre los números de nodos lógicos y los números de nodos físicos:
nodenumbers status.dpn mapall --noerror 'tail -2 /data01/cur/gsan.log'
- Revisar el hardware
- Ahora se deben detener todas las tareas automatizadas.
- El servidor debe tener poca actividad y debe ser seguro continuar con cualquier tarea o comando manual.
Compruebe el servidor mediante la comprobación de los registros de GSAN en los nodos de datos. Verifique que se registre poca o ninguna actividad.
El comando uptime también se puede ejecutar mediante mapall, para comprobar que el "promedio de carga" en los nodos de datos sea bajo (entre 0,01 y 0,05)
Por ejemplo:
Por ejemplo:
mapall --noerror 'uptime' (0.0) ssh -x admin@10.xx.xx.xxx 'uptime' 16:39:29 up 100 days, 6:39, 0 users, load average: 0.01, 0.02, 0.01 (0.1) ssh -x admin@10.xx.xx.xxx 'uptime' 16:39:29 up 100 days, 6:39, 0 users, load average: 0.02, 0.01, 0.01 (0.2) ssh -x admin@10.xx.xx.xxx 'uptime' 16:39:29 up 100 days, 6:39, 0 users, load average: 0.02, 0.01, 0.01Los pasos anteriores configuran el servidor en un estado no productivo. Siempre revierta los cambios una vez que se hayan completado todas las tareas manuales.
Additional Information
Affected Products
Avamar, Avamar ServerArticle Properties
Article Number: 000170876
Article Type: Solution
Last Modified: 06 Aug 2025
Version: 15
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.