PowerStore: Pre-Upgrade Health Check to Detect a Stale SCSI-3 Reservation Issue
Summary: The Pre-Upgrade Health Check (PUHC) checks the system for any stale SCSI-3 reservations.
Symptoms
The Pre-Upgrade Health Check (PUHC) checks the system for any stale SCSI-3 reservations.
The PowerStore health check (PUHC) may fail because of SCSI-3 reservation with invalid or mismatch SCSI registration, with the following error:
Found stale SCSI3 reservations. Please contact your service provider. (off_release_stale_scsi3_reg_check). Error code: 0xE10050020204.
The health check is an off-release PUHC check that is contained in the Health Check thin package downloaded from the Dell Drivers & Downloads site. See the Additional Information section for information about the Health Check thin package.
Example of PUHC check detecting this issue:

Cause
In normal situations, whenever a host reserves an SCSI-3 reservation against a volume, there should be one or more SCSI registrations corresponding to it (depending on how many paths the host has, each registration corresponds to a I_T_L).
In rare instances, a SCSI registration is cleared but the corresponding SCSI-3 reservation is left over on the PowerStore side, pointing to the cleared SCSI registration. NDU to 4.0.0.X of such appliances may fail during the SYM handover step.
Resolution
This issue is resolved in PowerStoreOS version 4.1.0.1
Upgrades from PowerStoreOS version 3.x to 4.1.0.1+ will not encounter this issue.
The issue detected by this PUHC is resolved with PowerStoreOS version 4.0.1.3 and 4.1.0 (or later).
Workaround:
If the target code level of a pending upgrade is lower than version 4.1.0.1, follow this procedure:
Ask the customer to do the following two actions:
- Schedule a maintenance window for the NDU to minimize the chance of new reservations during the NDU.
- Perform a two-step upgrade from PowerStoreOS version 3.0.x, or from versions 3.2.x through 4.0.x by first upgrading to the latest 3.6.x release.
Additional Information
For more information of PUHC checks, see articles: