Skip to main content

NVP-vProxy: Backup immediately fails "The size of proxied data written has not been set"

Summary: The virtual machine backups immediately fail with "The size of proxied data written has not been set."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker VMware Protection integration is being configured with the vProxy Appliance. The initial execution of the VMware workflow fails immediately after startup. The NetWorker Management Console (NMC) backup action details and the backup action log shows:

MM/DD/YYYY HH:MM:SS [VM_NAME]: Searched all savesets, no complete saveset found. Perform full backup.
MM/DD/YYYY HH:MM:SS [VM_NAME]: Using backup mode 'VSS'.
MM/DD/YYYY HH:MM:SS [VM_NAME]: Started backup with job ID '98641' for save-set ID '8ae632f3-00000006-7f67e5fc-5a67e5fc-0382f4ec-501ec3bb' on vProxy '[VPROXY_NAME]'.
MM/DD/YYYY HH:MM:SS The size of proxied data written has not been set.
MM/DD/YYYY HH:MM:SS Save-set ID '2120738300' (client '[VCENTER_NAME]': save-set 'vm:5250eaf1-a2b0-9f56-947e-e78320b34298:[VCENTER_NAME]') is aborted.
MM/DD/YYYY HH:MM:SS [VM_NAME]: Downloaded vProxy Session log file 'C:\win32app\nsr\logs\policy\VM Protection\StaticVBA_DR\098641-[VM_NAME]-2018-1-24-14-48-51.log' under savejob 98641.
MM/DD/YYYY HH:MM:SS [VM_NAME]: Backup failed.

Cause

The vProxy and the virtual machines in the Protection Group must reside on the same vCenter server. The vProxy was deployed on a different vCenter server from the virtual machines in the Protection Group.

Resolution

A vProxy appliance must be available on the target vCenter server used in the Protection Group configuration. Redeploy the existing vProxy on the target vCenter server or deploy a new vProxy for the target vCenter.

Affected Products

NetWorker, NetWorker Management Console
Article Properties
Article Number: 000033935
Article Type: Solution
Last Modified: 09 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.