Dell Unity: CAVA-server ging offline en herstelde zich af en toe

Summary: De CAVA-server is offline gegaan en heeft zich met tussenpozen hersteld: "Er is een fout opgetreden in de viruscontroleserver xx.xx.xx.xx en deze is niet meer operationeel. (Fout: ERROR_AUTH 64)" :: Category=User Component=DART_VC "Viruscontroleserver xx.xx.xx.xx is online." :: Category=User Component=DART_VC. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Het probleem deed zich voor op Unity-code 4.4.0.1536311042 en Windows Server 2016.

Beschrijving van het probleem:

  1. De klant heeft CAVA geconfigureerd, ze kregen af en toe de foutmelding dat de CAVA-server offline ging en binnen enkele seconden weer online kwam.
    U ziet de volgende foutlogbestanden in EMCSystemLogFile.log

    "2018-12-28T02:18:22.331Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "ERROR" "13:10510021" :: "The virus checker server xx.xx.xx.xx has encountered an error and is no longer operational.(Error: ERROR_AUTH 64)" :: Category=User Component=DART_VC
    "2018-12-28T02:18:41.486Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "NOTICE" "13:1051001d" :: "Virus checker server xx.xx.xx.xx is online." :: Category=User Component=DART_VC
    "2018-12-28T02:35:42.361Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "ERROR" "13:10510021" :: "The virus checker server xx.xx.xx.xx has encountered an error and is no longer operational.(Error: ERROR_AUTH 64)" :: Category=User Component=DART_VC
    "2018-12-28T02:35:51.678Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "NOTICE" "13:1051001d" :: "Virus checker server xx.xx.xx.xx is online." :: Category=User

    Dezelfde foutmeldingen werden ook gerapporteerd in c4_safe_ktrace.log zoals:

    2018/12/28-21:32:25.865594 115K     7F86FEB3E709     sade:VC: 3:33:[Rick]  The virus checker server 160.46.85.196 has encountered an error and is no longer operational.(Error: ERROR_AUT
    2018/12/28-21:32:25.865596    0     7F86FEB3E709     sade:VC: 3:33:[Rick]  H 64)
    2018/12/28-21:32:25.865617   19     7F8790D83702     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1a0, NS=0) ShutdownStream() request UNSUPPORTED!
    2018/12/28-21:32:25.865622    4     7F8790D83702     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1a0, NS=0)  Handling as DisconnectCloseStream()!
    --
    2018/12/28-21:32:53.272520    0     7FC1D8ADC70A      std:PSMSYS:PSMSYS:psmDataAreaClose(1:13): PENDED...
    2018/12/28-21:32:55.127022 1.8M     7F86FEB3E702     sade:VC: 5:29:[Rick]  Virus checker server 160.46.85.196 is online.
    2018/12/28-21:32:55.128201 1177     7F8790DC7704     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1cb, NS=0) ShutdownStream() request UNSUPPORTED!
    2018/12/28-21:32:55.128206    3     7F8790DC7704     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1cb, NS=0)  Handling as DisconnectCloseStream()!
  2. De fout is willekeurig en zonder een bepaald patroon opgetreden. Het lijkt erop dat de CAVA-service niet wordt beïnvloed.

  3. KB#462457 is opgevolgd, maar we hebben geen verschuiving in de tijd gezien tussen CAVA-server/Unity/Windows DC-server.

  4. Uit netwerktraceringen blijkt dat de CAVA-server FSCTL_VALIDATE_NEGOTIATE_INFO Ioctl-aanvraag heeft verzonden, maar dat Unity niet heeft gereageerd en de verbinding met TCP-verbinding heeft verbroken.
    Toen het probleem zich voordeed, stuurde de CAVA-server een FSCTL_VALIDATE_NEGOTIATE_INFO Ioctl-aanvraag, maar Unity reageerde niet en voltooide de verbinding.

    # Goed voorbeeld van een case

    5817    0.433916    CAVA_IP    CIFS_IP    SMB2    156    Tree Connect Request Tree: \\rick\CHECK$
    5820    0.433983    CIFS_IP     CAVA_IP    SMB2    138    Tree Connect Response
    5823    0.434164    CAVA_IP    CIFS_IP    SMB2    212    Ioctl Request FSCTL_VALIDATE_NEGOTIATE_INFO
    5826    0.434217    CIFS_IP     CAVA_IP    SMB2    194    Ioctl Response FSCTL_VALIDATE_NEGOTIATE_INFO  <=========== good case

    # Voorbeeld van een slecht geval

    1806    0.096779    CAVA_IP    CIFS_IP    SMB2    156    Tree Connect Request Tree: \\rick\CHECK$
    1807    0.096854    CIFS_IP     CAVA_IP    SMB2    138    Tree Connect Response
    1818    0.097124    CAVA_IP    CIFS_IP    SMB2    212    Ioctl Request FSCTL_VALIDATE_NEGOTIATE_INFO
    1820    0.097200    CIFS_IP     CAVA_IP    TCP    54    445   52006 [FIN, ACK] Seq=85 Ack=261 Win=304 Len=0   <=========== bad case
  5. Dit probleem zou van invloed zijn op het kopiëren van CIFS-data, zoals het gebruik van emcopy om te proberen data van VNX naar Unity te migreren.
    Ze voeren meerdere kopieën tegelijk uit en af en toe mislukken verschillende exemplaren elke keer met de fout.

    Client OS : Microsoft (build 9200)
    TH000 : 02:28:08 : ERROR (53) : unable get server info from \\cifsserver.exmaple.net

 

Cause

Dit is een probleem, omdat Unity de informatie moet valideren met de initiële verbinding en niet met de gebonden verbinding. En het veroorzaakt problemen voor de klant.

 

Resolution

Dit is het probleem alleen met de SMB-versie 3.0.2, zelfs als ze overschakelen naar 3.1 of 2.1, het werkt. En zelfs in 3.0.2 hebben ze een tijdelijke oplossing.

Tijdelijke oplossing: Dislabe Multichannel op Windows-server of CAVA-server

Voer PowerShell uit als administrator en doe het volgende:

PS C:\windows\system32> Get-SmbClientConfiguration


ConnectionCountPerRssNetworkInterface : 4
DirectoryCacheEntriesMax              : 16
DirectoryCacheEntrySizeMax            : 65536
DirectoryCacheLifetime                : 10
DormantFileLimit                      : 1023
EnableBandwidthThrottling             : True
EnableByteRangeLockingOnReadOnlyFiles : True
EnableInsecureGuestLogons             : False
EnableLargeMtu                        : True
EnableLoadBalanceScaleOut             : True
EnableMultiChannel                    : True
EnableSecuritySignature               : True
ExtendedSessionTimeout                : 1000
FileInfoCacheEntriesMax               : 64
FileInfoCacheLifetime                 : 10
FileNotFoundCacheEntriesMax           : 128
FileNotFoundCacheLifetime             : 5
KeepConn                              : 600
MaxCmds                               : 50
MaximumConnectionCountPerServer       : 32
OplocksDisabled                       : False
RequireSecuritySignature              : False
SessionTimeout                        : 60
UseOpportunisticLocking               : True
WindowSizeThreshold                   : 8

PS C:\windows\system32> Set-SmbClientConfiguration -EnableMultiChannel $false

Confirm
Are you sure you want to perform this action?
Performing operation 'Modify' on Target 'SMB Client Configuration'.
[Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default is "Y"): yes
PS C:\windows\system32> Get-SmbClientConfiguration


ConnectionCountPerRssNetworkInterface : 4
DirectoryCacheEntriesMax              : 16
DirectoryCacheEntrySizeMax            : 65536
DirectoryCacheLifetime                : 10
DormantFileLimit                      : 1023
EnableBandwidthThrottling             : True
EnableByteRangeLockingOnReadOnlyFiles : True
EnableInsecureGuestLogons             : False
EnableLargeMtu                        : True
EnableLoadBalanceScaleOut             : True
EnableMultiChannel                    : False
EnableSecuritySignature               : True
ExtendedSessionTimeout                : 1000
FileInfoCacheEntriesMax               : 64
FileInfoCacheLifetime                 : 10
FileNotFoundCacheEntriesMax           : 128
FileNotFoundCacheLifetime             : 5
KeepConn                              : 600
MaxCmds                               : 50
MaximumConnectionCountPerServer       : 32
OplocksDisabled                       : False
RequireSecuritySignature              : False
SessionTimeout                        : 60
UseOpportunisticLocking               : True
WindowSizeThreshold                   : 8

 

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
Article Properties
Article Number: 000050509
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.