NetWorker: Lisensserveren returnerer feil på grunn av vertsnavnendring

Summary: NetWorker-lisensserveren returnerer feil på grunn av endring av vertsnavn.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Vertsnavnet for lisensserveren er endret

NetWorker Management Console (NMC)

Åpne NMC-administrasjonsvinduet på NetWorker-serveren, høyreklikk på serveren, og velg deretter Egenskaper fra listen. I kategorien Lisensiering i vinduet Serveregenskaper blar du til og velger lisensfilen for å fylle ut CLP-lisenstekstfeltet .

Under validering av lisensfil fra NMC vises følgende feil:
 

Checking CLP connection using '/nsr/lic/licspec.properties'.
Checking license properties file '/nsr/lic/licspec.properties'
Found 'license.path=/nsr/lic/_NETWV_3651067_06-Oct-2018.lic'
Checking license file '/nsr/lic/_NETWV_3651067_06-Oct-2018.lic'
157364:nsrlic: Unable to check out 'NETWORKER_UPDATE': status = -16 'Cannot read data from license server system. (-16,287)'
157364:nsrlic: Unable to check out 'NETWORKER_CAPACITY': status = -16 'Cannot read data from license server system. (-16,287)'
157363:nsrlic: License file '/nsr/lic/_NETWV_3651067_06-Oct-2018.lic' issues found: 0
FAILED
 
Informasjonen i lmgrd Tjenesten kjører, men feilen vises fortsatt "Cannot read data from license server system"

Cause

NetWorker Server ble koblet til den gamle lisensserveren.
Vertsnavnet til lisensserveren er endret.
Port 27000 og 27001 ble ikke åpnet.

Resolution

  1. Drepte lmgrd Tjenesten
  2. Start lmgrd Service og les lisensfilen
[root@emc]# lmutil lmreread -c /opt/emc/licenses
lmutil - Copyright (c) 1989-2014 Flexera Software LLC. All Rights Reserved.
lmreread successful
  1. Kontroller tilkoblingen mellom lisensserveren og NetWorker-serveren. nslookup og ping fungerer fint, men når vi sjekker for port sin sviktende på lisensserveren
[root@emclicenseserver]# curl -kv hostname:27001
* About to connect() to hostname port 27001 (#0)
* Trying 10.33.16.154... Connection refused
* couldn't connect to host
  1. Åpne port 27000 og 27001 på OS-nivå og åpne den
  2. Oppdater lisensservernavnet som angitt i lisensfilen i nsradmin som det har gamle lisensserveren navn og brukeren har endret vertsnavnet
nsradmin> p type: nsr
type: NSR;
name:hostname;
version: \
NetWorker 9.1.1.5.Build.288 CLP Capacity License;
comment: ;
CLP License server: oldlichostname;
CLP License server port: 27000;

refresh license conformance report: No;
nsradmin> update CLP License server: newlichostname
CLP License server: newlichostname;
Update? y
updated resource id 3.0.118.14.163.194.113.75.0.0.0.0.10.33.16.151(8147)
nsradmin> p type: nsr
type: NSR;
name: hostname;
version: \
NetWorker 9.1.1.5.Build.288 CLP Capacity License;
comment: ;
CLP License server: newlichostname;
CLP License server port: 27000;

refresh license conformance report: No;
  1. Start NetWorker-serveren på nytt
  2. Fra vinduet NMC-administrasjon –> klikk på servernavn –>serveregenskaper –> kategorien Lisensiering –> Klikk på CLP-lisenstekstfor å bla gjennom lisensfilen –> klikk på OK. Bla gjennom filen, og kontroller om den er validert.

Affected Products

NetWorker, NetWorker Management Console
Article Properties
Article Number: 000044563
Article Type: Solution
Last Modified: 10 Mar 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.