CloudLink: KMS-konfiguration mislykkes efter opgradering Cloudlink 8.1.0 til 8.2

Summary: Cloudlink8.2 har de nyeste sikkerhedsbiblioteker, som kræver specifikke felter, der skal opdateres i det signerede CA-certifikat.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

KMS-konfiguration mislykkes efter opgradering Cloudlink 8.1.0 til 8.2 på grund af forkert signeret CA-certifikat

Cause

Cloudlink8.2 har de nyeste sikkerhedsbiblioteker, der kræver specifikke felter (fremhævet), der skal opdateres i det signerede CA-certifikat.

              F.eks. fremhævede felter:

openssl req -x509 -newkey rsa:4096 -keyout clusterca_key.pem -out clusterca.pem -sha256 -days 365  -addext 'keyUsage=keyCertSign' -addext "basicConstraints=critical,CA:TRUE,pathlen:0" -subj '/CN=pp-clc802-oct28-1/O=Dell/OU=ISG/ST=TX/L=RoundRock' -addext 'subjectAltName=DNS:pp-clc802-oct28-1,DNS:pp-clc802-oct28-2' -addext 'subjectKeyIdentifier=hash'

Resolution

  1. Regenerering af certifikater med CA-feltet indstillet til true ved hjælp af CA-certifikatautoritet for KMIP-server, som er Cloudlink-server.
  2. Log på Cloudlink UI --klik> på "KMIP SERVER" --> klik på "Information" -->klik på "Actions" -->klik på "Upload CA Signed PEM" 
  3. Når Cloudlink KMIP-servercertifikatet er opdateret, skal vi generere nye KMIP-klientcertifikater, der kan føjes til KMS-betroet konfiguration på vCenter.
  4. I afsnittet KMIP SERVER -->klik på "Client" --> Vælg Client-->gå til "Actions" --> "Generate New Certificate"
  5. Du bør se, at den .zip fil med klientnavnet består af tre filer (ca.pem, cert.pem og key.pem).
  6. Log på vCenter --> vælg det vCenter-objekt, ---> gå til konfiguration --> gå til "key Provider" --> vælg klyngenavnet --> vælg "Establish Trust" i nedenstående --> vælg "Make KMS trust vCenter" --> vælg den tredje alternativknap og næste --> upload cert.pem og key.pem --> klik på "CREATE TRUST", som vil fuldføre konfigurationen.
Article Properties
Article Number: 000393850
Article Type: Solution
Last Modified: 08 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.