CloudLink: Yükseltmeden sonra KMS yapılandırması başarısız oluyor Cloudlink 8.1.0'dan 8.2'ye
Summary: Cloudlink8.2, imzalı CA sertifikasında güncelleştirilmesi gereken belirli alanlar gerektiren en son güvenlik kitaplıklarına sahiptir.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Yanlış imzalanmış CA sertifikası nedeniyle Cloudlink 8.1.0'dan 8.2'ye yükseltmeden sonra KMS yapılandırması başarısız oluyor
Cause
Cloudlink8.2, imzalı CA sertifikasında belirli alanların (vurgulanmış) güncellenmesini gerektiren en son güvenlik kitaplıklarına sahiptir.
Örneğin, vurgulanan alanlar:
openssl req -x509 -newkey rsa:4096 -keyout clusterca_key.pem -out clusterca.pem -sha256 -days 365 -addext 'keyUsage=keyCertSign' -addext "basicConstraints=critical,CA:TRUE,pathlen:0" -subj '/CN=pp-clc802-oct28-1/O=Dell/OU=ISG/ST=TX/L=RoundRock' -addext 'subjectAltName=DNS:pp-clc802-oct28-1,DNS:pp-clc802-oct28-2' -addext 'subjectKeyIdentifier=hash'Resolution
- Cloudlink sunucusu olan KMIP sunucusu için CA sertifika yetkisini kullanarak CA alanı true olarak ayarlanmış sertifikaları yeniden oluşturma.
- Cloudlink UI'da oturum açın -->"KMIP SERVER"a tıklayın --> "Information"a tıklayın -->"Actions"a tıklayın -->"Upload CA Signed PEM"e tıklayın
- Cloudlink KMIP sunucusu sertifikası güncelleştirildikten sonra, vCenter'daki KMS güvenilir yapılandırmasına eklemek için yeni KMIP istemci sertifikaları oluşturmamız gerekir.
- KMIP SUNUCUSU bölümünde --> "İstemci"ye tıklayın --> İstemciyi seçin --> "Eylemler"e gidin --> "Yeni Sertifika Oluştur"a gidin
- İstemci adının üç dosyadan (ca.pem, cert.pem ve key.pem) oluştuğu .zip dosyayı görmeniz gerekir.
- vCenter'da oturum açın --> vCenter nesnesini seçin ---> yapılandırmaya gidin --> "key Provider"a gidin --> küme adını seçin -- aşağıdaki "Güven Oluştur"u seçin -->> "KMS'nin vCenter a güvenmesini sağla"yı seçin --> üçüncü radyo düğmesini seçin ve ardından --> cert.pem ve key.pem dosyalarını yükleyin --> yapılandırmayı tamamlayacak olan "ESTABLISH TRUST" öğesine tıklayın.
Article Properties
Article Number: 000393850
Article Type: Solution
Last Modified: 08 Dec 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.