Avamar: scarse prestazioni di backup per il client Avamar che esegue l'antivirus Sophos

Summary: Questo articolo descrive le situazioni in cui un client Avamar che esegue l'antivirus Sophos riscontra prestazioni di backup scadenti.

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Symptoms

Questo comportamento può causare backup Avamar a esecuzione prolungata e impedire il completamento dei backup all'interno della finestra di backup disponibile.

Un client Avamar in cui è installato l'antivirus Sophos può occasionalmente riscontrare scarse prestazioni di backup quando viene eseguita una scansione on-demand Sophos sul sistema.

Nei giorni in cui l'antivirus Sophos esegue una scansione on-demand, Avamar potrebbe segnalare che la proporzione di file modificati è elevata.  
 
avtar Info <5156>: Backup #82 timestamp 2014-03-21 16:24:53, 80,687 files, 11,757 folders, 46.06 GB (80,188 files, 17.03 GB, 36.98% new) avtar Info <6083>: Backed-up 46.06 GB in 73.38 minutes: 38 GB/hour (65,976 files/hour)
Qui, avtar segnala che i dati modificati (i valori tra parentesi quadre) sono molto alti rispetto al dataset sottoposto a backup.  In questo caso, oltre il 99% dei file viene rilevato come modificato (80.188 file su 80.687)

In altri giorni, la proporzione di file modificati è più tipica.
avtar Info <5156>: Backup #91 timestamp 2014-04-03 10:11:54, 139,164 files, 13,805 folders, 60.73 GB (4 files, 280.1 KB, 0.00% new) avtar Info <6083>: Backed-up 60.73 GB in 7.03 minutes: 519 GB/hour (1,188,522 files/hour)

Cause

Il processo client Avamar (avtar) si basa sul ctime di un file per determinare se il file è stato modificato. Se il software di terze parti altera il ctime di un file nel dataset, avtar rileverà che il file è stato modificato. Avtar deve quindi elaborare (blocco, compressione, hash) l'intero file.  

Questa operazione può richiedere molto tempo se molti file hanno subito modifiche ctime o in cui i singoli file sono di grandi dimensioni.

Come illustrato nella documentazione

sophos 7.4 Archiver esegue il backup di tutti i file a cui è stata eseguita la scansione on-demand.
 
 Ciò è dovuto alle modifiche apportate da Sophos Anti-Virus nel tempo di modifica dello stato dei file. Per impostazione predefinita, Sophos Anti-Virus tenta di ripristinare l'ora di accesso (atime) dei file all'ora indicata prima della scansione.
Tuttavia, questo modifica il tempo di modifica dello stato dell'inode (ctime). Se il proprio archiver utilizza il ctime per decidere se un file è stato modificato, esegue il backup di tutti i file analizzati da Sophos Anti-Virus.
 
Risolvere il problema:

Eseguire la ricerca con l'opzione--no-reset-atime.


Resolution

Seguire la documentazione di Sophos e configurare Sophos per l'esecuzione con l'opzione --no-reset-atime.

Affected Products

Avamar

Products

Avamar, Avamar Client
Article Properties
Article Number: 000041039
Article Type: Solution
Last Modified: 06 Feb 2025
Version:  5
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