IDPA: Come aumentare la dimensione della partizione /space nella VM AVE prima di eseguire l'aggiornamento a 2.7 e versioni successive

Summary: Prima dell'aggiornamento a IDPA versione 2.7, alcuni modelli DP4400 e DP5x00 IDPA richiedono un'espansione della partizione interna. Questo articolo della Knowledge Base illustra la procedura per utilizzare lo strumento di utilità ave_scale. ...

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Symptoms

Quando la dimensione della partizione /space di AVE è inferiore a 96 GB, la convalida dell'aggiornamento di IDPA 2.7 non riesce. Ciò viene segnalato in RUCK, uno strumento di verifica preliminare dell'aggiornamento per garantire che l'appliance sia pronto per l'aggiornamento.

Consultare l'articolo Dell 196100 PowerProtect DP Series Appliance e IDPA: Istruzioni sull'utilità PowerProtect DP Rapid Upgrade Checker.

av_space_partition |  Use this KB to increase the size of the /space partition.

    Cause

    IDPA richiede che la partizione Protection Storage /space abbia una capacità di 96 GB prima di poter eseguire l'aggiornamento alla versione 2.7. AVE_Scale è uno strumento da riga di comando che automatizza l'espansione di questa partizione.

    Resolution

      Lo strumento viene fornito come file .zip nella pagina del software Dell PowerProtect Data Protection oppurescaricabile direttamente con questo link (è richiesto l'accesso al supporto Dell).
      Link per il download dello strumento di gestione delle partizioni dello spazio di pre-aggiornamento AVE ave_scale-19.4.0-7, dalla pagina Download 
      Il .zip contiene i seguenti file:

      • ave_scale-19.4.0-7.exe, per Windows
      • ave_scale-19.4.0-7, per Linux
      • Checksum e README

       

      Questa utilità è supportata per IDPA in Avamar Virtual Edition versione 18.2 e successive. Verificare che i requisiti siano soddisfatti nel campo Informazioni aggiuntive di seguito.

      1. Prima di eseguire questa utilità, creare un checkpoint in AVE e convalidarlo.
        1. Aprire un PuTTY o SSH su AVE utilizzando le credenziali di amministratore.
        2. Sospendere l'utilità di pianificazione della manutenzione con il comando: 
          dpnctl stop maint
        3. Arrestare il servizio backup scheduler con il comando:
          dpnctl stop sched
        4. Verificare che i servizi vengano sospesi o arrestati con il comando:
          dpnctl status
        5. Eseguire un checkpoint con il comando: 
          avmaint checkpoint --ava
        6. Monitorare lo stato del checkpoint e prendere nota del nome del checkpoint con il comando: 
          watch avmaint cpstatus
        7. Una volta status="completed" e result="OK", eseguire la convalida del checkpoint (controllo HFS) sul checkpoint manuale con il comando: 
          avmaint hfscheck --ava --rolling=true --full=false
           (verificare che stia convalidando il checkpoint appena creato).
        8. Monitorare lo stato del controllo HFS con il comando: 
          watch avmaint hfscheckstatus
        9. L'output deve essere status="completed" e result="OK". L'operazione potrebbe richiedere del tempo, a seconda dell'utilizzo dell'appliance.
        10. Verificare il CP appena creato e HFScheck su AVE con il comando: 
          cplist --full
      2. Verificare se MCS Flush è stato completato nelle ultime 12 ore.
      /usr/local/avamar/bin/mcserver.sh --status | grep -i "last flush completed"
      1. Se l'ora di Last Flush Completed è precedente a 12 ore o vicina a 12 ore, eseguire l'operazione di svuotamento MCS.
      /usr/local/avamar/bin/mcserver.sh --flush
      1. Ora torniamo ad ACM, verificare se l'opzione /home/admin/aveScale La directory esiste. Se la directory esiste, rinominarla in /home/admin/aveScale_old Utilizzando il seguente comando:
       mv /home/admin/aveScale /home/admin/aveScale_old

       

      Uso:

      ave_scale createspace <options>
      Opzioni:
      opzioni supportate per createspace :

      Opzione

      Descrizione

      --ave-admin-password <value>

      Password utente amministratore del sistema operativo guest AVE.

      --ave-hostname <value>

      Nome host o indirizzo IP risolvibile dell'Avamar Server.

      --ave-password <value>

      Password utente root del sistema operativo guest AVE.

      --ave-vm-name <value>

      Nome della VM AVE da vCenter Server, non nome
      host Si tratta di un'opzione obbligatoria.

      --vc-name <value>

      Nome host risolvibile di vCenter Server.

      --vc-username <value>

      Nome utente di vCenter Server.

      --vc-password <value>

      Password di vCenter Server.

      --vc-port <value>

      Numero di porta HTTPS di vCenter. 
      Il numero di porta predefinito è 443.

      --non-interactive

      Esegue il comando in modalità non interattiva quando tutte le password richieste sono fornite nella riga di comando.

      -d, --debug

      Esegue il debug dell'output.

      -h, --help

      Aiuto per il createspace .

      -l, --log string

      Percorso del file di registro.
      Il percorso predefinito è ./ave_scale.log.
      Utilizzare "-" per stderr.

       

      Nota: In caso di problemi, contattare il supporto Dell e condividere il codice di uscita fornito.
       

      Procedura per aumentare le dimensioni della partizione /space nella VM AVE.

      1. Scarica il ave_scale file di utilità.

      Collegarsi alla versione più recente dell'utilità ave_scale. L'archivio .zip contiene i file eseguibili Linux e Windows, i checksum e il file README.

      1. Accedere ad ACM come root utilizzando una connessione SSH.

        Assicurarsi che il file disponga dell'autorizzazione eseguibile. Per ottenere l'autorizzazione eseguibile, eseguire il seguente comando (19.4.x-x è utilizzato come esempio qui, sostituire 'x.x' con la versione:

        chmod 755 ave_scale-19.4.x-x
      2.  Espandere le dimensioni della partizione utilizzando il seguente comando:

      ./ave_scale-19.4.x-x createspace --vc-name <VCSA IP/FQDN> --vc-username administrator@vsphere.local --vc-password <VCSA password> --ave-hostname <AVE IP/FQDN> --ave-vm-name AVE --ave-password <AVE root password> --ave-admin-password <AVE admin user password>
      

      Modifica dei campi in base alle esigenze.

      1. Una volta completata correttamente l'utilità, accedere ad AVE utilizzando ssh con credenziali di amministratore.
      2. Eseguire il comando df -h per controllare le dimensioni della partizione /space.
      3. Assicurarsi che la dimensione totale della partizione /space sia 96 GB.
        Filesystem      Size  Used Avail Use% Mounted on
        devtmpfs         18G  4.0K   18G   1% /dev
        tmpfs            18G     0   18G   0% /dev/shm
        tmpfs            18G  1.1G   17G   7% /run
        tmpfs            18G     0   18G   0% /sys/fs/cgroup
        /dev/sda2        16G  6.9G  8.0G  47% /
        /dev/sda1       978M   59M  868M   7% /boot
        /dev/sdc1       1.5T  6.2G  1.5T   1% /data02
        /dev/sdd1       1.5T  6.4G  1.5T   1% /data03
        /dev/sda8        96G   19G   78G  20% /space
        /dev/sdb1       1.5T   68G  1.5T   5% /data01
        /dev/sda6       7.8G  229M  7.2G   4% /var
        
      4. Avviare i servizi dell'utilità di pianificazione della finestra di manutenzione e dell'utilità di pianificazione del backup:
      • Avviare l'utilità di pianificazione della manutenzione con il comando: 
        dpnctl start maint
      • Avviare il servizio backup scheduler con il comando:
        dpnctl start sched
      • Verificare che i servizi vengano avviati con il comando:
        dpnctl status

       

      Per informazioni dettagliate su ave_scale vedere il capitolo Espandere AVE in un'ambiente VMware nella Guida all'installazione e all'upgrade di Dell EMC Avamar Virtual Edition.

      Se l'appliance non deve essere aggiornato immediatamente, riabilitare le policy che sono state disabilitate durante l'esecuzione dei passaggi menzionati nella sezione Requisiti.

      Additional Information

      • Privilegi:
        • Su un host Linux, deve disporre di root per eseguire lo strumento ave_scale.
        • Il nome utente di vCenter Server (--vc-username) specificata nella riga di comando deve disporre dei privilegi per eseguire le seguenti attività:
        • Riconfigurare l'hardware del guest di una macchina virtuale.
        • Accendere e spegnere una macchina virtuale
        • Eseguire i comandi utilizzando l'agent guest della macchina virtuale.
        • Trasferisci i file da e verso un'istanza AVE.
      • Rete:
        • Sugli host Windows e Linux, lo strumento ave_scale deve essere in grado di ricevere risposte ping ICMP dall'istanza AVE di destinazione.
        • Lo strumento ave_scale deve essere in grado di connettersi all'istanza di vCenter Server utilizzando HTTPS.
      • Stato del nodo AVE:
        • Prendere nota dello stato corrente di tutte le policy sull'Avamar Server. Si consiglia di disabilitare tutti i criteri prima di eseguire ave_scale .
        • Attendere il completamento di tutti i job correnti.
        • Se il ripristino a livello di file (FLR, File-Level Restore) consente di eseguire il ripristino dei file, si attivano alcune sessioni anomale. Queste sessioni anomale mantengono occupato l'Avamar Server causando ave_scale strumento a fallire. Individuare e terminare queste sessioni anomale attenendosi alla seguente procedura:
      1. Accedere a Protection Software come amministratore, utilizzando PuTTY
      2. Eseguire il comando seguente per visualizzare le sessioni attive nel sistema:
        avmaint sessions | grep "path\|sessionid\|starttime"

      Dove:

      • path: Visualizza il percorso del client
      • sessionid: Visualizza l'ID univoco della sessione
      • starttime: Visualizza il timestamp UNIX dell'inizio della sessione
      1. Tradurre il valore da starttime in un formato leggibile eseguendo il seguente comando:
        t.pl <starttime>
      2. Confrontare il valore con l'utilità di pianificazione del backup per confermare se la sessione è in esecuzione. Se la sessione è stata avviata diversi giorni fa e non è configurata come straordinario, potrebbe trattarsi di una sessione che ha smesso di rispondere.
      3. Eseguire il comando seguente per rimuovere le sessioni che non rispondono:
        avmaint kill <sessionid>
      4. Dopo aver rimosso tutte le sessioni che non rispondono, eseguire il comando seguente per visualizzare l'elenco delle sessioni in esecuzione sul server Protection Software:
        avmaint sessions --full
      • Verificare se sono in esecuzione processi di backup o replica attenendosi alla seguente procedura:
      1. Connettersi all'utility node utilizzando SSH e accedere come amministratore.
      2. Eseguire il comando seguente per verificare se lo stato del server è inattivo: opstatus.dpn
      3. Eseguire i comandi seguenti:
      • avmaint sessions | grep path
        (per verificare se sono in corso processi di backup).
      • ​​​​​mccli activity show --active | grep Replication
        (per verificare se sono in corso processi di replica).

       

      • Se sono in esecuzione processi di backup o replica, è possibile attendere il completamento o terminarli.

      Si consiglia di attendere il completamento dei processi in esecuzione.

      1. Eseguire il comando seguente per terminare i job di backup o replica:
        mccli activity cancel --id=<job_id>
      2. Eseguire i seguenti comandi per verificare che i lavori non siano più in corso.
      • avmaint sessions | grep path
        (per verificare se sono in corso processi di backup).
      • mccli activity show --active | grep Replication
        (per verificare se sono in corso processi di replica).

      Affected Products

      Integrated Data Protection Appliance Family

      Products

      Integrated Data Protection Appliance Software
      Article Properties
      Article Number: 000190523
      Article Type: Solution
      Last Modified: 03 Dec 2025
      Version:  23
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