IDPA: Como aumentar o tamanho da partição /space na VM AVE antes de fazer upgrade para a versão 2.7 e posteriores

Summary: Alguns modelos do IDPA do DP4400 e DP5x00 exigem uma expansão de partição interna antes do upgrade para o IDPA versão 2.7. Este artigo da KB descreve o procedimento para usar a ferramenta de utilitário ave_scale. ...

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Symptoms

Quando o tamanho da partição /space do AVE for inferior a 96 GB, a validação do upgrade do IDPA 2.7 apresentará falha. Isso é relatado no RUCK, uma ferramenta de pré-verificação de upgrade para garantir que o equipamento esteja pronto para upgrade.

Consulte o artigo 196100 da Dell, PowerProtect DP Series Appliance e IDPA: Instruções sobre o utilitário PowerProtect DP Rapid Upgrade Checker.

av_space_partition |  Use this KB to increase the size of the /space partition.

    Cause

    O IDPA exige que a partição de armazenamento/espaço de proteção tenha 96 GB de capacidade antes que o upgrade do 2.7 possa ser executado. AVE_Scale é uma ferramenta de linha de comando que automatiza a expansão desta partição.

    Resolution

      A ferramenta é fornecida como um arquivo .zip na página do software de proteção de dados Dell PowerProtectou faça download diretamente com este link (é necessário entrar no Suporte Dell).
      Link para download da ferramenta de gerenciamento de partições de espaço de pré-upgrade AVE ave_scale-19.4.0-7, na página Downloads 
      O .zip contém os seguintes arquivos:

      • ave_scale-19.4.0-7.exe, para Windows
      • ave_scale-19.4.0-7, para Linux
      • Checksums e README

       

      Esse utilitário é compatível com o IDPA nas versões 18.2 e posteriores do Avamar Virtual Edition. Certifique-se de que os requisitos sejam atendidos no campo Informações adicionais abaixo.

      1. Antes de executar esse utilitário, crie um checkpoint no AVE e valide-o.
        1. Abra um PuTTY ou SSH para o AVE usando as credenciais de administrador.
        2. Suspenda o agendador de manutenção com o comando: 
          dpnctl stop maint
        3. Interrompa o serviço do agendador de backup com o comando:
          dpnctl stop sched
        4. Verifique se os serviços estão suspensos ou interrompidos com o comando:
          dpnctl status
        5. Faça um checkpoint com o comando: 
          avmaint checkpoint --ava
        6. Monitore o status do checkpoint e anote o nome dele com o comando: 
          watch avmaint cpstatus
        7. Depois de status="completed" e result="OK", execute a validação do checkpoint (verificação HFS) no checkpoint manual com o comando: 
          avmaint hfscheck --ava --rolling=true --full=false
           (verifique se está validando o checkpoint recém-criado).
        8. Monitore o status da verificação de HFS com o comando: 
          watch avmaint hfscheckstatus
        9. A saída deverá ser: status "completed" e resultado "OK". Isso pode levar algum tempo, dependendo da utilização do equipamento.
        10. Verifique o CP e o HFScheck recém-criados no AVE com o comando: 
          cplist --full
      2. Verifique se a atualização do MCS foi concluída nas últimas 12 horas.
      /usr/local/avamar/bin/mcserver.sh --status | grep -i "last flush completed"
      1. Se o tempo de conclusão do último flush tiver mais de 12 horas ou for próximo de 12 horas, execute a operação de flush do MCS.
      /usr/local/avamar/bin/mcserver.sh --flush
      1. Agora de volta ao ACM, verifique se o /home/admin/aveScale O diretório existe. Se o diretório existir, renomeie-o para /home/admin/aveScale_old Usando o seguinte comando:
       mv /home/admin/aveScale /home/admin/aveScale_old

       

      Uso:

      ave_scale createspace <options>
      Opções:
      opções suportadas para o createspace comando:

      Opção

      Descrição

      --ave-admin-password <value>

      Senha do usuário administrador do sistema operacional convidado do AVE.

      --ave-hostname <value>

      Nome de host ou endereço IP do Avamar Server que pode ser resolvido.

      --ave-password <value>

      Senha do usuário root do sistema operacional convidado do AVE.

      --ave-vm-name <value>

      Nome da VM AVE do vCenter Server, não nome do host
      Esta é uma opção obrigatória.

      --vc-name <value>

      Nome de host do vCenter Server que pode ser resolvido.

      --vc-username <value>

      Nome de usuário do vCenter Server.

      --vc-password <value>

      Senha do vCenter Server.

      --vc-port <value>

      Número da porta HTTPS do vCenter. 
      O número de porta padrão é 443.

      --non-interactive

      Executa o comando no modo não interativo quando todas as senhas necessárias são fornecidas na linha de comando.

      -d, --debug

      Faz a depuração da saída.

      -h, --help

      Ajuda para o createspace .

      -l, --log string

      Caminho do arquivo de log.
      O caminho padrão é ./ave_scale.log.
      Use "-" para stderr.

       

      Observação: Se houver algum problema, entre em contato com o Suporte Dell e compartilhe o código de saída fornecido.
       

      Etapas para aumentar o tamanho da partição /space na VM AVE.

      1. Faça download do ave_scale arquivo utilitário.

      Link para a versão mais recente do utilitário ave_scale. O arquivo .zip contém os executáveis Linux e Windows, checksums e README.

      1. Faça log-in no ACM como root usando uma conexão SSH.

        Verifique se o arquivo tem permissão executável. Para obter a permissão executável, execute o seguinte comando (19.4.x-x é usado como exemplo aqui, substitua "x.x" pela versão:

        chmod 755 ave_scale-19.4.x-x
      2.  Expanda o tamanho da partição usando o seguinte comando:

      ./ave_scale-19.4.x-x createspace --vc-name <VCSA IP/FQDN> --vc-username administrator@vsphere.local --vc-password <VCSA password> --ave-hostname <AVE IP/FQDN> --ave-vm-name AVE --ave-password <AVE root password> --ave-admin-password <AVE admin user password>
      

      Alterando campos conforme apropriado.

      1. Assim que o utilitário for concluído com êxito, faça login no AVE usando o SSH com credenciais de administrador.
      2. Execute o df -h Comando para verificar o tamanho da partição /space.
      3. Confirme se o tamanho total da partição /space é de 96 GB.
        Filesystem      Size  Used Avail Use% Mounted on
        devtmpfs         18G  4.0K   18G   1% /dev
        tmpfs            18G     0   18G   0% /dev/shm
        tmpfs            18G  1.1G   17G   7% /run
        tmpfs            18G     0   18G   0% /sys/fs/cgroup
        /dev/sda2        16G  6.9G  8.0G  47% /
        /dev/sda1       978M   59M  868M   7% /boot
        /dev/sdc1       1.5T  6.2G  1.5T   1% /data02
        /dev/sdd1       1.5T  6.4G  1.5T   1% /data03
        /dev/sda8        96G   19G   78G  20% /space
        /dev/sdb1       1.5T   68G  1.5T   5% /data01
        /dev/sda6       7.8G  229M  7.2G   4% /var
        
      4. Inicie os serviços do agendador da janela de manutenção e do agendador de backup:
      • Inicie o agendador de manutenção com o comando: 
        dpnctl start maint
      • Inicie o serviço do agendador de backup com o comando:
        dpnctl start sched
      • Verifique se os serviços foram iniciados com o comando:
        dpnctl status

       

      Para obter detalhes sobre ave_scale , consulte o capítulo Expandir AVE em um ambiente VMware no Guia de instalação e upgrade do Dell EMC Avamar Virtual Edition.

      Se o equipamento não deve receber upgrade imediatamente, reative as políticas que foram desativadas durante a execução das etapas mencionadas na seção Requisitos.

      Additional Information

      • Privilégios:
        • Em um host Linux, deve ter root para executar a ferramenta ave_scale.
        • O nome de usuário do vCenter Server (--vc-username) especificada na linha de comando deve ter os privilégios necessários para executar as seguintes tarefas:
        • Reconfigurar o hardware do convidado de uma máquina virtual.
        • Ligar e desligar uma máquina virtual.
        • Executar comandos usando o agente convidado da máquina virtual.
        • Transferir arquivos de e para uma instância do AVE.
      • Rede:
        • Nos hosts Windows e Linux, a ferramenta ave_scale deve ser capaz de receber respostas de ping ICMP da instância do AVE de destino.
        • A ferramenta ave_scale deve ser capaz de conectar-se à instância do vCenter Server usando HTTPS.
      • Status do nó do AVE:
        • Observe o estado atual de todas as políticas no Avamar Server. É recomendável desativar todas as políticas antes de executar o ave_scale ferramenta.
        • Aguarde a conclusão de todos os trabalhos atuais.
        • Se a funcionalidade de restauração em nível de arquivo (FLR) restaurar arquivos, algumas sessões anormais serão acionadas. Essas sessões anormais mantêm o Avamar Server ocupado, causando o ave_scale ferramenta para falhar. Localize e encerre essas sessões anormais, executando as seguintes etapas:
      1. Faça login no Protection Software como administrador, usando PuTTY
      2. Execute o seguinte comando para ver as sessões ativas no sistema:
        avmaint sessions | grep "path\|sessionid\|starttime"

      Onde:

      • path: Exibe o caminho para o client
      • sessionid: Exibe o identificador exclusivo da sessão
      • starttime: Exibe o registro de data e hora do UNIX de quando a sessão começou
      1. Traduza o valor do comando starttime parâmetro para um formato legível executando o seguinte comando:
        t.pl <starttime>
      2. Compare o valor com o agendador de backup para confirmar se a sessão está em execução. Se a sessão tiver sido iniciada há vários dias e não estiver configurada como hora extra, talvez seja uma sessão que parou de responder.
      3. Execute o seguinte comando para remover as sessões que não respondem:
        avmaint kill <sessionid>
      4. Depois que todas as sessões que não respondem tiverem sido removidas, execute o seguinte comando para ver a lista de sessões em execução no servidor Protection Software:
        avmaint sessions --full
      • Use as etapas a seguir para verificar se algum trabalho de backup ou replicação está em execução:
      1. Conecte-se ao nó do utilitário usando SSH e faça log-in como administrador.
      2. Execute o seguinte comando para verificar se o status do servidor está ocioso: opstatus.dpn
      3. Execute os seguintes comandos:
      • avmaint sessions | grep path
        (Para verificar se há trabalhos de backup em andamento).
      • ​​​​​mccli activity show --active | grep Replication
        (Para verificar se há algum trabalho de replicação em andamento).

       

      • Se algum trabalho de backup ou replicação estiver em execução, poderá aguardar a conclusão desses trabalhos ou encerrá-los.

      É recomendável aguardar até que os trabalhos em execução sejam concluídos.

      1. Execute o seguinte comando para encerrar os trabalhos de backup ou replicação:
        mccli activity cancel --id=<job_id>
      2. Execute os comandos a seguir para confirmar se os trabalhos não estão mais em andamento.
      • avmaint sessions | grep path
        (Para verificar se há trabalhos de backup em andamento).
      • mccli activity show --active | grep Replication
        (Para verificar se há algum trabalho de replicação em andamento).

      Affected Products

      Integrated Data Protection Appliance Family

      Products

      Integrated Data Protection Appliance Software
      Article Properties
      Article Number: 000190523
      Article Type: Solution
      Last Modified: 03 Dec 2025
      Version:  23
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