AppSync. Appsync-backup.bat в режиме отладки My Stop Responding with Message: Не удалось создать каталог Keycloak

Summary: Appsync-backup.bat в режиме отладки может перестать отвечать и отправить сообщение: Не удалось создать каталог keycloak: C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Любая функция, выполняющая резервное копирование базы данных AppSync, может перестать реагировать, если какая-либо из этих папок существует на накопителе, используемом продуктом для установки. 
\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox
 \EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
 \EMC\AppSync\jboss\datastore\data\configFiles
 \EMC\AppSync\jboss\datastore\data\AppSync_Ese
 \EMC\AppSync\jboss\datastore\data\AppSync_LIC
Запуск appsync-backup.bat из папки <install dir>\backup-assistant в режиме отладки, например:
appsync-backup -d
Перестает реагировать на запрос со следующей ошибкой, предполагая, что установочным диском был «C»:
 Failed to create keycloak directory :C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak

Cause

Appsync-backup.bat выполняется в базе данных, не имеющей определенного массива, который, как известно, перестает отвечать на запросы для AppSync 4.4 и более поздних версий, остаются следующие папки (при условии, что установочный накопитель — C:):
C:\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox
C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
C:\EMC\AppSync\jboss\datastore\data\configFiles
C:\EMC\AppSync\jboss\datastore\data\AppSync_Ese
C:\EMC\AppSync\jboss\datastore\data\AppSync_LIC
Это приводит к тому, что последующие запуски утилиты appsync-backup.bat, даже если она запускается во время модернизации, перестают отвечать. Однако при выполнении вручную в режиме отладки отображается ошибка:
Failed to create keycloak directory :C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak

Resolution

Удалите следующие папки:
C:\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox
C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
C:\EMC\AppSync\jboss\datastore\data\configFiles
C:\EMC\AppSync\jboss\datastore\data\AppSync_Ese
C:\EMC\AppSync\jboss\datastore\data\AppSync_LIC

Products

AppSync
Article Properties
Article Number: 000200777
Article Type: Solution
Last Modified: 14 May 2026
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.