PPMA 3.4.2.1 not able to communicate with PowerPath/VE 8.1 on ESXi 8.x,

Summary: Upgraded ESXi host with 8.0.2 host and PPVE 8.1 and hosts fails to connect to PPMA 3.4.2.1

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Symptoms

After upgrading ESXi and vCenter from 7.0.3 to 8.0.2. and installing PPVE 8.1 on the hosts it failed to communicate with the PPMA 3.4.2.1

The datacollector logs contains the following messages (This Token could not be processed by PPMA)

ERROR 03:21:31.807 [poll-task-fresxshd2002.deutsche-boerse.de] c.e.p.d.remote.dsdk.SsoAuthenticator - The Bearer token received from the vCenter for host:10.129.113.179 is :<?xml version='1.0' encoding='UTF-8'?><S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/"><S:Body><S:Fault xmlns:ns4="http://www.w3.org/2003/05/soap-envelope"><faultcode>S:Client</faultcode><faultstring>Couldn't create SOAP message due to exception: [com.ctc.wstx.exc.WstxLazyException] com.ctc.wstx.exc.WstxUnexpectedCharException: Unexpected character '&lt;' (code 60); expected a semi-colon after the reference for entity 'JAE'
 at [row,col {unknown-source}]: [1,672]</faultstring></S:Fault></S:Body></S:Envelope>.This Token could not be processed by PPMA.
INFO  03:21:31.807 [poll-task-fresxshd2002.deutsche-boerse.de] c.e.p.d.remote.dsdk.EsxDSDKClient - Could not retrieve the JWT token
ERROR 03:21:31.807 [poll-task-fresxshd2002.deutsche-boerse.de] c.e.p.d.hosts.impl.EsxHostListener - Connection attempt failed to host fresxshd2002.deutsche-boerse.de:0
ERROR 03:21:31.823 [poll-task-fresxshd2002.deutsche-boerse.de] c.e.p.d.remote.dsdk.EsxDSDKClient - Unable to connect to the server for host 10.129.113.179. The error is :HTTP/1.1 401 Unauthorized

The rpowermt command failed.

 # rpowermt check_registration host=xx.xxx.xxx.xx
Error while extracting JWT token

Cause

The customer included the & character in the password of the vCenter user powerpath

ESXi 8.x communication is based on the JWT tokens and relies on XML - and the ampersand (&) is a special character in XML - used to begin entity references. Using the character in the password broke the communication.

Resolution

The customer changed the PowerPath user password in vCenter and removed the & character from the password. 
The Hosts were able to successfully communicate with the PPMA  after doing this.

Affected Products

PowerPath Management Appliance
Article Properties
Article Number: 000222874
Article Type: Solution
Last Modified: 31 Jul 2025
Version:  1
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