Jak korzystać z rozwiązania Veeam z napędami taśmowymi i sterownikiem Microsoft LTO w systemie Windows 2012/2012R2
Summary: Jak korzystać z rozwiązania Veeam z napędami taśmowymi i sterownikiem Microsoft LTO w systemie Windows 2012/2012R2.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Sporadyczne napędy taśmowe LTO przechodziły w tryb offline za pomocą rozwiązania Veeam na kontrolerze PERC H330 ze sterownikiem IBM.
Cause
Jako możliwe rozwiązanie problemów z używaniem rozwiązań Veeam z napędami taśmowymi LTO na kontrolerze PERC H330 i używaniem sterownika IBM wymaganego przez VEEAM przetestowaliśmy użycie sterownika LTO skrzynki odbiorczej firmy Microsoft. Jest to obejście, które zostało pomyślnie przetestowane w naszym laboratorium z określonymi wersjami sprzętu i oprogramowania. Jednak ze względu na wiele możliwych kombinacji sprzętu i oprogramowania, nie możemy zagwarantować, że rozwiązanie sprawdzi się we wszystkich środowiskach:
Resolution
Środowisko testowe:
- Power Edge T430 z kartą PERC H330 i napędem
taśmowym LTO 6 — Windows 2012R2 ze wszystkimi poprawkami (na dzień 06/2016)
— Veeam Backup&Replication 9.0.0.1491
— przetestowane oprogramowanie wewnętrzne PERC H330: 25.3.0.0016; 25.4.0.0017; 25.4.1.0004
— przetestowany sterownik PERC: 6.603.07.00
W tym scenariuszu 3 taśmy LTO zostały zapisane przy użyciu rozwiązania Veeam z następującymi poziomami oprogramowania wewnętrznego/sterowników o różnych rozmiarach bloków (64 kB, 128 kB, 256 kB):
oprogramowanie wewnętrzne kontrolera PERC H330: 25.3.0.0016
— sterownik PERC H330: 6.603.07.00
- Sterownik taśm IBM: 6.2.5.6
- Oprogramowanie wewnętrzne LTO6: F9A1
Zapisane taśmy zostały zweryfikowane przez odzyskiwanie plików.
Następnie sterownik IBM został zastąpiony aktualnym sterownikiem skrzynki odbiorczej Microsoft z systemu Windows 2012R2 zgodnie z poniższym opisem:
Początkowo zainstalowany sterownik (6.2.5.6) został odinstalowany za pomocą "uninst.exe" z pakietu sterownika IBM:
Po kolejnym ponownym uruchomieniu napęd LTO jest wyświetlany z żółtym wykrzyknikiem.
Teraz sterownik Microsoft musi zostać zainstalowany ręcznie:
Po kolejnym ponownym uruchomieniu napęd powinien być teraz wyświetlany jako napęd taśmowy LTO, zainstalowany sterownik jest teraz sterownikiem Microsoft.
Wersja: 6.3.9600.16384
Następnie zinwentaryzowano nośnik napisany wcześniej za pomocą Veeam i sterownika IBM:
Wykonano to ze wszystkimi 3 wcześniej zapisanymi nośnikami (rozmiar bloku 64 kB, 128 kB i 256 kB).
Na początku każdy nośnik został użyty do przywrócenia 1 pliku metody testowej, a następnie wykonano kolejną kopię zapasową na odpowiednim nośniku. Nie było żadnych problemów / problemów.
W dalszych testach udało się ustalić zachowanie Veeam ze sterownikiem Microsoftu:
Sama inwentaryzacja jest pozornie bezbłędna, ale dysk nadal będzie wyświetlany jako pusty, więc nie ma możliwości utworzenia kopii zapasowej ani usunięcia tego nośnika. W takim przypadku nośnik musi zostać usunięty za pomocą narzędzia innej firmy, takiego jak ITDT.
Następnie nośnik można łatwo zinwentaryzować i wykorzystać.
Aby usunąć taśmę do dalszego użytku z Veeam przy użyciu narzędzia ITDT, wykonaj następujące czynności:
Uruchom ITDT jako administrator:
Wpisz U dla "[ U ] Tapeutil" i Enter.
Wpisz 1 dla opcji "[ 1 ] Otwórz urządzenie" i Enter.
Kontynuuj za pomocą klawisza Enter.
Kontynuuj za pomocą klawisza Enter.
Kontynuuj za pomocą klawisza Enter.
Urządzenie zostało otwarte, kontynuuj za pomocą klawisza Enter.
Wpisz 28 dla opcji "[ 28 ] Erase" i Enter.
Rozpocznie się proces usuwania.
Uwaga: proces usuwania (jest to "długie wymazywanie") trwa kilka godzin. Można go przerwać, resetując dysk (naciskając przycisk wysuwania przez co najmniej 15 sekund), taśmę można bez problemu wykorzystać po ponownym załadowaniu przez firmę Veeam.
Jeśli podczas rozpoczynania procesu usuwania zostanie wyświetlony następujący komunikat:
Wykonaj następujące czynności, a następnie spróbuj ponownie rozpocząć proces usuwania:
Następujące zachowanie jest nadal niejasne:
- Power Edge T430 z kartą PERC H330 i napędem
taśmowym LTO 6 — Windows 2012R2 ze wszystkimi poprawkami (na dzień 06/2016)
— Veeam Backup&Replication 9.0.0.1491
— przetestowane oprogramowanie wewnętrzne PERC H330: 25.3.0.0016; 25.4.0.0017; 25.4.1.0004
— przetestowany sterownik PERC: 6.603.07.00
W tym scenariuszu 3 taśmy LTO zostały zapisane przy użyciu rozwiązania Veeam z następującymi poziomami oprogramowania wewnętrznego/sterowników o różnych rozmiarach bloków (64 kB, 128 kB, 256 kB):
oprogramowanie wewnętrzne kontrolera PERC H330: 25.3.0.0016
— sterownik PERC H330: 6.603.07.00
- Sterownik taśm IBM: 6.2.5.6
- Oprogramowanie wewnętrzne LTO6: F9A1
Zapisane taśmy zostały zweryfikowane przez odzyskiwanie plików.
Następnie sterownik IBM został zastąpiony aktualnym sterownikiem skrzynki odbiorczej Microsoft z systemu Windows 2012R2 zgodnie z poniższym opisem:
Początkowo zainstalowany sterownik (6.2.5.6) został odinstalowany za pomocą "uninst.exe" z pakietu sterownika IBM:
Po kolejnym ponownym uruchomieniu napęd LTO jest wyświetlany z żółtym wykrzyknikiem.
Teraz sterownik Microsoft musi zostać zainstalowany ręcznie:
Po kolejnym ponownym uruchomieniu napęd powinien być teraz wyświetlany jako napęd taśmowy LTO, zainstalowany sterownik jest teraz sterownikiem Microsoft.
Wersja: 6.3.9600.16384
Następnie zinwentaryzowano nośnik napisany wcześniej za pomocą Veeam i sterownika IBM:
Wykonano to ze wszystkimi 3 wcześniej zapisanymi nośnikami (rozmiar bloku 64 kB, 128 kB i 256 kB).
Na początku każdy nośnik został użyty do przywrócenia 1 pliku metody testowej, a następnie wykonano kolejną kopię zapasową na odpowiednim nośniku. Nie było żadnych problemów / problemów.
W dalszych testach udało się ustalić zachowanie Veeam ze sterownikiem Microsoftu:
- Taśmy wcześniej opisane w tej instalacji Veaam można było inwentaryzować bez ograniczeń. Odzyskiwanie danych i dalsze wykorzystywanie ich do kopii zapasowych jest możliwe bez problemów i niezależnie od wielkości bloku. Usunięcie lub sformatowanie taśmy nie było wymagane.
- Nowe, nieużywane taśmy można łatwo zinwentaryzować i w pełni wykorzystać do tworzenia kopii zapasowych i dalszego odzyskiwania.
- Taśm używanych wcześniej z innymi aplikacjami do tworzenia kopii zapasowych lub narzędziami testowymi, takimi jak ITDT, nie można było inwentaryzować, opisywać, usuwać ani formatować za pomocą rozwiązań Veeam. Było to możliwe dopiero po usunięciu taśmy za pomocą odpowiedniego narzędzia innej firmy (w tym przypadku ITDT). Jednak po usunięciu nośników w ramach Veeam możliwe było nieograniczone użytkowanie.
Sama inwentaryzacja jest pozornie bezbłędna, ale dysk nadal będzie wyświetlany jako pusty, więc nie ma możliwości utworzenia kopii zapasowej ani usunięcia tego nośnika. W takim przypadku nośnik musi zostać usunięty za pomocą narzędzia innej firmy, takiego jak ITDT.
Następnie nośnik można łatwo zinwentaryzować i wykorzystać.
Aby usunąć taśmę do dalszego użytku z Veeam przy użyciu narzędzia ITDT, wykonaj następujące czynności:
Uruchom ITDT jako administrator:
Wpisz U dla "[ U ] Tapeutil" i Enter.
Wpisz 1 dla opcji "[ 1 ] Otwórz urządzenie" i Enter.
Kontynuuj za pomocą klawisza Enter.
Kontynuuj za pomocą klawisza Enter.
Kontynuuj za pomocą klawisza Enter.
Urządzenie zostało otwarte, kontynuuj za pomocą klawisza Enter.
Wpisz 28 dla opcji "[ 28 ] Erase" i Enter.
Rozpocznie się proces usuwania.
Uwaga: proces usuwania (jest to "długie wymazywanie") trwa kilka godzin. Można go przerwać, resetując dysk (naciskając przycisk wysuwania przez co najmniej 15 sekund), taśmę można bez problemu wykorzystać po ponownym załadowaniu przez firmę Veeam.
Jeśli podczas rozpoczynania procesu usuwania zostanie wyświetlony następujący komunikat:
Wykonaj następujące czynności, a następnie spróbuj ponownie rozpocząć proces usuwania:
- Sprawdź, czy taśma jest rzeczywiście załadowana do napędu i załaduj ją ponownie w razie potrzeby.
- Rozładowanie/załadowanie taśmy.
- Uruchom ponownie system.
Następujące zachowanie jest nadal niejasne:
- Taśmy napisane wcześniej za pomocą rozwiązania Veeam przy użyciu sterownika IBM są rozpoznawane przez ITDT jako tylko do odczytu w przypadku korzystania ze sterownika firmy Microsoft. Po usunięciu, jak opisano powyżej, są one normalnie użyteczne.
- Jeśli zainstalowany jest sterownik taśm IBM, czasami nie jest możliwe zwiększenie lub obniżenie wersji oprogramowania wewnętrznego PERC ("no supported device found"). W niektórych przypadkach możliwe jest uaktualnienie/przywrócenie wersji po ponownym uruchomieniu, ale czasami dopiero po fizycznym odłączeniu napędu LTO od kontrolera.
- Jeśli zainstalowany jest sterownik taśm IBM, zwiększenie lub obniżenie wersji oprogramowania wewnętrznego napędu LTO jest częściowo niemożliwe. Czasami jest to możliwe po ponownym uruchomieniu, a w niektórych przypadkach dopiero po uaktualnieniu lub obniżeniu wersji oprogramowania wewnętrznego PERC lub przełączeniu na sterownik Microsoft.
Affected Products
Dell EMC ML3, PowerVault 124T, Powervault LTO6, PowerVault ML6000, PowerVault TL2000, PowerVault TL4000, PowerVault TL1000Article Properties
Article Number: 000144804
Article Type: Solution
Last Modified: 07 Oct 2022
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.