Hvordan bruke Veeam med båndstasjoner og Microsoft LTO-driver i Windows 2012/2012R2

Summary: Hvordan bruke Veeam med båndstasjoner og Microsoft LTO-driver i Windows 2012/2012R2.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Sporadiske LTO-båndstasjoner ble frakoblet ved hjelp av Veeam på PERC H330 med IBM-driveren.

Cause

Som en mulig løsning på problemer med bruk av Veeam med LTO-båndstasjoner på PERC H330 og bruk av IBM-driveren som kreves av VEEAM, har vi testet bruken av Microsofts innboks LTO-driver. Det er en løsning som har blitt testet i laboratoriet vårt med visse maskinvare- og programvareversjoner. På grunn av de mange mulige kombinasjonene av maskinvare og programvare kan vi imidlertid ikke garantere at løsningen vil fungere i alle miljøer:

Resolution

Testmiljø:

- Power Edge T430 med PERC H330-adapter og LTO 6-båndstasjon
- Windows 2012R2 med alle oppdateringer (per 06/2016)
- Veeam Backup &Replication 9.0.0.1491
- Testet PERC H330 FW Stände: 25.3.0.0016; 25.4.0.0017; 25.4.1.0004
– testet PERC-driver: 6.603.07.00

I det gitte scenariet ble 3 LTO-bånd skrevet med Veeam ved hjelp av følgende FW / drivernivåer med forskjellige blokkstørrelser (64kB, 128kB, 256kB):

- PERC H330 FW: 25.3.0.0016
- PERC H330-driver: 6.603.07.00
- IBM bånddriver: 6.2.5.6
- LTO6 FW: F9A1

De skrevne båndene er validert ved gjenoppretting av filer.
Deretter ble IBM-driveren erstattet av den nåværende Microsoft-innboksdriveren fra Windows 2012R2 som beskrevet nedenfor:

Først ble den installerte driveren (6.2.5.6) avinstallert med "uninst.exe" fra IBM-driverpakken:


SLN316530_en_US__1Veeam 01 SLN316530_en_US__2Veeam 02
SLN316530_en_US__3Veeam 03




SLN316530_en_US__5Veeam 05 SLN316530_en_US__4Veeam 04
Etter den påfølgende omstarten vises LTO-stasjonen med et gult utropstegn.
SLN316530_en_US__6Veeam 06

Nå må Microsoft-driveren installeres manuelt:
SLN316530_en_US__11Veeam 11

SLN316530_en_US__9Veeam 09 SLN316530_en_US__8Veeam 08




SLN316530_en_US__7Veeam 07 SLN316530_en_US__10Veeam 10


Etter en annen omstart skal stasjonen nå vises som LTO Tapedrive, den installerte driveren er nå Microsoft-driveren.
Versjon: 6.3.9600.16384
SLN316530_en_US__12Veeam 12



SLN316530_en_US__13Veeam 13

SLN316530_en_US__14Veeam 14Etter det, et medium tidligere skrevet med Veeam og IBM driveren ble inventarisert:
SLN316530_en_US__15Veeam 15

SLN316530_en_US__16Veeam 16

Dette ble gjort med alle 3 tidligere skrevet media (64kB, 128kB og 256kB blocksize).
Først ble hvert medium brukt til å gjenopprette 1-fil av testmetoden, og deretter ble det utført en ytterligere sikkerhetskopi til det respektive mediet. Det var ingen problemer / problemer.
I ytterligere tester kan Veeams oppførsel med Microsoft-driveren bestemmes:
  1. Bånd som tidligere ble beskrevet med denne Veaam-installasjonen, kunne oppbevares uten begrensninger. Gjenoppretting av data og videre bruk for sikkerhetskopier er mulig uten problemer og uavhengig av blokkstørrelse. Det var ikke nødvendig å slette eller formatere båndet.
  2. Nye, ubrukte kassetter kunne enkelt lagerføres og brukes fullt ut til sikkerhetskopiering og videre gjenoppretting.
  3. Bånd som tidligere ble brukt med andre sikkerhetskopieringsprogrammer eller testverktøy som ITDT, kunne ikke lagres, beskrives, slettes eller formateres med Veeam. Dette var bare mulig etter å ha slettet båndet med et passende tredjepartsverktøy (i dette tilfellet ITDT). Men etter å ha slettet mediene, var ubegrenset bruk mulig under Veeam.
Problemet beskrevet under punkt 3 viser følgende virkemåte:
Selve beholdningen er tilsynelatende uten feil, men stasjonen vil fortsatt vises som tom, så det er ingen sikkerhetskopiering eller sletting av dette mediet mulig. I dette tilfellet må mediet slettes ved hjelp av et tredjepartsverktøy, for eksempel ITDT.
Etter det kan mediet lett oppbevares og brukes.
For å slette båndet for videre bruk med Veeam ved hjelp av ITDT-verktøyet, gjør du følgende:

Start ITDT som administrator:


SLN316530_en_US__17Veeam 17
SLN316530_en_US__18Veeam 18
Skriv inn U for "[U ] Tapeutil" og Enter.
SLN316530_en_US__19Veeam 19

Skriv inn 1 for "[ 1 ] åpne en enhet" og skriv inn.
SLN316530_en_US__20Veeam 20

Fortsett med Enter.
SLN316530_en_US__21Veeam 21

Fortsett med Enter.
SLN316530_en_US__22Veeam 22

Fortsett med Enter.
SLN316530_en_US__23Veeam 23

Enheten ble åpnet, fortsett med Enter.
SLN316530_en_US__24Veeam 24

Skriv inn 28 for "[ 28 ] Slett" og skriv inn.
SLN316530_en_US__25Veeam 25

Slettingsprosessen startes.

Merk: slettingsprosessen (det er en "lang slette") tar flere timer. Det kan avbrytes ved å tilbakestille stasjonen (trykke på utkastknappen i minst 15 sekunder), båndet kan brukes uten problemer etter lasting av Veeam.

Hvis du får følgende melding når du starter sletteprosessen:Utfør følgende trinn,
SLN316530_en_US__26Veeam 26

og prøv deretter å starte sletteprosessen på nytt:
  1. Kontroller om tapen faktisk er satt i stasjonen, og last den inn igjen om nødvendig.
  2. Last ut/last inn båndet.
  3. Start systemet på nytt.

Følgende virkemåte er fortsatt uklar:
  1. Bånd som tidligere er skrevet med Veeam ved hjelp av IBM-driveren, gjenkjennes av ITDT som skrivebeskyttet når du bruker Microsoft-driveren. Etter sletting, som beskrevet ovenfor, er de normalt brukbare.
  2. Hvis IBM Tapedriver er installert, er det noen ganger ikke mulig å opp- eller nedgradere PERC-fastvaren ('ingen støttet enhet funnet'). I noen tilfeller er det mulig å oppgradere/nedgradere etter en omstart, men noen ganger bare etter at LTO-disken er fysisk koblet fra kontrolleren.
  3. Hvis IBM Tapedriver er installert, er det delvis umulig å opp- / nedgradere LTO-fastvaren. Noen ganger er dette mulig etter en omstart, i noen tilfeller bare etter oppgradering eller nedgradering av PERC-fastvaren eller bytte til Microsoft-driveren.

Affected Products

Dell EMC ML3, PowerVault 124T, Powervault LTO6, PowerVault ML6000, PowerVault TL2000, PowerVault TL4000, PowerVault TL1000
Article Properties
Article Number: 000144804
Article Type: Solution
Last Modified: 07 Oct 2022
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.