Jak korzystać z rozwiązania Veeam z napędami taśmowymi i sterownikiem Microsoft LTO w systemie Windows 2012/2012R2

Summary: Jak korzystać z rozwiązania Veeam z napędami taśmowymi i sterownikiem Microsoft LTO w systemie Windows 2012/2012R2.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Sporadyczne napędy taśmowe LTO przechodziły w tryb offline za pomocą rozwiązania Veeam na kontrolerze PERC H330 ze sterownikiem IBM.

Cause

Jako możliwe rozwiązanie problemów z używaniem rozwiązań Veeam z napędami taśmowymi LTO na kontrolerze PERC H330 i używaniem sterownika IBM wymaganego przez VEEAM przetestowaliśmy użycie sterownika LTO skrzynki odbiorczej firmy Microsoft. Jest to obejście, które zostało pomyślnie przetestowane w naszym laboratorium z określonymi wersjami sprzętu i oprogramowania. Jednak ze względu na wiele możliwych kombinacji sprzętu i oprogramowania, nie możemy zagwarantować, że rozwiązanie sprawdzi się we wszystkich środowiskach:

Resolution

Środowisko testowe:

- Power Edge T430 z kartą PERC H330 i napędem
taśmowym LTO 6 — Windows 2012R2 ze wszystkimi poprawkami (na dzień 06/2016)
— Veeam Backup&Replication 9.0.0.1491
— przetestowane oprogramowanie wewnętrzne PERC H330: 25.3.0.0016; 25.4.0.0017; 25.4.1.0004
— przetestowany sterownik PERC: 6.603.07.00

W tym scenariuszu 3 taśmy LTO zostały zapisane przy użyciu rozwiązania Veeam z następującymi poziomami oprogramowania wewnętrznego/sterowników o różnych rozmiarach bloków (64 kB, 128 kB, 256 kB):

oprogramowanie wewnętrzne kontrolera PERC H330: 25.3.0.0016
— sterownik PERC H330: 6.603.07.00
- Sterownik taśm IBM: 6.2.5.6
- Oprogramowanie wewnętrzne LTO6: F9A1

Zapisane taśmy zostały zweryfikowane przez odzyskiwanie plików.
Następnie sterownik IBM został zastąpiony aktualnym sterownikiem skrzynki odbiorczej Microsoft z systemu Windows 2012R2 zgodnie z poniższym opisem:

Początkowo zainstalowany sterownik (6.2.5.6) został odinstalowany za pomocą "uninst.exe" z pakietu sterownika IBM:


SLN316530_en_US__1Veeam 01 SLN316530_en_US__2Veeam 02
SLN316530_en_US__3Veeam 03




SLN316530_en_US__5Veeam 05 SLN316530_en_US__4Veeam 04
Po kolejnym ponownym uruchomieniu napęd LTO jest wyświetlany z żółtym wykrzyknikiem.
SLN316530_en_US__6Veeam 06

Teraz sterownik Microsoft musi zostać zainstalowany ręcznie:
SLN316530_en_US__11Veeam 11

SLN316530_en_US__9Veeam 09 SLN316530_en_US__8Veeam 08




SLN316530_en_US__7Veeam 07 SLN316530_en_US__10Veeam 10


Po kolejnym ponownym uruchomieniu napęd powinien być teraz wyświetlany jako napęd taśmowy LTO, zainstalowany sterownik jest teraz sterownikiem Microsoft.
Wersja: 6.3.9600.16384
SLN316530_en_US__12Veeam 12



SLN316530_en_US__13Veeam 13 SLN316530_en_US__14Veeam 14

Następnie zinwentaryzowano nośnik napisany wcześniej za pomocą Veeam i sterownika IBM:

SLN316530_en_US__15Veeam 15 SLN316530_en_US__16Veeam 16


Wykonano to ze wszystkimi 3 wcześniej zapisanymi nośnikami (rozmiar bloku 64 kB, 128 kB i 256 kB).
Na początku każdy nośnik został użyty do przywrócenia 1 pliku metody testowej, a następnie wykonano kolejną kopię zapasową na odpowiednim nośniku. Nie było żadnych problemów / problemów.
W dalszych testach udało się ustalić zachowanie Veeam ze sterownikiem Microsoftu:
  1. Taśmy wcześniej opisane w tej instalacji Veaam można było inwentaryzować bez ograniczeń. Odzyskiwanie danych i dalsze wykorzystywanie ich do kopii zapasowych jest możliwe bez problemów i niezależnie od wielkości bloku. Usunięcie lub sformatowanie taśmy nie było wymagane.
  2. Nowe, nieużywane taśmy można łatwo zinwentaryzować i w pełni wykorzystać do tworzenia kopii zapasowych i dalszego odzyskiwania.
  3. Taśm używanych wcześniej z innymi aplikacjami do tworzenia kopii zapasowych lub narzędziami testowymi, takimi jak ITDT, nie można było inwentaryzować, opisywać, usuwać ani formatować za pomocą rozwiązań Veeam. Było to możliwe dopiero po usunięciu taśmy za pomocą odpowiedniego narzędzia innej firmy (w tym przypadku ITDT). Jednak po usunięciu nośników w ramach Veeam możliwe było nieograniczone użytkowanie.
Problem opisany w punkcie 3 wykazuje następujące zachowanie:
Sama inwentaryzacja jest pozornie bezbłędna, ale dysk nadal będzie wyświetlany jako pusty, więc nie ma możliwości utworzenia kopii zapasowej ani usunięcia tego nośnika. W takim przypadku nośnik musi zostać usunięty za pomocą narzędzia innej firmy, takiego jak ITDT.
Następnie nośnik można łatwo zinwentaryzować i wykorzystać.
Aby usunąć taśmę do dalszego użytku z Veeam przy użyciu narzędzia ITDT, wykonaj następujące czynności:

Uruchom ITDT jako administrator:


SLN316530_en_US__18Veeam 18
SLN316530_en_US__17Veeam 17
Wpisz U dla "[ U ] Tapeutil" i Enter.
SLN316530_en_US__19Veeam 19

Wpisz 1 dla opcji "[ 1 ] Otwórz urządzenie" i Enter.
SLN316530_en_US__20Veeam 20

Kontynuuj za pomocą klawisza Enter.
SLN316530_en_US__21Veeam 21

Kontynuuj za pomocą klawisza Enter.
SLN316530_en_US__22Veeam 22

Kontynuuj za pomocą klawisza Enter.
SLN316530_en_US__23Veeam 23

Urządzenie zostało otwarte, kontynuuj za pomocą klawisza Enter.
SLN316530_en_US__24Veeam 24

Wpisz 28 dla opcji "[ 28 ] Erase" i Enter.
SLN316530_en_US__25Veeam 25

Rozpocznie się proces usuwania.

Uwaga: proces usuwania (jest to "długie wymazywanie") trwa kilka godzin. Można go przerwać, resetując dysk (naciskając przycisk wysuwania przez co najmniej 15 sekund), taśmę można bez problemu wykorzystać po ponownym załadowaniu przez firmę Veeam.

Jeśli podczas rozpoczynania procesu usuwania zostanie wyświetlony następujący komunikat:
SLN316530_en_US__26Veeam 26

Wykonaj następujące czynności, a następnie spróbuj ponownie rozpocząć proces usuwania:
  1. Sprawdź, czy taśma jest rzeczywiście załadowana do napędu i załaduj ją ponownie w razie potrzeby.
  2. Rozładowanie/załadowanie taśmy.
  3. Uruchom ponownie system.

Następujące zachowanie jest nadal niejasne:
  1. Taśmy napisane wcześniej za pomocą rozwiązania Veeam przy użyciu sterownika IBM są rozpoznawane przez ITDT jako tylko do odczytu w przypadku korzystania ze sterownika firmy Microsoft. Po usunięciu, jak opisano powyżej, są one normalnie użyteczne.
  2. Jeśli zainstalowany jest sterownik taśm IBM, czasami nie jest możliwe zwiększenie lub obniżenie wersji oprogramowania wewnętrznego PERC ("no supported device found"). W niektórych przypadkach możliwe jest uaktualnienie/przywrócenie wersji po ponownym uruchomieniu, ale czasami dopiero po fizycznym odłączeniu napędu LTO od kontrolera.
  3. Jeśli zainstalowany jest sterownik taśm IBM, zwiększenie lub obniżenie wersji oprogramowania wewnętrznego napędu LTO jest częściowo niemożliwe. Czasami jest to możliwe po ponownym uruchomieniu, a w niektórych przypadkach dopiero po uaktualnieniu lub obniżeniu wersji oprogramowania wewnętrznego PERC lub przełączeniu na sterownik Microsoft.

Affected Products

Dell EMC ML3, PowerVault 124T, Powervault LTO6, PowerVault ML6000, PowerVault TL2000, PowerVault TL4000, PowerVault TL1000
Article Properties
Article Number: 000144804
Article Type: Solution
Last Modified: 07 Oct 2022
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.