RecoverPoint for Vms : La mise à niveau à partir de la version 5.3.0.x ou 5.3.1.0 peut cesser de répondre à 11 % ou 84 %

Summary: La mise à niveau à partir de RecoverPoint for VMs 5.3.0.x ou 5.3.1.0 peut échouer avec l’erreur suivante : « Error: Upgrade had failed. Si la mise à niveau continue d’échouer, contactez le support client. vRPA n’est pas en place" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Il existe plusieurs symptômes différents possibles à partir de la même cause profonde :

Symptôme 1 :
La mise à niveau du paquet Debian n’a pas abouti, même si les journaux d’installation dis-le qu’elle a réussi.

Symptôme 2 :
le service Tomcat ne s’est pas déclenché après le redémarrage.

Symptôme 3 :
un ou plusieurs des messages suivants s’affichent dans les journaux clusterLogic de RPA1 ou RPA2 :

ERROR - Failed to connect to vRPA with IP <IP>.
com.sun.xml.ws.client.ClientTransportException: HTTP transport error: java.net.ConnectException: Connection refused (Connection refused)
ERROR - UpgradeRemoteRPATask :Task failed: Upgrading vRPA number <RPA NUMBER>.
com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: vRPA <IP> is not up.

Symptôme 4 :
les messages suivants s’affichent dans l’interface utilisateur :

The error seen in UI is "Error: Upgrade had failed. If upgrade keeps failing, contact customer support. vRPA <IP> is not up"

 

Cause

Lors de la mise à niveau de la RPA, les packages Debian (fichiers .deb) sont installés et un redémarrage est effectué.
L’installation du package s’exécute en arrière-plan et peut être abandonnée par le redémarrage à l’étape suivante de la mise à niveau.
Étant donné que le programme d’installation est arrêté avant la fin, il se peut que tomcat8.service ne soit pas disponible dans le répertoire systemd, ce qui entraîne l’échec du redémarrage de tomcat8 et rend la RPA inaccessible.

 

Resolution

Solution de contournement préventive :
Connectez-vous en tant qu’utilisateur administrateur à chaque RPA avant la mise à niveau et exécutez le script signé suivant ([2] Configuration -> [8] Options avancées -> [4] Exécuter le script

OTBkOWY0ZDA1MjMxODMxNWM2NTJkMjZjOGYyM2E1MWQKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk
ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOlJQLTMxNzE4CkFkZHMgc2xlZXAgdG8gYWxsb3cgdXBn
cmFkZSB0byBjb21wbGV0ZQpBc3NpZiBIYWwKVkVSU0lPTj0kKGdyZXAgdF92ZXJzaW9uX2Z1bGwg
L2hvbWUva29zL2tib3gvc3JjL2luaXRpYWxpemF0aW9uL3R3ZWFrX3BhcmFtcy90d2Vhay5wYXJh
bXMudmVyc2lvbnxncmVwIC1vICJbMS05XS4qWzAtOV0iKQpNQUpPUlZFUlNJT049JChlY2hvICIk
VkVSU0lPTiJ8YXdrIC1GICIuIiAne3ByaW50ICQxfScpCk1JTk9SVkVSU0lPTj0kKGVjaG8gIiRW
RVJTSU9OInxhd2sgLUYgIi4iICd7cHJpbnQgJDJ9JykKU1BWRVJTSU9OPSQoZWNobyAiJFZFUlNJ
T04ifGF3ayAtRiAiLiIgJ3twcmludCAkM30nKQpQQVRDSFZFUlNJT049JChlY2hvICIkVkVSU0lP
TiJ8YXdrIC1GICIuIiAne3ByaW50ICQ0fScpCmlmIChbICRNQUpPUlZFUlNJT04gLWVxIDUgXSAm
JiBbICRNSU5PUlZFUlNJT04gLWVxIDMgXSAmJiBbICRTUFZFUlNJT04gLWVxIDAgXSkgfHwgKFsg
JE1BSk9SVkVSU0lPTiAtZXEgNSBdICYmIFsgJE1JTk9SVkVSU0lPTiAtZXEgMyBdICYmIFsgJFNQ
VkVSU0lPTiAtZXEgMSBdICYmIFsgJFBBVENIVkVSU0lPTiAtZXEgMCBdKTsKCXRoZW4KCQlpZiBb
IGBncmVwICJzbGVlcCA2MDAiIC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJp
YnV0aW9uL2lzb19zZXJ2aWNlcy5zaHx3YyAtbGAgLWVxIDAgXTsKCQkJdGhlbgoJCQkJc2VkIC1p
ICcxODYgaSBzbGVlcCA2MDAnIC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJp
YnV0aW9uL2lzb19zZXJ2aWNlcy5zaAoJCQkJc2VkIC1pICJzL3NsZWVwIDYwMC8gICBzbGVlcCA2
MDAvIiAvaG9tZS9rb3Mva2JveC9zcmMvaW5zdGFsbGF0aW9uL2Rpc3RyaWJ1dGlvbi9pc29fc2Vy
dmljZXMuc2gKCQkJCWVjaG8gIkNoYW5nZXMgYXBwbGllZCBzdWNjZXNzZnVsbHkgdG8gaXNvX3Nl
cnZpY2VzLnNoLiIKCQllbHNlCgkJCWVjaG8gIlZhbHVlIGFscmVhZHkgYWRkZWQuIE5vIGNoYW5n
ZXMgbWFkZS4iCgkJZmkKZWxzZQoJZWNobyAiTm8gbmVlZCB0byBydW4gdGhpcyBzY3JpcHQgb24g
dGhpcyB2ZXJzaW9uLiBObyBjaGFuZ2VzIG1hZGUuIgpmaQo=
#

Résolution:
Ce problème est résolu dans RecoverPoint 5.3 SP1 Patch 1 et versions de code ultérieures.
La mise à niveau à partir de 5.3 SP1 P1 et versions ultérieures devrait empêcher le problème de se produire.

 

Additional Information

Note:
Pour plus d’informations, consultez le numéro de défaut Jira RP-31718. L’accès à Jira est uniquement disponible pour les représentants du service client autorisés.

 

Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000182751
Article Type: Solution
Last Modified: 20 Jan 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.