Skip to main content
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

No Video Over USB Type-C Cable with Wyse 5470 MTC

Summary: This article details how to resolve the symptom of video not being displayed over a USB-C cable when connected to a Wyse 5470 MTC computer.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Wyse 5470 MTC
  • C2422HE - DelI 24 Video Conferencing Monitor
  • C2722DE - Dell 27 Video Conferencing Monitor
  • C3422WE - Dell 34 Curved Video Conferencing Monitor
  • P2422H - Dell 24 Monitor
  • P2422HE - Dell 24 USB-C Hub Monitor
  • U2422H - Dell UltraSharp 24 Monitor
  • U2422HE - Dell UltraSharp 24 USB-C Hub Monitor
  • U2722D - Dell UltraSharp 27 Monitor
  • U2722DE - Dell UltraSharp 27 USB-C Hub Monitor

Video may not display when using a USB Type C cable for a video connection, even if video is displayed from the same computer when using an HDMI or DP connection.

Cause

The root cause is related to the Cypress PD FW, which does not support non-DDM Type C cables.

Resolution

There are two ways to recover this issue:

  • Change cable from Type C cable to HDMI or DP cable.
  • Update the BIOS.
    1. Disconnect any USB Type C device that is connected to the Wyse 5470.
    2. Download the latest BIOS .exe file.
  1. Copy the file Wyse_5470_[VERSION].exe to FAT32 formatted USB storage.
  2. Plug in the USB storage to the Wyse 5470.
  3. Power the Wyse 5470 on and tap the F12 key until the one-time boot.
  4. Select BIOS Flash Update and then press the Enter key to start the BIOS update process.
Note:

Affected Products

Dell 24 Video Conferencing Monitor C2422HE, Dell 27 Video Conferencing Monitor C2722DE, Dell 34 Video Conferencing Curved Monitor C3422WE, Dell P2422H, Dell P2422HE, Dell U2422H, Dell U2422HE, Dell U2722D, Dell U2722DE, Wyse 5470
Article Properties
Article Number: 000195608
Article Type: Solution
Last Modified: 10 Jan 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.