Article Number: 498592

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SourceOne Discovery Manager: Discovery Manager search for canonical address of deleted users fails with Index error.

Summary: Discovery Manager search for canonical address of deleted users fails with Index error.

Primary Product: SourceOne Discovery Manager

Product: SourceOne Discovery Manager more...

Last Published: 20 Mar 2020

Article Type: Break Fix

Published Status: Online

Version: 7

SourceOne Discovery Manager: Discovery Manager search for canonical address of deleted users fails with Index error.

Article Content

Issue


Searching in Discovery Manager for a deleted users email address fails on particular index sets.
The search is configured adding the "Sender or Recipient" field and adding the Deleted user canonical address directly into the field since it is not available in the Active Directory and cannot be selected in the Address book menu.
Creating Identities in Discovery Manager triggers the same issue.

During the search some errors are logged in the Discovery Manager search pane:

"Error Detail: 03:(legal hold - dm_Matter#3160#A5E637CE_015) (156 / 21765) Search results may be incomplete, internal ISYS Error: (0) (), index '\\share\index$\Native_Archive_Legal\legal hold - dm\Matter#3160#A5E637CE\015'. (0x86042D1C)

The search continues despite the error but will stop if it reaches 500 errors.

The following is generated in the ExAsSrch.exe.log trace log for a specific index set:

CSrchObj::PerformQuery
ERROR System call failed. (0x86040100)
Not enough storage is available to process this command.  (0x80070008)|IndexApi.cpp(402)|Job Id: -1; Activity Name: ServerName; Activity Id: -1; Activity Type: -1; ServerName


The following errors are generated in the ExJBQueryDC.exe.log:

CoExGWQuery::GetHits
INFO Query has errors, continuing search. Hit packet status code = 3|CoExGWQuery.cpp(466)|Job Id: 26966438; Activity Name: DM_Search_3_14_2017_4_18_10_122218; Activity Id: 183911; Activity Type: 31; ServerName


CExSearchQueryThread::ProcessSearchResults
VERBOSE
Error in Packet: ServerVer: 6 CallStatus: 3 StatusStr: '03:(legal hold - dm_Matter#3160#A5E637CE_015) (156 / 21765) Search results may be incomplete, internal ISYS Error: (0) (), index '\\share\Index$\Native_Archive_Legal\legal hold - dm\Matter#3160#A5E637CE\015'. (0x86042D1C)' JanusFldr: '' Flags: 0 Hits: 0 Bytes: 0|ExSearchQueryThread.cpp(347)|Job Id: 26966438; Activity Name: DM_Search_3_14_2017_4_18_10_122218; Activity Id: 183911; Activity Type: 31; ServerName


CExSearchStatusTableDC::InsertErrInfo
VERBOSE
Error XML : <?xml version="1.0" encoding="utf-16"?>  <!--by EMC-->  <Errors xmlns:dt="urn:schemas-microsoft-com:datatypes">      <Version>1.0</Version>      <Error Type="EX_TASK_ERROR_INDEXER" ID="-2046541559" Value="Error Detail: 03:(legal hold - dm_Matter#3160#A5E637CE_015) (156 / 21765)
Search results may be incomplete, internal ISYS Error: (0) (), index '\\share\Index$\Native_Archive_Legal\legal hold - dm\Matter#3160#A5E637CE\015'. (0x86042D1C) (0x86044109)">      </Error>  </Errors>  |ExSearchStatusTableDC.cpp(214)|Job Id: 26966438; Activity Name: DM_Search_3_14_2017_4_18_10_122218; Activity Id: 183911; Activity Type: 31; ServerName


CExCloseQueryThread::WaitUntilCompleted
ERROR
thread handle timed out|CoExAsQuery.h(369)|Job Id: 26966438; Activity Name: DM_Search_3_14_2017_4_18_10_122218; Activity Id: 183911; Activity Type: 31; ServerName

CExCloseQueryThread::End
ERROR
Unable to stop worker thread %1.  Error: %2!x! (0x86042C1D)|CoExAsQuery.h(303)|Job Id: 26966438; Activity Name: DM_Search_3_14_2017_4_18_10_122218; Activity Id: 183911; Activity Type: 31; ServerName
Cause
When a user adds a canonical address in an Address field, it creates a complex ISYS query which causes the ExAsSrch  process to consume more memory and processing power.
This alone is not a problem but the you may be affected by this if you have and unusually big ISYS indexes over 1GB in size.

Both factors causes the ExAsSrch to trigger an internal ISYS error when searching in those big indexes.
 
Resolution
Resolution 1:
When searching for deleted users emails, it is not necessary to search for the canonical address. The same results can be obtained searching the for the CN or for the Display name of the user either specifying them in a Identity or directly in the address fields.

For example, emails belonging to the user "Smith, Bob"</o=Organization/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients/cn=Test>  can be searched with the following terms in the "Sender or Recipients" field:
  • ="Smith, Bob"
  • test

To know more about the different options available, check the section Methods to specify addresses in search fields in the Discovery Manager Desktop User guide.

Resolution 2:
  1. Create a dummy user in Exchange to represent the deleted user.
  2. Edit Email Address in Exchange administrator.
  3. Add the SMTP  and/or  X.500 addresses of the deleted user. For example, you can add a X.500 address like /o=first organization/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients cn=4deea4fbcf2b646028c71230c19e5de5cd-Bob
  4. Wait for the Active Directory to synchronize.
  5. Create a new search in Discovery Manager and add the "Sender or Recipients" field, then select the user from the Address list.
  6. Perform the search.
Notes

Issue


Searching in Discovery Manager for a deleted users email address fails on particular index sets.
The search is configured adding the "Sender or Recipient" field and adding the Deleted user canonical address directly into the field since it is not available in the Active Directory and cannot be selected in the Address book menu.
Creating Identities in Discovery Manager triggers the same issue.

During the search some errors are logged in the Discovery Manager search pane:

"Error Detail: 03:(legal hold - dm_Matter#3160#A5E637CE_015) (156 / 21765) Search results may be incomplete, internal ISYS Error: (0) (), index '\\share\index$\Native_Archive_Legal\legal hold - dm\Matter#3160#A5E637CE\015'. (0x86042D1C)

The search continues despite the error but will stop if it reaches 500 errors.

The following is generated in the ExAsSrch.exe.log trace log for a specific index set:

CSrchObj::PerformQuery
ERROR System call failed. (0x86040100)
Not enough storage is available to process this command.  (0x80070008)|IndexApi.cpp(402)|Job Id: -1; Activity Name: ServerName; Activity Id: -1; Activity Type: -1; ServerName


The following errors are generated in the ExJBQueryDC.exe.log:

CoExGWQuery::GetHits
INFO Query has errors, continuing search. Hit packet status code = 3|CoExGWQuery.cpp(466)|Job Id: 26966438; Activity Name: DM_Search_3_14_2017_4_18_10_122218; Activity Id: 183911; Activity Type: 31; ServerName


CExSearchQueryThread::ProcessSearchResults
VERBOSE
Error in Packet: ServerVer: 6 CallStatus: 3 StatusStr: '03:(legal hold - dm_Matter#3160#A5E637CE_015) (156 / 21765) Search results may be incomplete, internal ISYS Error: (0) (), index '\\share\Index$\Native_Archive_Legal\legal hold - dm\Matter#3160#A5E637CE\015'. (0x86042D1C)' JanusFldr: '' Flags: 0 Hits: 0 Bytes: 0|ExSearchQueryThread.cpp(347)|Job Id: 26966438; Activity Name: DM_Search_3_14_2017_4_18_10_122218; Activity Id: 183911; Activity Type: 31; ServerName


CExSearchStatusTableDC::InsertErrInfo
VERBOSE
Error XML : <?xml version="1.0" encoding="utf-16"?>  <!--by EMC-->  <Errors xmlns:dt="urn:schemas-microsoft-com:datatypes">      <Version>1.0</Version>      <Error Type="EX_TASK_ERROR_INDEXER" ID="-2046541559" Value="Error Detail: 03:(legal hold - dm_Matter#3160#A5E637CE_015) (156 / 21765)
Search results may be incomplete, internal ISYS Error: (0) (), index '\\share\Index$\Native_Archive_Legal\legal hold - dm\Matter#3160#A5E637CE\015'. (0x86042D1C) (0x86044109)">      </Error>  </Errors>  |ExSearchStatusTableDC.cpp(214)|Job Id: 26966438; Activity Name: DM_Search_3_14_2017_4_18_10_122218; Activity Id: 183911; Activity Type: 31; ServerName


CExCloseQueryThread::WaitUntilCompleted
ERROR
thread handle timed out|CoExAsQuery.h(369)|Job Id: 26966438; Activity Name: DM_Search_3_14_2017_4_18_10_122218; Activity Id: 183911; Activity Type: 31; ServerName

CExCloseQueryThread::End
ERROR
Unable to stop worker thread %1.  Error: %2!x! (0x86042C1D)|CoExAsQuery.h(303)|Job Id: 26966438; Activity Name: DM_Search_3_14_2017_4_18_10_122218; Activity Id: 183911; Activity Type: 31; ServerName
Cause
When a user adds a canonical address in an Address field, it creates a complex ISYS query which causes the ExAsSrch  process to consume more memory and processing power.
This alone is not a problem but the you may be affected by this if you have and unusually big ISYS indexes over 1GB in size.

Both factors causes the ExAsSrch to trigger an internal ISYS error when searching in those big indexes.
 
Resolution

Resolution 1:
When searching for deleted users emails, it is not necessary to search for the canonical address. The same results can be obtained searching the for the CN or for the Display name of the user either specifying them in a Identity or directly in the address fields.

For example, emails belonging to the user "Smith, Bob"</o=Organization/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients/cn=Test>  can be searched with the following terms in the "Sender or Recipients" field:
  • ="Smith, Bob"
  • test

To know more about the different options available, check the section Methods to specify addresses in search fields in the Discovery Manager Desktop User guide.

Resolution 2:
  1. Create a dummy user in Exchange to represent the deleted user.
  2. Edit Email Address in Exchange administrator.
  3. Add the SMTP  and/or  X.500 addresses of the deleted user. For example, you can add a X.500 address like /o=first organization/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients cn=4deea4fbcf2b646028c71230c19e5de5cd-Bob
  4. Wait for the Active Directory to synchronize.
  5. Create a new search in Discovery Manager and add the "Sender or Recipients" field, then select the user from the Address list.
  6. Perform the search.

Notes

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First Published

Tue Apr 18 2017 09:22:38 GMT

First Published

Tue Apr 18 2017 09:22:38 GMT

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