Dell Unity:アップグレード中にプライマリーSPを再起動するとUnityにアクセスできない

Summary: この記事では、アップグレード中にプライマリーSPを再起動すると、Unity Management Servicesにアクセスできなくなる理由について説明します。 (ユーザーが修正可能)

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Symptoms

アップグレード プロセス中にプライマリーSPが再起動します。

コード アップグレード プロセスのプライマリーSPの再起動中に、Unity管理サービスにアクセスできなくなります。

Unity IPはping可能ではなく、Unisphereはロードされません。

データ アクセスには影響しません。

Cause

Unityでは、プライマリーSPが管理サービス(IPアドレス)を処理します
プライマリーSPが再起動すると、管理サービスはセカンダリー(ピア)SPにフェールオーバーされます。

問題1:
セカンダリーSPがプライマリーと同じ管理ネットワークに接続されていない場合、管理サービスのフェールオーバー時にUnity IPにアクセスできなくなります

例:
アップグレード前:
  • SP Aはプライマリー、SP Bはセカンダリー
  • SP Aは、Unisphereにアクセスする管理ネットワークに接続されています。
  • SP Bは、SP Aと同じネットワークに接続されていません。
アップグレード中にSP Aが再起動すると、次のようになります。
  • SP Bがプライマリーになり、SP Aがセカンダリーになります。
  • Management ServiceはSP Bを使用しているため、Unity管理IPにアクセスできません。
問題2:
2つ目の問題は、SP間のフェールオーバーが発生し、新しいSPでMACアドレスをスプーフィングした場合に発生する可能性があります。一部のユーザー環境が新しい「重複した」MACアドレスを取得し、スイッチ ポートへのアクセスをブロックして、アクセスが失われている可能性があります。
 
注:Unity OE 5.3以降では、アップグレード前ヘルス チェック(PUHC)ユーティリティーの新しい拡張機能が導入されています。

この機能拡張により、管理ポートで発生する可能性のある接続の問題がチェックされます。詳細については、Dell Unity: アップグレード前ヘルスチェックが警告付きで完了する: platform::check_management_port_2 (ユーザー修正可能)
Test of the management port configuration indicates there may be a problem with the management port VLAN settings that could cause loss of management functionality during storage processor reboots associated with the upgrade. Some valid network configurations can also make this test fail. Ensure that the alternate management port is properly configured. See KB#000066048 for recommended VLAN management port guidelines. You can safely ignore this warning if there is not a real issue.
PUHC警告のユーザー インターフェイスのスクリーンショット:

新しいPUHC警告のスクリーンショット

この警告メッセージは、UnityアレイがピアSP(ストレージ プロセッサー)の管理ネットワーク接続を確認できなかったことを示します。新しいUnity OE 5.3 PUHCの機能拡張により、ネットワークへのアドレス解決プロトコル(ARP)プローブが開始されます。これは、管理操作がピアSPにフェールオーバーされた場合に、ピアSP上の接続の問題を確認するためです。

PUHC は、標準の ARP ping の代わりに ARP プローブを送信します。管理IPアドレスは、プライマリーSPでのみアクティブであり、ピアではアクティブではありません。これが、チェックがピアの ARP プローブである必要がある理由です。非プライマリー(ピア)SPには、標準ARP用に構成されたIPアドレスがありません。したがって、ARP 要求は 0.0.0.0 が入力された状態で送信する必要があり、ARP プローブです

警告メッセージは、ARP プローブから応答が受信されない場合に発生します

この警告は、アップグレード前に1つのSP管理ポートのポート リンクがダウンしていたことを意味するものではありません。それが問題である場合は、アップグレード前ヘルスチェックで検出されます(Dellの記事「Dell Unity: ヘルス チェックが「[Error code: platform::check_peer_management_port_link_2] (User Correctable)」で失敗する

Resolution

アップグレード前のPUHC中:
次の警告メッセージは、障害ではなくソフト警告です。
Warning Code: platform::check_management_port_2
次の記事のいずれかのオプションを使用して、管理操作をピアSPにフェールオーバーし、ピアSPがネットワークに接続されているかどうかをテストします。Dell Unity: 管理サービス(ECOM)フェールオーバーの実行方法(Dell修正可能

この記事に関する追加オプションとして、現在のプライマリーSPを再起動して、管理操作をピアSPにフェールオーバーします。フェールオーバー プロセス中に、管理操作が最大10分失われる可能性があります。管理操作がリカバリーされたら、ピアSPがプライマリーSPになっていることを確認します。フェールオーバー テスト後にSPAとSPBで管理操作が正常に動作している場合、この警告メッセージは無視しても問題ありません

アップグレード中:
アップグレードの途中まで表示されなかった場合、この警告は無視してかまいません。[Retry]ボタンをクリックしてアップグレードを続行します。  

[再試行]ボタンが機能しない場合は、Dellサポートに連絡して、このナレッジベース記事を見積もります

アップグレードが正常に完了すると、次のようになります
以下の警告
Warning Code: platform::check_management_port_2
Unity OE 5.3以降へのアップグレードが正常に完了した後にこの警告メッセージが表示された場合は、無視しても問題ありません。

Additional Information

このKBは、アップグレードだけでなく、すべてのプライマリーSPの再起動に適用されます。

問題の例: 
  • あるケースでは、1つのSPが管理ネットワークに接続され、もう1つのSPの管理ケーブルがiSCSIスイッチに接続されていました。
  • 別のケースでは、1つのSPが管理ネットワークに接続され、もう1つのSPの管理ケーブルが異なるVLAN経由で別のネットワークに接続されているスイッチ ポートに接続されていました。
Unity OEバージョン5.3の時点で、この状態をチェックするための新しいテストは、アップグレード前ヘルス チェック(PUHC)ユーティリティーの一部です。  このテストでは、プライマリSPとセカンダリSPの両方をチェックします。  新しいテスト(ポートがダウンしていないか確認する現在のテストとは異なる)は、「arp ping」(arping)ユーティリティーを使用して、インターフェイスがインターフェイスを介してアドレス解決プロトコル(ARP)トラフィックを許可するかどうかをテストします。  通常、スイッチはVLAN間のARPブロードキャストをブロックするように構成されているため、ほとんどの場合、このテストは、管理ポートのVLANが正しく構成されているかどうかを判断するために信頼性が高いことになります。  スイッチがVLAN間でブロードキャストを許可するように構成されている場合、このテストでは偽陰性が発生する可能性があります。また、VLAN内でもブロードキャストが無効になっている場合、このテストでは誤検出が発生する可能性があります。  しかし、ほとんどの場合、通常の条件下では、この新しいテストによって、管理ポートがVLANで適切に構成されているかどうかを判断します。

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
Article Properties
Article Number: 000066048
Article Type: Solution
Last Modified: 21 Jun 2024
Version:  8
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