Авамар: Помилка VSS Backup з помилкою 32 для EFIMicrosoftBootBCD через проблему з доступом до файлів

Summary: Усуньте збої резервного копіювання Avamar Volume Shadow Copy Service (VSS) із розділами EFI та кодом помилки 32 за допомогою виправлення на основі версії плагіна Avamar VSS.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Спостерігаються такі симптоми:

  • Резервне копіювання Avamar Windows VSS повне з винятками:
[avtar] direlem error:init_ntfs_hardlink: Open file for hardlink information failed 
"\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD", LastError=32 
(code 32: The process cannot access the file because it is being used by another process)

  • Процес avtar показує таку помилку:
avtar Error <5139>: File access share error "\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD" 
(code 32: The process cannot access the file because it is being used by another process).

  • Додавання наведеного нижче прапорця до файлу avtar.cmd має вирішити проблему:
--x31=268435456
  • У деяких випадках проблема не зникає, і з'являється нова помилка:
2024-11-04 21:15:17 avtar Info <5008>: Logging to C:\Program Files\avs\var\TXT_Daily_2030_8hrs-Test_Plantsec02-1730773800009#2-3015-VSS.log
2024-11-04 21:15:17 avtar Info <5174>: - Reading C:\Program Files\avs\var\avtar.cmd
2024/11/05-03:15:17.86100 [avtar]  uflags::parsefile  Printing flags from C:\Program Files\avs\var\avtar.cmd:
.cmd flag [1]: --x31=268435456
.cmd flag [2]: --debug=true

                              xxxxxxxxxxx

  <targetlist>
    <path name="\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\" />
  </targetlist>

               xxxxxxxxxxxxxxxxxxx

2024/11/05-03:15:28.74600 [avtar]  CBackupBCDUtility::exportTmpBCD out (The operation completed successfully.) return (0) bRet (1)
2024/11/05-03:15:28.74600 [avtar]  CBackupBCDUtility::convert2TempBCDPath pathOld(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD)
2024/11/05-03:15:28.74600 [avtar]  filestream::fileopen openBCD convert2new path(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD)
2024-11-04 21:15:28 avtar Error <16507>: Path "\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD": Total processed bytes 24576 is inconsistent with original data size 28672
2024/11/05-03:15:28.85700 [avtar]  ucontainer::base::check_set subsequent error 80 - padded a file with zeros because we were unable to read all data from endfile not being set because we already have this error 0 - success
2024/11/05-03:15:28.85700 [avtar]  upath::parentdir() discarding non-entry element 'HarddiskVolume1'
2024/11/05-03:15:28.85700 [avtar]  upath::parentdir() discarding non-entry element 'Device'
2024/11/05-03:15:28.85700 [avtar]  upath::parentdir() discarding non-entry element 'GLOBALROOT'
2024/11/05-03:15:28.85700 [avtar]  CBackupBCDUtility::isBCDBackupIssue path(\\?\globalroot\device\harddiskvolume1\efi\microsoft\boot\bcd.log) : exit code 32 bRet 1
2024/11/05-03:15:28.85700 [avtar]  CBackupBCDUtility::convert2TempBCDPath pathOld(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD.LOG) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD.LOG)
2024/11/05-03:15:28.85700 [avtar]  filestream::fileopen openBCD convert2new path(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD.LOG) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD.LOG)
  • Така поведінка призводить до резервного копіювання, яке завершується помилками, що згодом призводить до збоїв будь-яких спроб виконати відновлення голих металів (BMR).
  • Вплив на навколишнє середовище: Всі версії плагіна Avamar VSS, а також Windows 2012 і новіші версії, коли налаштовані розділи EFI.

Cause

Цю проблему було визначено як проблему з програмним забезпеченням, що виникає на серверах Microsoft Windows 2012 і пізніших версіях із налаштованими розділами EFI.
 
Застереження: Каталог даних конфігурації завантаження (BCD), зазначений у журналі, не може бути виключений із резервної копії, оскільки він вимагає завантаження в Windows після відновлення BMR.

Для отримання більш детальної інформації перевірте:

https://learn.microsoft.com/en-us/windows/win32/vss/using-vss-automated-system-recovery-for-disaster-recovery?redirectedfrom=MSDN(External Link)

Resolution

Якщо помилка коду 32 виникає під час резервного копіювання плагіна Avamar Windows VSS "EFI\Microsoft\Boot\BCD". 
Переконайтеся, що ви додали прапорець "--x31=268435456" до файлу avtar.cmd та застосували HotFix (HF) відповідно до версії плагіна клієнта.

  • v19.9-100-78 => ВЧ 338870 
  • v19.10-100-135 => Немає доступного ВЧ, оновіться до збірки 166 і застосуйте відповідний ВЧ
  • v19.10-100-166 (SP1) => ВЧ 338885
  • v19.12-100-186 =>ВЧ 338884

Щоб завантажити виправлення зі сторони підтримки Dell, виконайте кроки, описані в Avamar: Як знайти та завантажити поточне виправлення, виправлення, інсталяцію або пакет оновлення продукту з веб-сайту підтримки Dell

Щоб застосувати поточне виправлення, дотримуйтесь інструкцій, наданих службою підтримки Dell за допомогою файлу README, або перегляньте статтю бази знань Dell, щоб дізнатися про конкретне виправлення.

Після застосування поточного виправлення перезапустіть службу плагінів Avamar Windows VSS і спробуйте знову створити резервну копію каталогу "EFI\Microsoft\Boot\BCD".

Переконайтеся, що проблему вирішено, перевіривши журнали Avamar на наявність будь-яких помилок, пов'язаних із каталогом "EFI\Microsoft\Boot\BCD".

Обережність: Якщо після застосування поточного виправлення проблема не зникає, зверніться до служби підтримки Dell за додатковою допомогою.

Affected Products

Avamar Client for Windows

Products

Avamar, Avamar Server, Avamar Virtual Edition
Article Properties
Article Number: 000063956
Article Type: Solution
Last Modified: 06 Aug 2025
Version:  13
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.