Avamar:由于文件访问问题,VSS 备份失败,并显示 EFIMicrosoftBootBCD 错误 32
Summary: 使用基于 Avamar VSS 插件程序版本的热修复程序,解决 EFI 分区的 Avamar 卷影拷贝服务 (VSS) 备份失败问题以及错误代码 32。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
观察到以下症状:
- Avamar Windows VSS 备份完成,但出现异常:
[avtar] direlem error:init_ntfs_hardlink: Open file for hardlink information failed
"\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD", LastError=32
(code 32: The process cannot access the file because it is being used by another process)
- avtar 进程显示以下错误:
avtar Error <5139>: File access share error "\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD"
(code 32: The process cannot access the file because it is being used by another process).
- 将以下标记添加到 avtar.cmd 文件应解决此问题:
--x31=268435456
- 在某些情况下,问题仍然存在,并显示新的错误:
2024-11-04 21:15:17 avtar Info <5008>: Logging to C:\Program Files\avs\var\TXT_Daily_2030_8hrs-Test_Plantsec02-1730773800009#2-3015-VSS.log
2024-11-04 21:15:17 avtar Info <5174>: - Reading C:\Program Files\avs\var\avtar.cmd
2024/11/05-03:15:17.86100 [avtar] uflags::parsefile Printing flags from C:\Program Files\avs\var\avtar.cmd:
.cmd flag [1]: --x31=268435456
.cmd flag [2]: --debug=true
xxxxxxxxxxx
<targetlist>
<path name="\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\" />
</targetlist>
xxxxxxxxxxxxxxxxxxx
2024/11/05-03:15:28.74600 [avtar] CBackupBCDUtility::exportTmpBCD out (The operation completed successfully.) return (0) bRet (1)
2024/11/05-03:15:28.74600 [avtar] CBackupBCDUtility::convert2TempBCDPath pathOld(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD)
2024/11/05-03:15:28.74600 [avtar] filestream::fileopen openBCD convert2new path(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD)
2024-11-04 21:15:28 avtar Error <16507>: Path "\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD": Total processed bytes 24576 is inconsistent with original data size 28672
2024/11/05-03:15:28.85700 [avtar] ucontainer::base::check_set subsequent error 80 - padded a file with zeros because we were unable to read all data from endfile not being set because we already have this error 0 - success
2024/11/05-03:15:28.85700 [avtar] upath::parentdir() discarding non-entry element 'HarddiskVolume1'
2024/11/05-03:15:28.85700 [avtar] upath::parentdir() discarding non-entry element 'Device'
2024/11/05-03:15:28.85700 [avtar] upath::parentdir() discarding non-entry element 'GLOBALROOT'
2024/11/05-03:15:28.85700 [avtar] CBackupBCDUtility::isBCDBackupIssue path(\\?\globalroot\device\harddiskvolume1\efi\microsoft\boot\bcd.log) : exit code 32 bRet 1
2024/11/05-03:15:28.85700 [avtar] CBackupBCDUtility::convert2TempBCDPath pathOld(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD.LOG) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD.LOG)
2024/11/05-03:15:28.85700 [avtar] filestream::fileopen openBCD convert2new path(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD.LOG) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD.LOG)
- 此行为会导致备份完成但出现错误,随后导致执行裸机恢复 (BMR) 的任何尝试失败。
- 受影响的环境:配置 EFI 分区时的所有版本的 Avamar VSS 插件程序以及 Windows 2012 及更高版本。
Cause
此问题已确定为配置了 EFI 分区的 Microsoft Windows 2012 服务器及更高版本发生的软件问题。
注意:无法从备份中排除日志中引用的启动配置数据 (BCD) 目录,因为它需要在 BMR 恢复后启动至 Windows。
有关更多详细信息,请查看:
Resolution
如果在 Avamar Windows VSS 插件备份“EFI\Microsoft\Boot\BCD”时遇到代码 32 错误。
确保将标记“--x31=268435456”添加到avtar.cmd文件,并根据客户端插件程序版本应用热修复程序 (HF)。
- v19.9-100-78 => 高频 338870
- v19.10-100-135 => 没有可用的 HF,升级到内部版本 166 并应用相应的 HF
- v19.10-100-166 (SP1) => HF338885
- v19.12-100-186 =>高频 338884
要从戴尔支持端下载热修复程序,请参阅 Avamar:如何从戴尔支持网站查找和下载产品热修复程序包、修补程序、安装包或升级包
要应用热修复程序,请使用自述文件按照戴尔支持提供的说明进行作,或参阅戴尔知识库文章了解特定的热修复程序。
应用热修复程序后,重新启动 Avamar Windows VSS 插件服务,并尝试再次备份“EFI\Microsoft\Boot\BCD”目录。
通过检查 Avamar 日志中是否存在与“EFI\Microsoft\Boot\BCD”目录相关的任何错误,验证问题是否已得到解决。
注意:如果应用热修复程序后问题仍然存在,请联系戴尔支持以获得进一步的帮助。
Affected Products
Avamar Client for WindowsProducts
Avamar, Avamar Server, Avamar Virtual EditionArticle Properties
Article Number: 000063956
Article Type: Solution
Last Modified: 06 Aug 2025
Version: 13
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.