Dell Unity: o comando uemcli não mostra "(3) Aceitar e armazenar", Não é possível armazenar o certificado SSL

Summary: Este artigo descreve as causas e soluções quando a opção [3] no menu sobre certificado não é exibida no comando uemcli. (Corrigível pelo usuário)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Três opções são exibidas ao executar o uemcli até que o certificado seja armazenado.

No entanto, às vezes o menu aparece novamente mesmo que o certificado tenha sido armazenado antes, e o menu Opção [3] não aparece.

Quando isso acontece, a opção [1] deve ser selecionada sempre que o comando for executado.

Exiba quando não houver problemas:

12:03:47 service@<Array Name> spb:~/user> uemcli -no /sys/general show
Remote certificate:
Issuer: CN=<Array Name>
Subject: CN=<Array Name>
Valid from: 2022:02:17:12:08:46
Valid to:   2025:02:16:12:08:46
Serial: xxxxxxxxxxxxxx
Id: xxxxxxxxxxxxxx
Would you like to:
  [1] Accept the certificate for this session
  [2] Reject the certificate
  [3] Accept and store
Please input your selection (The default selection is [1]):

Exiba quando esse evento de problema ocorre:

09:11:08 service@<Array Name> spb:~/user> uemcli -no /sys/general show
Remote certificate:
Issuer: CN=<Array Name>
Subject: CN=<Array Name>
Valid from: 2019:01:15:10:06:10
Valid to: 2022:01:14:10:06:10
Serial: xxxxxxxxxxxxxx
Id: xxxxxxxxxxxxxx
Would you like to:
  [1] Accept the certificate for this session
  [2] Reject the certificate
Please input your selection (The default selection is [1]):
Nota: Execução de uma ferramenta automatizada que incorpore o uemcli O comando do lado do cliente pode não obter os resultados corretos da ferramenta após uma determinada data. Isso ocorre porque o menu acima é exibido antes do resultado de uemcli Executando.

Cause

Isso ocorre quando o certificado SSL expira.

O certificado SSL do Unity expira após três anos, mas é automaticamente regenerado quando a data de expiração se aproxima.

No entanto, devido a um problema de software no Unity OE 5.0.x ou versões anteriores, ele não é automaticamente regenerado e expirado.

Resolution

Esse problema foi resolvido no UnityOE 5.3.0. 


Solução temporária:

Há duas opções para atualizar o certificado:

  • A opção 1 pode ser corrigida pelo usuário. 

Siga o artigo 22509, Dell Unity: Como renovar manualmente um certificado SSL do Unity Management. (Pode ser corrigido pelo usuário.)

  • Opção 2

Se não for preferível renomear temporariamente o sistema Unity, uma solução alternativa poderá ser implementada. Esta solução requer assistência do suporte técnico da Dell. Mencione o número deste artigo ao entrar em contato com o suporte.

Additional Information

Selecione a opção [3] Aceitar e armazenar, e todos os certificados baixados são armazenados na lockbox local segura no sistema client.

O uemcli O comando também opera os certificados na lockbox local do sistema client.

O certificado está definido para expirar após três anos; No entanto, o sistema de armazenamento gera novamente o certificado um mês antes de sua data de expiração.

Consulte o Guia de configuração de segurança da família Unity para obter informações sobre o certificado do sistema de armazenamento.

Affected Products

Dell EMC Unity, Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F

Products

Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F , Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition ...
Article Properties
Article Number: 000196041
Article Type: Solution
Last Modified: 29 May 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.