Data Domain:DD Boostユーザーにロック ステータスが表示される
Summary: この記事では、ddboostユーザーがUIにロック状態を表示する場合の問題について説明します。バックアップが失敗し、バックアップ アプリケーションがストレージ サーバーData Domainとの通信がないと苦情を申し立てます。
Symptoms
確認方法
パスワードの有効期限が切れているか、パスワードの有効期限が切れてから7日以内であることを検出する唯一の方法は、バックアップ アプリケーションからddboostユーザーを使用してDDシステムにSSHで接続することです。
そのため、パスワードの有効期間が期限切れまたは期限切れに近づいていることを確認するのは困難です。
例
ssh ddboost@"testdd.emc.com" Data Domain OS You are required to change your password immediately (password aged) Last login: Thu Apr 21 13:41:18 PDT 2016 from testavamar.emc.com on ssh WARNING: Your password has expired. You must change your password now and login again! Changing password for ddboost. (current) UNIX password:
発生した問題
- ddboostユーザーのステータスは、Web UI System Managerで「locked」になっています。
- Avamar、NetWorker、NetBackupなどのバックアップ アプリケーションでDDへのバックアップに失敗する
- バックアップ アプリケーションがストレージ サーバーData Domainと通信していないと苦情を言う
- このステータスは、左側のメニューの[DD Boost]タブまたは [Access -> Local Users]タブで確認できます


Cause
根本的な原因
ddboostユーザーがロックされる根本原因は、パスワードの有効期限が切れていることにあります。
理由
- 次のコマンドを実行します。
# user password aging show
- ほとんどの場合、[ Maximum Days Between Change] が90に設定されています
- また、Web UIでは、[Access -> Local Users (上図の赤で表示)]で確認できます。

- これは、DDOSを5.6以降にアップグレードした後、Maximum Days Between Changeがデフォルトの90日に設定されているためです
- パスワードの有効期間を90日より長く変更しても、その後のアップグレード(たとえば、6.0から6.1)では、デフォルトの90日に戻されます
Resolution
一時的
ddboostユーザーがロックされると、次のようになります。
-
sysadminユーザー(または管理者ロールを持つ他のユーザー)としてData Domainシステムにログインします。
-
ddboostユーザーを有効にします
# user enable <ddboost-user>
-
ddboostユーザーが有効になっていることを確認します。
# user show list
上記のアクションを実行すると、再びアクセスできるようになり、さらに90日間は問題がなくなります。
解決策
-
90日間のデフォルト値を維持する場合は、90日以内にddboostパスワードを変更するようにリマインダーを設定します。
(DDから変更の警告を受け取る唯一の方法は、パスワードの有効期限が切れてから7日以内にddboostユーザーを使用してシステムにSSHで接続することです)これは実用的ではないかもしれないので、より良い解決策は次のとおりです。
-
DDシステムで「max-days-between-change」の値90をより高い値に変更します。
# user password aging set <affected ddboost user name> max-days-between-change 99999 Example # user password aging set ddboost_user_1 max-days-between-change 99999
# user password aging show
上記の値は、ddboostパスワードを変更する必要がないことを意味します(正確には273年!)。
ただし、任意の長さに変更できます。
その他の情報
上記のアクションを実行してもddboostユーザーを使用してDDにアクセスまたはバックアップできない場合は、バックアップ アプリケーションがDDへのアクセスを複数回試行したためにタイムアウトが発生することがあります。そのため、ddboostアカウントはしばらくの間ロックされたままになります(ログイン試行の失敗回数によって異なります)。タイムアウトが継続的にリセットされないように、DDと通信するバックアップ アプリケーション サービスを停止する必要がある場合があります。
この記事で説明されているアクションを実行しても問題が解決しない場合は、Dellサポートに連絡し、Data Domainサポートでチケットを開いてください。
Additional Information
このコンテンツは、次の言語に翻訳されています。
- https://downloads.dell.com/TranslatedPDF/ES_KB520213.pdf
- https://downloads.dell.com/TranslatedPDF/DE_KB520213.pdf
- https://downloads.dell.com/TranslatedPDF/FR_KB520213.pdf
- https://downloads.dell.com/TranslatedPDF/IT_KB520213.pdf
- https://downloads.dell.com/TranslatedPDF/JA_KB520213.pdf
- https://downloads.dell.com/TranslatedPDF/KO_KB520213.pdf
ユーザーによる強化の詳細
| 説明 | 強化に関する推奨事項 |
|---|---|
| デフォルトのパスワードを変更します。 | sysadminとしてログインし、次のコマンドを実行します。 # user change password |
| 会社のパスワード ポリシーに従って、頻繁なパスワード ローテーションを構成します。 | 会社のパスワード ポリシーに従って、デフォルトのパスワード エージング ポリシーを設定します。# user password aging option set |
| 強力なパスワード ポリシーを構成します。 | ユーザーのパスワード強度ポリシーを設定します。# user password strength setパスワードの推奨事項:
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| さまざまなパスワードエージング要件 | DDでは、CLIユーザー パスワード エージング オプションを推奨しています。デフォルトでは、パスワードポリシーは後方互換性のために緩和されています。お客様はUIまたはCLIを使用してパスワード構成を変更し、より制限が厳しく、経過要件を満たしているようにすることができます。
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| さまざまなパスワード強度要件 | DDは包括的なパスワード ポリシーをサポートしており、CLIまたはUIを使用してパスワードを強化することを推奨しています。アカウントのパスワード ポリシーの特性と複雑さを、アプリケーション コード内で必要なものに設定または変更します。要件の詳細については、パスワード ポリシーを参照してください。
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