Skip to main content

Dell Active Pen is not Listed in the Dell Display and Peripheral Manager

Summary: This article provides information about the missing Dell active pen option in the Dell Display and Peripheral Manager (DDPM).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Pro Premium Active Pen PN5122W
  • Dell Pro Premium Active Pen PN7522W

Affected Platforms:

  • Dell 14 Plus DB14250
  • Dell 16 Plus DB16250
  • Dell 14 Plus 2-in-1 DB04250
  • Dell 16 Plus 2-in-1 DB06250
  • Dell 14 Plus 2-in-1 DB04255
  • Inspiron 14 7440 2-in-1
  • Inspiron 14 7445 2-in-1
  • Inspiron 14 7430 2-in-1
  • Inspiron 16 7630 2-in-1
  • Inspiron 14 7435 2-in-1
  • Inspiron 16 7635 2-in-1

A Dell Active pen cannot be added in the Dell Peripheral Manager application because the Pen icon is missing.

Add Device

No Device found

Cause

Driver-related issue

Resolution

The engineering department is working on a fix to be released in DDPM that eliminates having to install the Dell Active pen driver separately. The update to DDPM will be posted to the computer's support page once it is made available. ETA for release is February 2026.

Updating the Dell Active pen driver to version A00-00 or later on the computer resolves the issue. Reference How to Download and Install Dell Drivers for instructions on downloading and installing the driver.

Affected Products

Dell Pro Plus Active Pen PN5122W, Dell Pro Premium Active Pen PN7522W, Dell 14 Plus 2-in-1 DB04250, Dell 14 Plus 2-in-1 DB04255, Dell 16 Plus 2-in-1 DB06250, Dell 14 Plus DB14250, Dell 16 Plus DB16250, Inspiron 14 7430 2-in-1, Inspiron 14 7435 2-in-1 , Inspiron 14 7440 2-in-1, Inspiron 14 7445 2-in-1, Inspiron 16 7630 2-in-1, Inspiron 16 7635 2-in-1 ...
Article Properties
Article Number: 000325971
Article Type: Solution
Last Modified: 24 Sept 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.