Připojení SSH do systému Data Domain ze serveru Avamar selže s chybou ssh_exchange_identification

Summary: Přihlášení SSH do Data Domain selže kvůli seznamu přístupu správce.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Omezení přístupu správce nastavená v systému Data Domain, která nezahrnují IP adresu systému Avamar. To způsobuje problémy s přístupem a může způsobit, že systém Data Domain v uživatelském rozhraní správce Avamar nereaguje. 

Přihlášení SSH do systému Data Domain ze systému Avamar selže (pomocí libovolného účtu, například sysadmin nebo ddboost):

admin@test-avamar:~/#:  ssh ddboostuser@dd-názevhostitele-odstraněno

ssh_exchange_identification: číst: Resetování připojení pomocí partnera

Nebo

admin@test-avamar:~/#:  ssh ddboostuser@dd-názevhostitele-odstraněno
ssh_exchange_identification: Připojení bylo ukončeno vzdáleným hostitelem

Test připojení serveru Avamar k portu 22 systému Data Domain nevykazuje žádné problémy:

telnet dd-název-hostitele-odstraněno 22

Zkouším 10.10.10.23...
Připojeno k dd-hostname-removed.
Řídicí znak je '^]'.
^]
telnet>
q
Spojení uzavřeno.

Přihlášení do Data Domain pomocí SSH funguje na jiných počítačích bez problémů. Přihlášení přes SSH selže pouze ze serveru Avamar.

Cause

Systémy Data Domain obsahují seznam přístupu správce, který může omezit určité protokoly na základě IP adresy nebo názvu hostitele. Pokud jsou tato omezení zavedena, mohou se k systému Data Domain pomocí těchto protokolů připojit pouze IP adresy / název hostitele uvedené v poli Povolení hostitelé. 

Příklad 1:


AdminAccess Show
Service Enabled Allowed Hosts
------- ------- -------------
ssh ano 10.0.0.1
scp ano (stejné jako ssh)
telnet ne
10.0.0.1
ftp ne 10.0.0.1
ftps ano 10.0.0.1
http ano -
https ano -
------- ------- -------------

Ve výše uvedeném výstupu je protokol SSH omezen na povolenou pouze IP adresu 10.0.0.1. 

Příklad 2:

adminaccess show

Service Enabled Allowed Hosts
----------- ------- ---------------------------
ssh yes testbox1.corp.dellemc.local
testbox2.corp.dellemc.local
testbox3.corp.dellemc.local
scp no (stejné jako ssh)
...
webová služba ano N/A
----------- ------- ---------------------------


Ve výše uvedeném výstupu je přístup přes ssh omezen na 3 hostitele: testbox1, testbox2, testbox3

Příklad 3:

AdminAccess Show
Service Enabled Allowed Hosts
------- ------- --------------
ssh yes


Výše uvedený výstup ukazuje konfiguraci bez seznamu přístupu (libovolný hostitel se může přihlásit do systému Data Domain pomocí ssh).

Resolution

Přístup správce musí být nakonfigurován tak, aby zahrnoval IP adresu nebo název hostitele Avamar do povolených hostitelů. 

Přihlaste se k systému Data Domain jako účet správce.
 
Přístup správce lze obnovit zpět na výchozí pomocí následujícího příkazu:

adminaccess reset ssh

Výše uvedený příkaz resetuje pravidla ssh adminaccess a povolí připojení ssh z libovolného hostitele.

AdminAccess Show
Service Enabled Allowed Hosts
------- ------- -------------
ssh yes -
scp yes (same as ssh)
telnet no
10.0.0.1
ftp no 10.0.0.1
ftps ano 10.0.0.1
http yes -
https yes -
------- ------- -------------

Pokud přístup SSH nelze resetovat, povolte explicitní přístup SSH ze systému Avamar pomocí následujícího příkazu:

adminaccess ssh add <Avamar IP Address or FQDN>

Ověřte, zda byl správně aktualizován seznam přístupu správce.

AdminAccess Show
Service Enabled Allowed Hosts
------- ------- ---------------------------
ssh ano
10.0.0.1
avamar.emc.com
scp ano (stejné jako ssh)
telnet ne
10.0.0.1
ftp ano 10.0.0.1
ftps ne -
http ano -
https ano -
------- ------- ---------------------------

Tyto kroky lze také provést pomocí webového uživatelského rozhraní Data Domain. 

Pokud problém stále není vyřešen, přečtěte si článek s cestou řešení Odstraňování problémů s chybami hlášení integrace systému Data Domain v uživatelském rozhraní správce Avamar (cesta řešení).
 

Affected Products

Avamar

Products

Avamar, Avamar Server, Data Domain
Article Properties
Article Number: 000041010
Article Type: Solution
Last Modified: 08 Jul 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.