Data Domain - /ddvar의 공간이 부족합니다.

Summary: 이 문서에서는 /ddvar 디렉토리에서 디스크 공간을 확보하는 방법에 대한 단계를 나열합니다. ddvar/ 디렉토리는 로그 파일, 생성된 지원 업로드 번들, 압축된 코어 파일 및 .rpm 업그레이드 패키지가 배치되는 관리 디렉토리입니다. 경우에 따라 이 디렉토리가 꽉 차서 Data Domain 시스템이 알림을 보내도록 트리거할 수 있습니다. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

/ddvar 디렉토리(/ddvar/ 및 /ddr/var/는 서로 바꿔 사용할 수 있음)는 로그 파일, 생성된 지원 업로드 번들, 압축된 코어 파일 및 .rpm 업그레이드 패키지가 배치되는 관리 디렉토리입니다. 경우에 따라 이 디렉토리가 꽉 차서 Data Domain 시스템이 알림을 보내도록 트리거할 수 있습니다.

# alerts show current
Id Post Time Severity Class Object Message
----- ------------------------ -------- ----------------- ------ --------------------------------------------------------------------------
p0-36 Tue Sep 17 17:39:12 2024 ERROR SystemMaintenance System Maintenance Space running low in /ddvar for system maintenance activities
.-----   ------------------------   --------   -----------------   ------   --------------------------------------------------------------------------

해당 레지스트리 항목은 다음과 같습니다.

dynamic.ems.708.1.401.1243325160.1.5 = 시스템 유지 보수 작업을 위한 /ddvar에 공간이 부족합니다.

FS(모든 데이터 액세스를 처리함)를 포함한 일부 프로세스는 로그를 기록하기 위해 /ddvar 파티션에 의존하며, 파티션이 완전히 꽉 차서 쓸 수 없게 되면 FS 프로세스가 결국 제대로 작동하지 않을 수 있으며 결과적으로 더 이상 시작되지 않을 수 있습니다. 따라서 고객이 이러한 경고에 주의를 기울이고 그에 따라 조치를 취하는 것이 매우 중요합니다.

Cause

운영 체제 파티션에 저장된 로그 파일이 너무 많으면 ddvar의 공간이 부족해집니다. core 파일이 (/ddr/var/core/ 또는 /ddr/var/ext/와 같은 별도의 파티션이 아닌) /ddr/var/에 저장되어 있을 때, 이것이 원인일 수도 있습니다. 경우에 따라 SUB가 매우 커서(수 GiB) 고객이 문제 해결을 위해 계속 더 많이 생성하므로 디스크 공간이 빠르게 소모됩니다. 간혹 큰 로그 파일이 순환되지 않거나 이전 문제 해결 작업의 잔여물이 /ddr/var/에서 불필요한 디스크 공간을 차지하는 문제가 있습니다.

Resolution

/ddvar의 공간이 부족합니다.

목적

이 문서에는 에서 디스크 공간을 확보하는 방법에 대한 단계가 나와 있습니다. /ddvar 디렉토리.
ddvar/ directory는 로그 파일, 생성된 지원 업로드 번들, 압축된 코어 파일 및 .rpm 업그레이드 패키지가 배치됩니다. 경우에 따라 이 디렉토리가 꽉 차서 Data Domain 시스템이 알림을 보내도록 트리거할 수 있습니다.
# alerts show current
Id      Post Time                  Severity   Class               Object   Message
-----   ------------------------   --------   -----------------   ------   --------------------------------------------------------------------------
p0-36   Tue Sep 17 17:39:12 2024   ERROR      SystemMaintenance            Space running low in /ddvar for system maintenance activities.
-----   ------------------------   --------   -----------------   ------   --------------------------------------------------------------------------
해당 레지스트리 항목은 다음과 같습니다.
dynamic.ems.708.1.401.1243325160.1.5 = Space running low in /ddvar for system maintenance activities.

 

조짐

  • 알림 "시스템 유지 보수 작업을 위해 /ddvar에 공간이 부족합니다."
  • 알림: "/ddvar에 공간이 부족합니다. 공간을 비우지 않으면 코어 덤프 기능이 비활성화됩니다."
  • 알림: "/ddvar의 공간 부족으로 인해 코어 덤프 기능이 비활성화되었습니다."

적용 대상

  • 모든 Data Domain 시스템
  • 모든 소프트웨어 릴리스

해결책

========== 서버 사용량 ==========
리소스 크기 GiB Used GiB Avail GiB Use%
------------------         --------        --------           ---------      ----
/backup: pre-comp - 17814.5 - -
/ 백업 : post-comp 1892.9 1099.1 793.8 58 %
/ddvar 19.7 14.1 4.6       75%

  1. 확인 /ddvar 공간이 부족합니다.
    Data Domain 시스템 프롬프트 180649 다음을 입력합니다.
    에프에프
  2. /ddvar에 사용된 공간이 일시적으로 증가할 수 있으며Transient /ddvar space usage increases181878 KB에 설명된 대로 일시적인 공간 사용량 알림이 발생할 수 있습니다. 추가 공간을 확보하기 위해 /ddvar의 파일을 정리해야 하는 경우 다음 단계를 계속합니다.
  3. Data Domain 시스템의 호스트 이름IP 주소를 확인합니다.
    hostname
    The Hostname is: support1.emc.local
    
    	
    net lookup
    support1.emc.local has address 192.168.1.52
    	

Datadomain 명령줄[ssh를 통해 연결하는 경우] 및 웹 콘솔[GUI]을 사용하여 \ddvar 폴더의 디스크 공간을 확보합니다.
1. putty
2와 같은 SSH 클라이언트를 사용하여 Data Domain에 액세스합니다. 시스템에 저장된 corefile을 나열합니다(이러한 명령은 모든 DDOS 버전에서 사용할 수 있는 것은 아닙니다).
# support coredump list

to delete specific core file use:

# support coredump delete [corefile.filename]

to delete all of them use:

# support coredump delete all
      
3. 시스템에 저장된 지원 번들 나열
# support bundle list

to delete specific support bundle 

# support bundle delete <bundle-name-list> 

to delete all support bundles

# support bundle delete all

4. Data Domain System Manager 웹 콘솔 인터페이스
에 연결 5. Maintenance > system
6으로 이동합니다. "Data Domain 시스템에서 사용 가능한 업그레이드 패키지" 테이블에서 패키지 파일 이름
7 옆의 확인란을 선택하여 찾을 수 있는 업그레이드 패키지를 선택합니다. "Remove Upgrade Package" 버튼을 클릭합니다. Microsoft Windows 기반 시스템을 사용하여 \ddvar 폴더의 디스크 공간 확보
  1. Data Domain 시스템의 ACL(Access List)이 현재 시스템에서 액세스할 수 있도록 181315 구성되어 있는지 확인합니다.
  2. Data Domain 시스템에서 이전 코어 파일을 삭제합니다. 참고: 호스트 이름이 작동하지 않는 경우 대신 IP 주소를 사용해 보십시오.
    ========== 서버 사용량 ==========
    리소스 크기 GiB Used GiB Avail GiB Use%
    ------------------         --------        --------           ---------      ----
    /backup: pre-comp - 17814.5 - -
    / 백업 : post-comp 1892.9 1099.1 793.8 58 %
    /ddvar 19.7 3.2 16.5       12%
    
    	
    1. Windows 시스템에서 시작 버튼을 누르고 선택 Run... 을 클릭하고 \ddvar 공유의 IP 주소 (또는 호스트 이름) 및 경로를 입력합니다.
      명령 실행
      OK를 클릭합니다.
    2. /ddvar 공유에 대한 전체 사용 권한을 가지려면 다음 계정 중 하나로 DataDomain Restorer를 인증합니다.
      • Restorer 기본 sysadmin 계정
      • Class admin
        의 일부인 Other Restorer 로컬 계정 # user show list 명령으로 확인
      • 그룹 ID가 50
        으로 표시되는 Active Directory 관리자 계정 # cifs troubleshooting user 10500 명령으로 확인
    3. 코어 파일이 있는 경우 삭제합니다. 열기 \심 폴더.
      코어 파일
      • 코어 파일이 있는 경우 날짜별로 나열합니다(자세히 보기). 지난 24시간 이내의 코어 파일이 있는 경우 추가 분석이 필요한 더 심각한 문제를 나타낼 수 있습니다. 이 경우 계약된 지원 공급업체에 문의하여 SUB(Support Bundle) 링크 오류 180563 업로드하고 서비스 요청을 생성합니다.
      • 코어 파일이 최신이 아닌 경우 모든 파일을 강조 표시하고 삭제합니다.
    4. 이전 SUB(Support Upload Bundle) 파일을 삭제합니다. 다음 디렉토리로 이동하십시오: \ddvar\지원 폴더.
      SUB(Support Upload Bundle) 파일
      • 모든 지원 번들 파일 강조 표시 및 삭제(support-bundle.tar.gz*)
    5. 이전 업그레이드 파일 삭제(.rpm 파일)을 Data Domain 시스템에서 가져올 수 있습니다.
      다음 디렉토리로 이동하십시오: \ddvar\릴리스 폴더. 모든 파일을 강조 표시하고 삭제합니다.
      참고: .rpm 파일이 임시로 사용됩니다(업그레이드 중에만). 시스템을 업그레이드한 후에는 이러한 파일이 더 이상 필요하지 않습니다.
    6. 공간이 복구되었는지 확인합니다.
      Data Domain 시스템 프롬프트에서 다음을 입력합니다.
      에프에프
    Unix 기반 시스템을 사용하여 /ddvar 디렉토리의 디스크 공간 확보.
    ========== 서버 사용량 ==========
    리소스 크기 GiB Used GiB Avail GiB Use%
    ------------------         --------        --------           ---------      ----
    /backup: pre-comp - 17814.5 - -
    / 백업 : post-comp 1892.9 1099.1 793.8 58 %
    /ddvar 19.7 3.2 16.5       12%
    
    
    1. Data Domain 시스템의 NFS ACL(Access List)이 현재 시스템에서 액세스할 수 있도록 181315 구성되어 있는지 확인합니다.
    2. 클라이언트 시스템에 /ddvar 내보내기를 마운트합니다. 181310
    3. Data Domain 시스템에서 이전 코어 파일(있는 경우)을 삭제합니다.
      NFS 클라이언트 시스템의 명령 프롬프트에서 다음을 입력합니다.
      ls -l /ddvar/core
      • 지난 24시간 이내의 코어 파일이 있는 경우 추가 분석이 필요한 더 심각한 문제를 나타낼 수 있습니다. 이 경우 계약된 지원 공급업체에 문의하여 SUB(Support Bundle) 링크 오류 180563 업로드하고 서비스 요청을 생성합니다.
      • 코어 파일이 최신이 아닌 경우 모든 파일을 삭제합니다.
        rm/ddvar/코어/*
    4. 이전 SUB(Support Upload Bundle) 파일을 삭제합니다. NFS 클라이언트 시스템의 명령 프롬프트에서 다음을 입력합니다.
      rm/ddvar/support/support-bundle.*
    5. 이전 업그레이드 파일 삭제(.rpm 파일)
      NFS 클라이언트 시스템의 명령 프롬프트에서 다음을 입력합니다.
      rm/ddvar/releases/*.rpm
    6. 공간이 복구되었는지 확인합니다.
      Data Domain 시스템 프롬프트에서 다음을 입력합니다.
      에프에프
    참고: 만약 /ddvar 이 문서의 단계를 실행한 후에도 여전히 가득 참으로 보고됩니다. 계약한 지원 공급업체에 문의하여 자동 지원 180561 수집하고 서비스 요청을 생성하십시오.

참조

  • 일시적인 /ddvar 공간 사용량증가181878
  • /ddvar 180997의 공간에 대한 알림 계산


참고: 이 문서의 링크는 등록된 Dell 고객 전용입니다.

Affected Products

Data Domain

Products

Data Domain
Article Properties
Article Number: 000043441
Article Type: Solution
Last Modified: 02 Oct 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.