Data Domain. Поиск и устранение проблем, связанных с разрешениями CIFS

Summary: В этой статье приводится пошаговое руководство по диагностике и устранению проблем с разрешениями CIFS в системах Dell EMC Data Domain. В нем рассматриваются проверки подлинности, разрешения на уровне сетевой папки, разрешения для файлов NTFS и рекомендации по репликации. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • При подключении к сетевым папкам CIFS пользователи получают сообщение об ошибке «Access Denied».
  • Задания резервного копирования завершаются сбоем из-за проблем с доступом к CIFS.
  • Общие ресурсы CIFS недоступны из клиентов Windows.

Cause

Проблемы с разрешениями CIFS могут возникать по следующим причинам.

  • Сбои аутентификации (Kerberos или NTLM)
  • Неверные разрешения на уровне общего ресурса или ограничения клиентского доступа
  • Отсутствуют или неправильно настроены разрешения для файлов NTFS
  • Целевые объекты репликации, обеспечивающие доступ только для чтения

Resolution

Поиск и устранение неисправностей с разрешениями CIFS осуществляется по тем же принципам, что и в Windows Server. Поведение при доступе зависит от взаимодействия между разрешениями для общего ресурса и разрешениями файловой системы. Если разрешения NTFS неверны, измените их с помощью Проводника Windows. Для внесения этих изменений может потребоваться администратор домена Windows или авторизованный пользователь.

Выполните следующие действия, чтобы устранить проблемы с разрешениями CIFS.

  1. Проверить аутентификацию CIFS

    • Протестируйте возможность подключения без указания общего ресурса:
      Start → Run → \\<ddr-hostname|or|IP
      
      • kA2j0000000R6UnCAK_1_0
    • Если имя хоста работает, проверка подлинности Kerberos выполнена успешно
    • Если IP-адрес работает, проверка подлинности NTLM выполнена успешно
      • Если оба варианта работают, добавьте имя общего ресурса, чтобы попытаться получить доступ
    • Если обе проверки не пройдены, устраните аутентификацию, прежде чем продолжить
  2. Проверка разрешений для общего ресурса CIFS

    • В интерфейсе командной строки DD-CLI отобразите сведения об общем ресурсе:
      # cifs share show <share-name>
      Пример.
      ## cifs share show sql
      Shares information for: sql
      --------------- share sql ---------------
      permissions: 1 ACE(s) have been set by MMC
      clients: *
      enabled: yes
      groups: techsupp\sales
      users: techsupp\abc
      maxconn: 0
      writeable: yes
      path: /data/col1/data/sql
      ##
    • Подтверждать:
      • Пользователи/группы имеют доступ
      • Список клиентов содержит правильные имена хостов/IP-адреса
      • Путь существует и доступен для записи
    • Настройка разрешений с помощью Windows MMC
      Computer Management → Shared Folders → Shares → Properties → Share Permissions
      
    • Только администраторы домена могут изменять параметры безопасности общего ресурса.
  3. Проверка разрешений на доступ к файлам NTFS

    • На клиенте Windows:
      Right-click file/folder → Properties → Security tab
      Убедитесь, что требуемые пользователи/группы имеют соответствующий доступ.
    • Проверка состояния репликации

      • Если путь является целевым ресурсом репликации, он доступен только для чтения:
        # replication show config
        
      • Чтобы сделать систему доступной для записи, прервите репликацию:
        # replication break rctx://<context-number>
        
      • Выполните это действие в исходной и целевой системах.

Additional Information

Важные примечания.

  • Не смешивайте данные CIFS и NFS в одной папке.
  • Не предоставляйте общий доступ к экспортируемым каталогам для CIFS и NFS.
  • Если клиент CIFS является многосетевым (имеет несколько IP-адресов), внесите одно или несколько из следующих изменений в конфигурацию:
    • Добавьте оба интерфейса в список доступа к общему ресурсу
    • Добавьте оба DNS-имени в список доступа к общему ресурсу
    • Внесение изменений в маршрутизацию на клиенте
    • Внесение изменений в разрешение имен хостов

Обзор разрешений NTFS

Права доступа к файлам:

  • Полный доступ — чтение, запись, изменение, выполнение, изменение атрибутов/разрешений и принятие права собственности.
  • Изменение — чтение, запись, изменение, выполнение и изменение атрибутов.
  • Чтение и выполнение — просмотр файловых данных, атрибутов, владельца, разрешений и запуск исполняемых файлов.
  • Чтение — открытие и просмотр файловых данных, атрибутов, владельца и разрешений.
  • Запись — запись или добавление данных и изменение атрибутов.

Права доступа к папкам:

  • Полный доступ — чтение, запись, изменение, выполнение файлов, изменение атрибутов и разрешений и принятие права собственности.
  • Изменение — чтение, запись, изменение, выполнение файлов и изменение атрибутов.
  • Чтение и выполнение — просмотр содержимого папок, данных файлов, атрибутов, владельца, разрешений и файлов запуска.
  • Список содержимого папки — отображение содержимого папки и сведений о файле.
  • Чтение — просмотр файловых данных, атрибутов, владельца и разрешений.
  • Запись — запись или добавление данных и изменение атрибутов.

Управление владением

Принятие права собственности:

  1. Нажмите правой кнопкой мыши файл/папку → СвойстваSecurityAdvanced.
  2. Перейдите на вкладку ВладелецРедактировать.
  3. Выберите нового владельца; Дополнительно применяется к вложенным папкам/файлам.
  4. Дважды нажмите кнопку ОК .

Назначение права собственности:

  1. Откройте «Свойства» → «Безопасность» → вкладку «Дополнительновладелец»«Редактировать».
  2. Нажмите Другие пользователи или группы, введите имя и установите флажок Имена.
  3. Выберите нового владельца; Дополнительно применяется к вложенным папкам/файлам.
  4. Дважды нажмите кнопку ОК .

Affected Products

Data Domain

Products

Data Domain
Article Properties
Article Number: 000045216
Article Type: Solution
Last Modified: 19 Nov 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.