PowerFlex: Het toevoegen van een SDS-apparaat mislukt met "Een apparaat met de opgegeven naam bestaat al in de SDS"

Summary: Het toevoegen van een SDS-apparaat mislukt met "Een apparaat met de opgegeven naam bestaat al in de SDS"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Tijdens het toevoegen van een apparaat aan een SDS via scli, wordt deze fout weergegeven:

PowerFlex-apparaat met de opgegeven naam bestaat al

# scli --add_sds_device --sds_name sds-01 --device_path /dev/sdc --storage_pool pool1
Error: MDM failed command. Status: A device with the given name already exists in the SDS

 

Meestal kan dit worden opgelost door gebruik te maken van "--update_device_original_path." Als u echter probeert het probleem van apparaatpaden op te lossen Een apparaat met de opgegeven naam bestaat al in de SDS eindigt nu met deze fout:

#  scli --update_device_original_path --sds_id be84190600000001 --device_id cd82454400010008
Error: MDM failed command.  Status: Device has an unhandled error that cannot yet be cleared 

 

Dit probleem kan ook verschijnen als een dubbele invoer van het pad naar het apparaat in de gebruikersinterface , terwijl als u het pad van het apparaat vanaf de gerelateerde server controleert (bijvoorbeeld door "lsblk") ziet u geen duplicatie in de paden van het apparaat.

 

Impact

Kan geen nieuwe apparaten toevoegen aan de SDS om de storagecapaciteit in het cluster uit te breiden.

Cause

Zoals eerder vermeld, is het eerste dat u moet proberen om het oorspronkelijke pad van het apparaat dat momenteel in de SDS bestaat, bij te werken wanneer we deze fout zien. Als dit niet lukt, komt dit doordat de apparaten die de SDS in deze host bestuurt ooit een fout hebben gehad die is gewist, hetzij in de gebruikersinterface of via de opdrachtregel, maar de MDM staat niet toe dat de apparaatfouten verder worden gewist, omdat het apparaat niet langer de status "fout" heeft. De "unhandled error" is een ScaleIO-probleem dat wordt opgelost in een latere revisie van de code.

Resolution

De snelste manier om het probleem te omzeilen is door een tijdelijk apparaat toe te voegen dat het gat in de lijst met apparaten opvult. Bijvoorbeeld:

# scli --query_sds --sds_id be84190600000001 |grep ID: |awk '{print $4,$5,$6,$7}'
Path: /dev/sdb Original-path: /dev/sdb
Path: /dev/sdc Original-path: /dev/sdc
Path: /dev/sdd Original-path: /dev/sdd
Path: /dev/sde Original-path: /dev/sde
Path: /dev/sdf Original-path: /dev/sdf
Path: /dev/sdg Original-path: /dev/sdh
Path: /dev/sdh Original-path: /dev/sdi
Path: /dev/sdi Original-path: /dev/sdj
 
# lsblk
NAME   MAJ:MIN RM   SIZE RO MOUNTPOINT
sdb      8:16   0 930.4G  0
sdc      8:32   0 930.4G  0
sdd      8:48   0 930.4G  0
sde      8:64   0 930.4G  0
sdf      8:80   0 930.4G  0
sdg      8:96   0 930.4G  0
sda      8:0    0     8G  0
ââsda1   8:1    0  1011M  0 [SWAP]
ââsda2   8:2    0     7G  0 /
sdi      8:128  0 930.4G  0
sdh      8:112  0 930.4G  0
fd0      2:0    1     4K  0
sr0     11:0    1  1024M  0

 

Noteer het huidige pad dat elk apparaat gebruikt. Het laatste apparaat is /dev/sdi. Wanneer een nieuw apparaat wordt toegevoegd, wordt het geleverd als: /dev/sdj. Er is al een /dev/sdj Vermeld onder Original-Path. Wanneer een nieuw SDS-apparaat wordt toegevoegd, moeten de huidige en oorspronkelijke paden overeenkomen. Het "--update_device_original_path" commando wordt verondersteld dit op te helderen en overeen te komen met de huidige en oorspronkelijke paden.

In dit geval, met de host een SVM op ESXi, voegen we een kleine (8 GB, dunne) VMDK toe aan de SVM, die binnenkomt als /dev/sdj. Wanneer nu het nieuwe echte SDS-apparaat wordt toegevoegd, komt het binnen als /dev/sdk, die gratis is op zowel het huidige als het oorspronkelijke pad, en zal slagen.

 

Additional Information

Versies waarop dit van toepassing is

v2.0.0.3 en hoger

Opgelost in versie

v3.0 

Affected Products

Hyper-converged Systems, PowerFlex rack, ScaleIO
Article Properties
Article Number: 000045689
Article Type: Solution
Last Modified: 11 Nov 2025
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.