Avamar. Балансировка добавленных узлов не выполняется из-за действий, выполняемых в период обслуживания

Summary: Балансировка добавленных узлов в Avamar не выполняется из-за операций репликации или резервного копирования, выполняемых в период обслуживания.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Новые узлы добавляются в существующую сеть Avamar, но балансировка чередования практически не приводит к прогрессу.

По прошествии нескольких недель количество полос на новых узлах по-прежнему меньше, чем на исходных узлах.

Ниже приведен пример выходных данных команды status.dpn с отображением номеров полос данных на каждом разделе узла:

Thu Sep 14 17:25:37 CEST 2017 [avamar-server.customer.com] Thu Sep 14 15:25:37 2017 UTC (Initialized Tue Aug 27 07:32:25 2013 UTC)
Node IP Address Version State Runlevel Srvr+Root+User Dis Suspend Load UsedMB Errlen %Full Percent Full and Stripe Status by Disk
0.0 192.168.255.3 7.2.0-401 ONLINE fullaccess mhpu+0hpu+0hpu 1 false 0.36 31869 12707315 54.4% 54%(onl:3661) 54%(onl:3690) 54%(onl:3701)
0.1 192.168.255.4 7.2.0-401 ONLINE fullaccess mhpu+0hpu+0hpu 0 false 0.49 31713 14168999 54.4% 54%(onl:3702) 54%(onl:3691) 54%(onl:3671)
0.2 192.168.255.5 7.2.0-401 ONLINE fullaccess mhpu+0hpu+0hpu 0 false 1.05 31853 12673034 54.3% 54%(onl:3674) 54%(onl:3666) 54%(onl:3697)
0.3 192.168.255.6 7.2.0-401 ONLINE fullaccess mhpu+0hpu+0hpu 0 false 0.45 31603 12991585 54.3% 54%(onl:3702) 54%(onl:3671) 54%(onl:3692)
0.4 192.168.255.7 7.2.0-401 ONLINE fullaccess mhpu+0hpu+0hpu 1 false 0.47 31865 12004871 54.4% 54%(onl:3656) 54%(onl:3678) 54%(onl:3715)
0.5 192.168.255.8 7.2.0-401 ONLINE fullaccess mhpu+0hpu+0hpu 1 false 0.30 31631 8245977 54.4% 54%(onl:3805) 54%(onl:3611) 54%(onl:3623)
0.6 192.168.255.9 7.2.0-401 ONLINE fullaccess mhpu+0hpu+0hpu 0 false 0.92 31855 7928968 54.3% 54%(onl:3587) 54%(onl:3846) 54%(onl:3608)
0.7 192.168.255.10 7.2.0-401 ONLINE fullaccess mhpu+0hpu+0hpu 1 false 0.14 31370 597225 5.0% 4%(onl:700) 5%(onl:785) 5%(onl:789) <-- NEWLY ADDED NODE
0.8 192.168.255.11 7.2.0-401 ONLINE fullaccess mhpu+0hpu+0hpu 0 false 0.36 31424 548361 4.6% 4%(onl:877) 4%(onl:679) 4%(onl:659) <-- NEWLY ADDED NODE
Srvr+Root+User Modes = migrate + hfswriteable + persistwriteable + useraccntwriteable

 (В данном примере 0,7 и 0,8 — это новые узлы.)

Cause

Балансировка выполняется во время окна обслуживания, когда сеть простаивает.

Если операции резервного копирования или входящей репликации выполняются в период обслуживания, балансировка будет невозможна.

Resolution

Выполните одно из следующих действий:

1. Настройте балансировку, как рекомендовано в процедуре SolVe.

-- или --
 

2. Просмотрите расписание сети, чтобы определить, записываются ли резервные копии или входящие данные репликации в Avamar Server во время окна обслуживания. 

Это можно сделать, запустив самую последнюю версию sched.sh или выполнив сценарий диагностики системы (proactive_check.pl) с параметром --sched .

Дополнительные сведения см. в следующих статьях базы знаний: 

-- или --
 

3. Просматривайте монитор активности на предмет входящей активности резервного копирования в часы дня, когда выполняется обслуживание.

В случае конфликта между окном обслуживания измените настройку резервного копирования так, чтобы оно завершалось до наступления окна обслуживания, или перенесите окно обслуживания на другое время суток.

Additional Information

Разделение резервного копирования и обслуживания может быть временной мерой, пока требуется балансировка.

Рекомендуется не разрешать резервное копирование в период обслуживания.

Это замедляет выполнение задач резервного копирования и обслуживания. В результате производительность может стать недопустимо низкой.

Affected Products

Avamar

Products

Avamar, Avamar Server
Article Properties
Article Number: 000046169
Article Type: Solution
Last Modified: 14 Nov 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.