Avamar: Varmuuskopiointi on hidasta tai epäonnistuu "Time out - end" -toiminnolla, koska uusia tai muuttuneita tietoja on paljon
Summary: Avamar-varmuuskopiointi on hidasta tai epäonnistuu ja näyttöön tulee "Time out - end" -ilmoitus, koska tietoja on paljon uusia tai ne ovat muuttuneet.
Symptoms
Avamar-varmuuskopiointi näyttää toimivan tavallista hitaammin tai sitä ei voi suorittaa loppuun tavallisen varmuuskopiointijakson aikana.
Asiakasloki osoittaa, että varmuuskopio sisältää suuren prosenttiosuuden muokattuja tiedostoja ja/tai paljon uusia tietoja.
Lokiote, jossa näkyy useita muuttuneita tiedostoja.
2013-12-03 20:48:24 avtar Info <5156>: Backup #72 timestamp 2013-12-03 20:48:24, 2,890,814 files, 420,421 folders, 5,362 GB (2,743,151 files, 24.36 GB, 0.45% new)
Tämä loki osoittaa, että varmuuskopio tarkisti 2 890 814 tiedostoa ja että 2 743 151 näistä tiedostoista oli muutettu edellisen varmuuskopioinnin jälkeen. Vaikka tiedostojen suuri osa oli muokattavissa, vain 0,45 % uusista tiedoista lähetettiin Avamar-palvelimeen.
Lokiote, jossa näkyy paljon lisätietoja.
2015-09-26 11:09:52 avtar Info <5157>: PARTIAL Backup #31 timestamp 2015-09-26 11:20:21, 4,591 files, 1,044 directories, 145.1 GB (2,082 files, 61.63 GB, 42.47% new)
Tämä lokiote osoittaa, että varmuuskopioon on lisätty 60 Gt uusia tietoja, kun varmuuskopion kokonaiskoko on 145 Gt.
Cause
Varmuuskopiointi kestää näissä tilanteissa kauemmin, koska avtarin on tarkistettava jokainen tietojoukon tiedosto tarkistaakseen, onko sitä muokattu.
Muokatut tiedostot jaetaan pieniksi paloiksi, niille annetaan SHA-tiiviste ja niitä verrataan sitten välimuistin sisältöön. Tiedostot, joita ei ole välimuistissa, tarkistetaan Avamar-palvelimessa olevien tiedostojen kanssa, ja jos ne puuttuvat, ne lähetetään verkon kautta. Tämä voi kestää kauan suurille tiedostoille.
Avamar toimii odotetulla tavalla, mutta tiedot voivat olla epätavallisia tai tietojoukossa voi olla käynnissä jokin muu prosessi, jolla tiedostoja muokataan.
Jos Avamar-varmuuskopioon on lisätty paljon uusia tietoja, uusien tiedostojen käsittely ja käsittely kestää kauemmin.
Resolution
Asiakkaan tulee tarkistaa asiakas ja selvittää, johtuuko tietojen muutos tarkoituksellisesta ja normaalista toiminnasta.
Onko asiakas muokannut asiakkaan tietojoukkoa tai lisännyt levyaseman?
Jos uusien tietojen tai tiedostojen määrä kasvaa, alkuperäisen varmuuskopioinnin jälkeenkään tietoja ei välttämättä enää suoriteta loppuun päivittäisessä ikkunassa.
Tarkista varmuuskopioloki ja vertaa sitä aiempaan varmuuskopiointilokiin, jossa varmuuskopiointi on valmis normaalissa ajassa.
Jos varmuuskopioitavien tietojen määrä on ylittänyt alkuperäisen suunnitelman, pyydä apua Dell Professional Services -palveluista tai Dell Backup and Recovery Design Centeristä.
Additional Information
Seuraava DELL-artikkeli on hyödyllinen tutkittaessa, mitä varmuuskopion tiedostoja on muutettu ja mitkä Avamarin on käsiteltävä ne.
Avamar ei muokkaa tiedostoja eikä käytä arkistobittiä.
Tutki, mikä aiheuttaa tiedostojen tai tiedostojen metatietojen muokkaamisen.
Joidenkin virustorjuntaohjelmien on havaittu muokkaavan tiedoston metatietomääritteitä joko tarkoituksella tai vahingossa.
Esimerkkejä tällaisesta käyttäytymisestä on havaittu seuraavien tuotteiden kohdalla.
- Sophos:
- Sophos-virustorjunnalla toimivan Avamar-asiakkaan heikko varmuuskopiointiteho
- 118630: Sophos Anti-Virus nopeuttaa varmuuskopiointiaikoja.
- Trend Micro:
- Katso hotfix-korjaus 1383 näistä julkaisutiedoista.