Avamar : La sauvegarde est lente ou échoue avec la mention « Time out - end » en raison d’un grand nombre de données nouvelles ou modifiées
Summary: Une sauvegarde Avamar est lente ou échoue avec l’indication « Délai d’expiration – fin » en raison d’un grand nombre de données nouvelles ou modifiées.
Symptoms
Une sauvegarde Avamar semble s’exécuter plus lentement que d’habitude ou ne peut pas se terminer dans sa fenêtre de sauvegarde normale.
Le fichier log du client indique que la sauvegarde contient un pourcentage élevé de fichiers modifiés et/ou un grand nombre de nouvelles données.
Extrait de journal affichant de nombreux fichiers modifiés.
2013-12-03 20:48:24 avtar Info <5156>: Backup #72 timestamp 2013-12-03 20:48:24, 2,890,814 files, 420,421 folders, 5,362 GB (2,743,151 files, 24.36 GB, 0.45% new)
Ce journal indique que la sauvegarde a analysé 2 890 814 fichiers et que 2 743 151 de ces fichiers ont été modifiés depuis la dernière sauvegarde. Malgré ce pourcentage élevé de fichiers modifiés, seules 0,45 % de nouvelles données ont été envoyées à Avamar Server.
Extrait de journal montrant un grand nombre de données supplémentaires.
2015-09-26 11:09:52 avtar Info <5157>: PARTIAL Backup #31 timestamp 2015-09-26 11:20:21, 4,591 files, 1,044 directories, 145.1 GB (2,082 files, 61.63 GB, 42.47% new)
Cet extrait de journal indique que 60 Go de nouvelles données ont été ajoutés à la sauvegarde, par rapport à une taille de sauvegarde totale de 145 Go.
Cause
La raison pour laquelle la sauvegarde prend plus de temps dans ces situations est qu’avtar doit analyser chaque fichier du jeu de données pour vérifier s’il a été modifié.
Les fichiers modifiés sont divisés en petits blocs, un hachage SHA leur est attribué, puis ils sont comparés au contenu du cache. Les fichiers qui ne se trouvent pas dans le cache sont comparés à ceux conservés sur l’instance d’Avamar Server et, s’ils sont manquants, ils sont envoyés sur le réseau. Cette opération peut prendre beaucoup de temps pour les fichiers volumineux.
Avamar se comporte comme prévu, mais les données peuvent être inhabituelles ou un autre processus peut s’opérer sur le jeu de données pour modifier les fichiers.
Si un grand nombre de nouvelles données ont été ajoutées à une sauvegarde Avamar, le traitement et l’acquisition des nouveaux fichiers prennent plus de temps par la tâche.
Resolution
Le client doit examiner le client et déterminer si la modification des données est intentionnelle et due à une activité normale.
Le client a-t-il modifié le jeu de données pour le client ou ajouté un lecteur de disque ?
Si la quantité de nouvelles données ou le nombre de fichiers augmente, même une fois la sauvegarde initiale effectuée, il se peut qu’elle ne s’effectue plus dans les limites d’une fenêtre quotidienne.
Examinez le journal de sauvegarde et comparez-le à un fichier log de sauvegarde précédent où la sauvegarde s’est terminée dans le délai normal.
Si la quantité de données de sauvegarde a augmenté au-delà du périmètre de conception d’origine, demandez de l’aide aux services professionnels Dell ou au Centre de conception de sauvegarde et restauration Dell.
Additional Information
L’article DELL suivant est utile lors de la recherche des fichiers d’une sauvegarde ayant subi des modifications et devant être traités par Avamar.
Avamar ne modifie pas les fichiers et n’utilise pas le « bit d’archivage ».
Déterminez la cause de la modification des fichiers ou des métadonnées des fichiers.
On a observé que certains programmes antivirus modifiaient les attributs de métadonnées d’un fichier, que ce soit par conception ou par accident.
Des exemples de ce comportement ont été observés avec les produits suivants.
- Sophos :
- Performances de sauvegarde médiocres pour le client Avamar exécutant Sophos Anti-Virus
- 118630: Sophos Anti-Virus, ce qui entraîne une augmentation des temps de sauvegarde.
- Trend Micro :
- Voir le correctif 1383 dans ces notes de mise à jour.