NetWorker: The -I - is ignored when the save set is not a BBB with the data writing out with " -r" after the absolute path

Summary: The -I - is ignored when the save set is not a BBB with the data writing out with " -r" after the absolute path

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



When the save set is not from a Block Based Backup (BBB) the save set recover command will disregard the -I - switch and will begin recovering data.

Here is an example of the output
 

C:\Users\Administrator>recover  -vvv -d C:\Test -S 4271161932 -I -
Recovering a subset of 6 files within C:\ into C:\Test
Recover start time: 8/16/2017 3:11:34 PM
Requesting 1 recover session(s) from server.
recovering 6 save set(s) on rsid 3765
08/16/17 15:12:32.804977 libDDBoost version: major: 3, minor: 0, patch: 3, engineering: 0, build: 499747
C:\Test\<directory>\2016.07.21-notes.txt -r
C:\Test\<directory>\recover\ -r
C:\Test\<directory>\tinesgl1_jobsdb.sql -r
C:\Test\<directory>\ -r
        time = 4277847 microseconds, <0:00:04.277847>
Received 4 matching file(s) from NSR server `rastaman'
Recover completion time: 8/16/2017 3:12:38 PM

C:\Users\Administrator>


 

Cause

The syntax of the command line recover is applicable to BBB backups.

Resolution

Ensure the save set that is chosen for the recover is from a BBB backup. To verify, use the mminfo command
 

mminfo -a -S -q ssid=<ssid>
 
The output will have "*BlockBasedBackup: Yes" if it is.

 

To "search" for BBB backups, as Doumented in the NetWorker 9 Administration Guide a new mminfo query ssattr is introduced 

mminfo -avot -q "ssattr=*BlockBasedBackup"
 

NetWorker 8 will take a bit of scripting in PowerShell for Windows or with Unix/Linux. for a start

PS C:\Users\Administrator> mminfo -avot -S | select-string -context 10, 0  -pattern BlockBasedBackup > foo.txt

PS C:\Users\Administrator> select-string -pattern "ssid=" foo.txt  | %{ $_ -split(' ')[0]; } | select-string -pattern "ssid="

ssid=4287841403
ssid=4271064190
ssid=4254300420

PS C:\Users\Administrator>

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000057203
Article Type: Solution
Last Modified: 12 Feb 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.