Avamar: La instalación y la configuración de ADMe se pueden eliminar después de una actualización de Avamar OS
Summary: La actualización del sistema operativo de Avamar de SUSE Linux Enterprise Server (SLES) 11.x a 12.x que reemplaza su sistema de archivos raíz puede provocar la pérdida del archivo ejecutable y la configuración de Avamar Data Migration Enabler (ADMe). ...
Symptoms
Cualquier actualización de Avamar que implique una actualización del SO de SuSE SLES 11.x a 12.x y posiblemente otras versiones puede provocar la pérdida de configuración de ADMe.
Cause
Una actualización del SO de Avamar o cualquier proceso de actualización que reemplace su sistema de archivos (FS) raíz actual mediante un espacio físico estándar del SO o del FS raíz, puede provocar una pérdida del administrador de paquetes RPM (RPM) y de los ejecutables que requiere ADMe.
Históricamente, ADMe se instalaba en /atoadmin ubicado en el FS raíz y depende de la presencia de los RPM ksh, mailx y NetWorker. Las versiones posteriores de ADMe 19.52 y posteriores ahora se instalan en /home/admin/admeadmin y se conservan sus archivos de configuración de ADMe relacionados. Sin embargo, los RPM y los archivos ejecutables necesarios se pueden perder y se deben volver a instalar después de cualquier proceso de actualización que reemplace al FS raíz.
Se recomienda actualizar ADMe a la versión más reciente antes de realizar cualquier actualización de Avamar, en especial una que reemplace el FS raíz actual. Esto garantiza que la configuración de ADMe esté protegida. Cualquier RPM que se deba reinstalar debe estar disponible según sea necesario después de cualquier actualización de Avamar en los casos en que se reemplazó o actualizó el FS raíz.
Es posible que los RPM estén disponibles en /home/admin/admeadmin desde la instalación original de ADMe. Si es así, se pueden reutilizar para la reinstalación.
Si no es así, consulte el siguiente enlace para saber dónde obtener los RPM necesarios relacionados con ADMe.
Resolution
El archivo PDF adjunto muestra cómo proteger las configuraciones de ADMe. Proporciona instrucciones para volver a instalar los RPM necesarios antes de continuar con la actualización de Avamar.
Siga los pasos documentados necesarios para que ADMe vuelva a estar operativo.
En caso de duda, comuníquese con adam.kirkpatrick@dell.com para obtener aclaraciones o necesita ayuda.
Prepárese con anticipación al tener los RPM necesarios a mano, lo que permite que su reinstalación se realice sin problemas y sin demora.
Se requiere una cuenta de soporte de Dell para acceder al artículo Avamar: Cómo obtener e instalar los archivos RPM de ADMe necesarios que contienen los RPM e instrucciones que se deben seguir para su reinstalación.
Pasos generales:
Los pasos del 1 al 3 se consideran tareas del operador y se debe verificar que se completaron antes de continuar con la actualización de Avamar.
- Realice un respaldo de ADMe para proteger una configuración de ADMe existente.
- Mueva el nombre del archivo de respaldo ADMe que se muestra a una ubicación segura fuera del FS raíz.
- Realice una actualización estándar de ADMe a la versión más reciente de ADMe, según sea necesario. Al momento de escribir este artículo, 19.70-02-2023 es la versión más reciente disponible en el soporte de Dell.
- Una vez finalizada la actualización de Avamar, siga los pasos documentados en el artículo Avamar: Cómo obtener e instalar los archivos RPM de ADMe necesarios para restablecer los archivos ejecutables de ADMe y los RPM necesarios.
- Reinicie los servicios de la interfaz de usuario de NetWorker y ADMe como se muestra a continuación:
adme - gui start /etc/init.d/networker start (for Networker agents version 9.x) service networker start (for Networker agents version 19.x)