Avamar : L’installation et la configuration ADMe peuvent être supprimées après une mise à niveau du système d’exploitation Avamar

Summary: La mise à niveau du système d’exploitation Avamar de SUSE Linux Enterprise Server (SLES) 11.x vers la version 12.x qui remplace son système de fichiers racine peut entraîner la configuration d’Avamar Data Migration Enabler (ADMe) et la perte d’exécutables. ...

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Symptoms

Toute mise à niveau d’Avamar impliquant une mise à jour du système d’exploitation de SuSE SLES 11.x vers 12.x et éventuellement d’autres versions peut entraîner une perte de configuration ADMe.

Cause

Une mise à niveau du système d’exploitation Avamar ou tout processus de mise à niveau qui remplace son système de fichiers racine (FS) actuel à l’aide d’un système d’exploitation ou d’un système de fichiers racine standard peut entraîner une perte du RPM Package Manager (RPM) et des exécutables requis par ADMe. 

Historiquement, ADMe était installé dans /atoadmin situé sur le système de fichiers racine et dépend de la présence des RPMksh, mailx et NetWorker. Les versions supérieures d’ADMe 19.52 et ultérieures sont désormais installées dans /home/admin/admeadmin et ses fichiers de configuration ADMe associés sont conservés. Toutefois, les RPM et fichiers exécutables requis peuvent être perdus et doivent être réinstallés après tout processus de mise à niveau qui remplace le système de fichiers racine. 

Il est conseillé de mettre à niveau ADMe vers la dernière version avant d’effectuer une mise à niveau d’Avamar, en particulier une mise à niveau qui remplace le système de fichiers racine actuel. Cela garantit que la configuration ADMe elle-même est protégée. Tous les RPM qui doivent être réinstallés doivent être disponibles en fonction des besoins après les mises à niveau d’Avamar dans les cas où le système de fichiers racine a été remplacé ou mis à jour.

Les RPM peuvent être disponibles dans /home/admin/admeadmin à partir de l’installation ADMe d’origine. Si c’est le cas, ils peuvent être réutilisés pour une réinstallation.

Si ce n’est pas le cas, consultez le lien ci-dessous pour savoir où obtenir les RPM ADMe requis.

Resolution

Le fichier PDF joint explique comment protéger les configurations ADMe. Il fournit des instructions pour réinstaller les RPM nécessaires avant de poursuivre la mise à niveau d’Avamar.
Suivez les étapes documentées requises pour rendre ADMe à nouveau opérationnel. 
En cas de doute, contactez adam.kirkpatrick@dell.com pour obtenir des éclaircissements ou besoin d’aide.

Préparez-vous à l’avance en ayant les RPM requis à portée de main pour permettre leur réinstallation sans problème, sans délai.

Un compte de support Dell est requis pour accéder à l’article Avamar : Comment obtenir et installer les fichiers RPM ADMe requis contenant les RPM et les instructions à suivre pour leur réinstallation. 

Étapes générales :
Les étapes 1 à 3 sont considérées comme des tâches de l’opérateur et doivent être vérifiées comme terminées avant de poursuivre la mise à niveau d’Avamar.

  1. Effectuez une sauvegarde ADMe pour protéger une configuration ADMe existante.
  2. Déplacez le nom du fichier de sauvegarde ADMe affiché vers un emplacement sécurisé hors du système de fichiers racine.
  3. Effectuez une mise à niveau standard d’ADMe vers la dernière version d’ADMe, si nécessaire. À l’heure où nous écrivons ces lignes, le 03/02/2023 est la version 19.70 la plus récente disponible sur le site de support Dell.
  4. Une fois la mise à niveau d’Avamar terminée, suivez les étapes décrites dans l’article Avamar : Comment obtenir et installer les fichiers RPM ADMe requis pour rétablir les fichiers exécutables ADMe et les RPM requis.
  5. Redémarrez les services de l’interface utilisateur NetWorker et ADMe comme indiqué :
    adme - gui start
    /etc/init.d/networker start      (for Networker agents version 9.x)
    service networker start          (for Networker agents version 19.x)

Affected Products

Avamar Data Migration Enabler

Products

Avamar Data Store
Article Properties
Article Number: 000058787
Article Type: Solution
Last Modified: 09 Jul 2025
Version:  12
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