Avamar: Instalacja i konfiguracja ADMe może zostać usunięta po uaktualnieniu systemu operacyjnego Avamar

Summary: Uaktualnienie systemu operacyjnego Avamar z systemu SUSE Linux Enterprise Server (SLES) 11.x do wersji 12.x, które zastępuje główny system plików, może spowodować konfigurację narzędzia Avamar Data Migration Enabler (ADMe) i utratę pliku wykonywalnego. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Każde uaktualnienie Avamar obejmujące aktualizację systemu operacyjnego z SuSE SLES 11.x do 12.x i prawdopodobnie innych wersji może spowodować utratę konfiguracji ADMe.

Cause

Uaktualnienie systemu operacyjnego Avamar lub dowolny proces aktualizacji, który zastępuje bieżący główny system plików (FS) przy użyciu standardowego systemu operacyjnego lub głównego systemu plików FS, może spowodować utratę programu RPM Package Manager (RPM) i plików wykonywalnych wymaganych przez ADMe. 

W przeszłości ADMe było instalowane w katalogu /atoadmin znajdującym się w głównym systemie plików FS i zależy to od obecności pakietów RPMksh, mailx i NetWorker. Nowsze wersje ADMe 19.52 i nowsze są teraz instalowane w katalogu /home/admin/admeadmin , a powiązane pliki konfiguracyjne ADMe są zachowywane. Jednak wymagane pliki RPM i pliki wykonywalne mogą zostać utracone i będą musiały zostać ponownie zainstalowane po każdym procesie aktualizacji, który zastępuje główny FS. 

Zaleca się uaktualnienie oprogramowania ADMe do najnowszej wersji przed wykonaniem jakiejkolwiek aktualizacji Avamar, zwłaszcza takiej, która zastępuje bieżący główny system FS. Zapewnia to ochronę samej konfiguracji ADMe. Wszelkie pliki RPM, które muszą zostać ponownie zainstalowane, powinny być dostępne w razie potrzeby po uaktualnieniu Avamar w przypadkach, gdy główny FS został wymieniony lub zaktualizowany.

Pliki RPM mogą być dostępne w katalogu /home/admin/admeadmin z pierwotnej instalacji ADMe. Jeśli tak, można je ponownie wykorzystać do ponownej instalacji.

Jeśli nie, skorzystaj z poniższego łącza, aby uzyskać informacje o tym, gdzie uzyskać wymagane pliki RPM związane z ADMe.

Resolution

Załączony plik PDF przedstawia sposób ochrony konfiguracji ADMe. Zawiera instrukcje dotyczące ponownej instalacji wymaganych plików RPM przed kontynuowaniem aktualizacji Avamar.
Wykonaj udokumentowane czynności wymagane do przywrócenia działania ADMe. 
W razie wątpliwości skontaktuj się z adam.kirkpatrick@dell.com w celu uzyskania wyjaśnień lub potrzebnej pomocy.

Przygotuj się z wyprzedzeniem, mając pod ręką wymagane pliki RPM, aby ich ponowna instalacja przebiegła bezproblemowo i bez opóźnień.

Aby uzyskać dostęp do artykułu Avamar, wymagane jest konto Dell Support: Uzyskiwanie i instalowanie wymaganych plików RPM ADMe zawierających pliki RPM oraz instrukcje dotyczące ich ponownej instalacji. 

Kroki wysokiego poziomu:
Kroki od 1 do 3 są traktowane jako zadania operatora i powinny zostać zweryfikowane jako wykonane przed kontynuowaniem aktualizacji Avamar.

  1. Wykonaj kopię zapasową ADMe w celu ochrony istniejącej konfiguracji ADMe.
  2. Przenieś wyświetloną nazwę pliku kopii zapasowej ADMe do bezpiecznej lokalizacji poza głównym FS.
  3. W razie potrzeby wykonaj standardową aktualizację ADMe do najnowszej wersji. W chwili pisania tego tekstu 2023-02-03 19.70 jest najbardziej aktualną dostępną w Dell Support.
  4. Po zakończeniu aktualizacji Avamar wykonaj czynności opisane w artykule Avamar: Uzyskiwanie i instalowanie wymaganych plików RPM ADMe w celu przywrócenia plików wykonywalnych ADMe i wszelkich wymaganych plików RPM.
  5. Uruchom ponownie usługi interfejsu użytkownika NetWorker i ADMe, jak pokazano na ilustracji:
    adme - gui start
    /etc/init.d/networker start      (for Networker agents version 9.x)
    service networker start          (for Networker agents version 19.x)

Affected Products

Avamar Data Migration Enabler

Products

Avamar Data Store
Article Properties
Article Number: 000058787
Article Type: Solution
Last Modified: 09 Jul 2025
Version:  12
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.