Авамар: Налаштування продуктивності резервного копіювання клієнтів для наборів даних з низьким співвідношенням файлів у папки

Summary: Налаштування продуктивності резервного копіювання клієнта Avamar для наборів даних з низьким співвідношенням файлів і папок.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Продуктивність резервного копіювання Avamar для клієнта відносно повільна.

Використання процесора скромне, а пристрій зберігання даних не здається вузьким місцем.

Журнал резервного копіювання Avamar показує «викидні» значення в статистиці набору даних, які показують, що клієнт має співвідношення файлів і папок. Він може виграти від тюнінгу.

Cause

Процес "avtar" клієнта Avamar оптимізовано для хорошої роботи з більшістю наборів даних, уникаючи надмірного споживання ресурсів.

Іноді "avtar" може зіткнутися з наборами даних, характеристики яких відрізняються від параметрів налаштування за замовчуванням, обраних інженерією, і можуть не грати на їхню користь.

Набори даних для більшості резервних копій файлової системи зазвичай мають співвідношення файлів до папок приблизно 10:1.

Набори даних із низьким співвідношенням файлів і папок, наприклад 1:1 або 2:1, можуть мати знижену продуктивність за інших рівних умов.

Співвідношення файлів і папок можна перевірити, переглянувши повний журнал резервних копій для наступного запису.
 

2015-11-18 00:34:32 avtar Info <5156>: Backup #75 timestamp 2015-11-18 00:24:43, 4,007,032 files, 1,974,043 folders, 1,589 GB (2,680 files, 419.4 MB, 0.03% new) 

Resolution

Для наборів даних із низьким співвідношенням файлів до папок може бути корисним налаштувати параметр avtar "--maxopendirs" зі стандартного значення 100.

Параметр "maxopendirs" контролює, скільки каталогів avtar може відкрити одночасно, і допомагає avtar працювати ефективніше. При відповідному налаштуванні продуктивність резервного копіювання файлів за годину може збільшитися. Компромісом, як правило, є незначне збільшення використання пам'яті клієнтом Avamar. 

Наступні витяги з журналу взяті з того ж клієнта, з того ж набору даних без будь-яких інших змін, крім "maxopendirs".

Ми можемо бачити, як зі збільшенням «максопендірів» зі 100 до 1000 avtar споживає більше пам'яті та досягає вищої продуктивності резервного копіювання файлів/годину.
 

maxopendirs=<за замовчуванням>

    • Пікове завантаження пам'яті avtar = 492 Мб
2015-11-08 09:30:19 avtar Info <5156>: Backup #38 timestamp 2015-11-08 09:21:48, 3,995,129 files, 1,965,847 folders, 1,671 GB (172 files, 32.25 MB, 0.00% new)
2015-11-08 09:30:20 avtar Info <6083>: Backed-up 1,671 GB in 659.14 minutes: 152 GB/hour (363,668 files/hour)


maxopendirs=200

    • Пікове завантаження пам'яті avtar = 526 Мб
2015-11-12 09:32:47 avtar Info <5156>: Backup #54 timestamp 2015-11-12 09:23:31, 3,998,280 files, 1,969,137 folders, 1,546 GB (4,121 files, 688.2 MB, 0.04% new)
2015-11-12 09:32:47 avtar Info <6083>: Backed-up 1,546 GB in 667.61 minutes: 139 GB/hour (359,336 files/hour)


maxopendirs=800

    • Пікове завантаження пам'яті avtar = 605 Мб
2015-11-14 07:45:58 avtar Info <5156>: Backup #62 timestamp 2015-11-14 07:36:24, 4,003,390 files, 1,971,781 folders, 1,561 GB (3,816 files, 645.8 MB, 0.04% new)
2015-11-14 07:45:58 avtar Info <6083>: Backed-up 1,561 GB in 559.08 minutes: 168 GB/hour (429,638 files/hour)


Максопенддіри=1000

    • Пікове використання пам'яті avtar = 597 МБ (менше доступних точок вибірки завдяки швидшому резервному копіюванню)
2015-11-18 00:34:32 avtar Info <5156>: Backup #75 timestamp 2015-11-18 00:24:43, 4,007,032 files, 1,974,043 folders, 1,589 GB (2,680 files, 419.4 MB, 0.03% new)
2015-11-18 00:34:32 avtar Info <6083>: Backed-up 1,589 GB in 144.70 minutes: 659 GB/hour (1,661,482 files/hour) 

Affected Products

Avamar

Products

Avamar, Avamar Client
Article Properties
Article Number: 000060830
Article Type: Solution
Last Modified: 10 Feb 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.