Avamar: Sfoglia Isilon mostra solo la directory "/ifs" in caso di emissione della password e verifica utilizzando curl

Summary: L'interfaccia utente di Avamar che naviga in un NAS Isilon potrebbe mostrare "/ifs" solo se l'utente di esplorazione ("av-browse-admin") ha una password errata o scaduta. Test con controllo "curl" con "isi auth users" per visualizzare e reimpostare la password utilizzando "isi auth users" per modificare --set-password '' --enabled true. Vengono quindi visualizzate le sottodirectory. ...

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Symptoms

Comportamento osservato durante l'esplorazione di Isilon con Avamar.

Durante la navigazione in un Isilon NAS dall'interfaccia utente di amministrazione, viene osservato quanto segue:

  • Solo le aree di primo livello /ifs Viene visualizzata la directory.
  • Nessuna sottodirectory o file sottostante /ifs sono visibili.
  • L'utente browse (in genere av-browse-admin) viene accettato senza errori.

Cause

Motivi sottostanti per la visibilità limitata delle directory in Avamar Browse

L'interfaccia utente di Avamar si basa su una chiamata API basata su HTTP al cluster Isilon per recuperare la gerarchia dei namespace. Quando la richiesta API non può essere autenticata o l'account non è in uno stato valido, la risposta contiene solo le informazioni di primo livello /ifs Voce senza sottodirectory.

  • L'utente di ricerca ha una password errata, causando l'esito negativo dell'autenticazione della richiesta API (in genere av-browse-admin).
  • L'account utente di esplorazione è scaduto, bloccato o disabilitato, impedendo inoltre l'autenticazione.
  • La creazione impropria dell'utente di esplorazione (ad esempio, il mancato rispetto dei passaggi della guida utente NDMP) comporta autorizzazioni insufficienti per elencare le directory sottostanti /ifs. 
In presenza di una di queste condizioni, l'API Isilon restituisce solo il namespace root (/ifs) senza alcuna voce figlio, con conseguente limitazione della navigazione osservata.

Resolution

Verifica dell'accesso utente a Isilon.

Test della connettività con l'account root

Utilizzare curl per richiedere l'elenco degli elenchi di /ifs sul nodo Isilon. Sostituire [ISILON_IP] con l'IP di gestione di qualsiasi nodo.

curl -vk -u "root" -X GET "https://[ISILON_IP]:8080/namespace/ifs"

Test della connettività con l'utente Avamar Browse

Se la richiesta root ha esito positivo, ripetere il test con l'utente browse (impostazione predefinita av-browse-admin).

curl -vk -u "av-browse-admin" -X GET "https://[ISILON_IP]:8080/namespace/ifs"

 

ATTENZIONE: Una risposta vuota o solo il /ifs La voce indica un problema con le credenziali utente o lo stato di Sfoglia.


Controllare lo stato dell'utente di esplorazione su Isilon.

Eseguire il seguente comando sull'Isilon cluster per visualizzare gli attributi dell'utente:

isi auth users view av-browse-admin

Cercare campi come expired, locked o enabled: se l'utente è scaduto, bloccato o disabilitato , andare ai passaggi successivi.


Reimpostare la password dell'utente di navigazione.

Sostituire [NEW_PASSWORD] con la password scelta. Includere le virgolette singole esattamente come mostrato.

isi auth users modify av-browse-admin --set-password '[NEW_PASSWORD]'


Abilitare l'utente Browse (se disabilitato)

isi auth users modify av-browse-admin --enabled true

 

NOTA: La modifica della password può influire su tutti gli altri servizi che si basano sulle stesse credenziali. Verificare che nessun altro processo utilizzi questo account prima di modificarlo.


Ritestare il curl Richiesta con le credenziali aggiornate

curl -vk -u "av-browse-admin" -X GET "https://[ISILON_IP]:8080/namespace/ifs"

In caso di esito positivo, la risposta elenca le directory riportate di seguito /ifs. È inoltre possibile eseguire una query su un percorso più profondo, ad esempio:

curl -vk -u "av-browse-admin" -X GET "https://[ISILON_IP]:8080/namespace/ifs/DIR"

 

Verificare che Avamar sia in grado di sfogliare la condivisione Isilon.

Nell'interfaccia utente di Avamar Administrator, tentare di sfogliare nuovamente Isilon NAS. L'albero di directory completo dovrebbe ora essere visibile.

 

ATTENZIONE: Se il problema persiste dopo la verifica delle credenziali e dello stato utente, contattare il supporto Dell. Modifiche errate alle impostazioni di autenticazione possono impedire l'esecuzione dei backup.

Affected Products

Avamar

Products

Avamar, Avamar Plug-in for NDMP
Article Properties
Article Number: 000063862
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  4
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