Unity/VNX/Celerra: CAVA-Service kann auf Windows-Server nicht gestartet werden (vom Nutzer korrigierbar)

Summary: Wenn Sie versuchen, den CAVA-Service auf dem Windows-Server zu starten, kann der Service nicht gestartet werden.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Auf dem Windows-Server werden die folgenden Meldungen gefunden:

Windows konnte den EMC CAVA-Service auf dem lokalen Computer
nicht starten Fehler 1053: Der Service hat nicht rechtzeitig auf die Start- oder Steuerungsanforderung reagiert.

Aus Windows-Ereignisprotokoll:
Ein Timeout erreichte 30.000 Millisekunden, während auf die Verbindung des EMC CAVA-Service gewartet wurde.


Auf dem Data Mover werden die folgenden allgemeinen Fehlermeldungen gefunden:
[VNX/Celerra-Beispiele]

[nasadmin@VNX01CS0 ~]$ server_viruschk server_2
server_2 :
10 Threads gestartet.
2 Checker-IP-Adresse(n):
10.xx.136.xxx OFFLINE at Fri Sep 15 02:01:41 2017 (GMT+10:00)
Unknown protocol, CAVA version:
AV Engine:
Server Name:
10.xx.136.xxx Kein Signaturdatum

10.xx.136.xxx OFFLINE bei Fri Sep 15 02:01:51 2017 (GMT+10:00)
Unbekanntes Protokoll, CAVA-Version:
AV Engine:
Servername:
10.xx.136.xxx Kein Unterschriftsdatum

2 Dateimaske(n):
*.* =.*
Keine Datei ausgeschlossen.
Geben Sie \\nas01\CHECK$ frei.
RPC-Anforderungstimeout = 25.000 Millisekunden.
RPC-Wiederholungstimeout = 5.000 Millisekunden.
Oberer Schwellenwert = 200.
Niedriger Schwellenwert = 50.
Alle Virenschutzprogramme alle 10 Sekunden überprüfen.
Wenn alle Virenschutzprogramme offline sind:
Arbeiten Sie weiterhin mit Virenprüfung und CIFS.
Scan bei Lesevorgang deaktivieren.
Panik-Handler für 65 Blöcke registriert.
MS-RPC-Nutzer: NAS01$
MS-RPC ClientName: nas01.xxx.xxx.xxx

[nasadmin@VNX01CS0 ~]$ nas_logviewer /nas/log/sys_log | grep -i VC
Sep 14 12:34:25 2017:DART:VC:NOTICE:17:Slot 2:::1505356456:Der Virenschutz wird gestartet.
Sep 14 12:34:35 2017:DART:VC:ERROR:33:Steckplatz 2:::1505356466:Fehler auf CAVA-Server 10.xx.136.xxx: OFFLINE.
Sep 14 12:34:45 2017:DART:VC:ERROR:33:Steckplatz 2:::1505356476:Fehler auf CAVA-Server 10.xx.136.xxx: OFFLINE.
Sep 14 12:34:45 2017:DART:VC:ERROR:4:Slot 2:::1505356476:Kein Virenschutzserver verfügbar.
Sep 14 12:43:45 2017:DART:VC:NOTICE:16:Slot 2:::1505357023:Der Virenschutz wurde gestoppt.
~~
Sep 14 12:46:35 2017:DART:VC:NOTICE:16:Slot 2:::1505357191:Der Virenschutz wurde gestoppt.
Sep 14 14:13:35 2017:DART:VC:NOTICE:17:Slot 2:::1505362408:Der Virenschutz wird gestartet.
Sep 14 14:13:45 2017:DART:VC:ERROR:33:Steckplatz 2:::1505362418:Fehler auf CAVA-Server 10.xx.136.xxx: OFFLINE.
Sep 14 14:13:55 2017:DART:VC:ERROR:33:Slot 2:::1505362428:Fehler auf CAVA-Server 10.xx.136.xxx: OFFLINE.
Sep 14 14:13:55 2017:DART:VC:ERROR:4:Slot 2:::1505362428:Kein Virenschutzserver verfügbar.

[Unity-Beispiele]

14:26:30 service@VIRT1615YRRR08-spa spa:~> svc_cava cava-smb
cava-smb : Verarbeitete Befehle:
1 Befehl (e) erfolgreich
Ausgabe ist abgeschlossen

1507818392: VC: 5: VDM cava-smb: Aktiviert und gestartet.
1507818392: VC: 5: 1 Checker-IP-Adresse(n):
1507818392: VC: 5: 5.6.7.246 OFFLINE bei Thu Oct 12 14:26:29 2017 (GMT-00:00)
1507818392: VC: 5:                                                HTTP, CAVA-Version: , httpStatus: 1006 Verbindung getrennt
1507818392: VC: 5:                                                AV-Engine:
1507818392: VC: 5:                                                Servername: 5.6.7.246
1507818392: VC: 5:                                                Kein Unterschriftsdatum
1507818392: VC: 5:
1507818392: VC: 5: 1 Dateimaske(n):
1507818392: VC: 5: *.*
1507818392: VC: 5: Keine Datei ausgeschlossen.
1507818392: VC: 5: Geben Sie \\5.6.7.56\CHECK$ frei.
1507818392: VC: 5: RPC-Anforderungstimeout = 25.000 Millisekunden.
1507818392: VC: 5: RPC-Wiederholungstimeout = 5.000 Millisekunden.
1507818392: VC: 5: Oberer Schwellenwert = 200.
1507818392: VC: 5: Niedriger Schwellenwert = 50.
1507818392: VC: 5: Alle Virenschutzprogramme alle 10 Sekunden überprüfen.
1507818392: VC: 5: Wenn alle Virenschutzprogramme offline sind:
1507818392: VC: 5: Arbeiten Sie weiterhin mit Virenprüfung und CIFS.
1507818392: VC: 5: Scan bei Lesevorgang deaktivieren.
1507818392: VC: 5: MS-RPC-Nutzer: CAVA-SMB$
1507818392: VC: 5: MS-RPC-Clientname: cava-smb. LEUTE. ÜBUNGSÜBUNG
1507818392: ADMIN: 6: Befehl erfolgreich:  viruschk
14:26:32 service@VIRT1615YRRR08-spa spa:~>

[/EMC/C4Core/log/c4_safe_ktrace.log]

2017/10/12-14:31:55.028840 582 7FC1F33C9701 sade:VC: 5:[cava-smb] Dateisystem-536870934 für Virenprüfung aktivieren.
2017/10/12-14:31:55.028879 36 7FC1F33C9701 sade:VC: 5:[cava-smb] Dateisystem-536870933 für die Virenprüfung aktivieren.
12.10.2017-14:31:55.028947 66 7FC1F33C9701 sade:VC: 5:17:[cava-smb] Der Virenschutz wird gestartet.
12.10.2017-14:31:55.053859 24K 7FC1F33C9701 sade:VC: 3:34:[cava-smb] Beim Virenschutzserver 5.6.7.246 ist ein Fehler aufgetreten und er ist nicht mehr betriebsbereit. (Fehler: OFFLINE,2017
/10/12-14:31:55.053864 4 7FC1F33C9701 sade:VC: 3:34:[cava-smb] httpStatus: 1006 Verbindung getrennt)
2017/10/12-14:31:55.053879 13 7FC1F33C9701 sade:VC: 3: 4:[cava-smb] Es ist kein Virenschutzserver verfügbar.
12.10.2017-14:31:55.053888 7 7FC1F33C9701 sade:VC: 5:[cava-smb] Anforderungen insgesamt: 0.10.12-14
:31:55.053893 3 7FC1F33C9701 sade:VC: 5:[cava-smb]
2017/10/12-14:31:55.053899 4 7FC1F33C9701 sade:VC: 5:[cava-smb] KEINE ANTWORT von den Virenschutzservern: 0.10.12-14
:31:55.053932 31 7FC1F33C9701 sade:VC: 5:[cava-smb] ERROR_SETUP: 0.10.12-14
:31:55.053938 5 7FC1F33C9701 sade:VC: 5:[cava-smb] FEHLER: 0.10.12-14
:31:55.053945 4 7FC1F33C9701 sade:VC: 5:[cava-smb] ZEITÜBERSCHREITUNG: 0.10.12-14
:31:55.053949 2 7FC1F33C9701 sade:VC: 5:[cava-smb]
2017/10/12-14:31:55.053956 4 7FC1F33C9701 sade:VC: 5:[CAVA-SMB] 0 Dateien in der Collector-Warteschlange.
12.10.2017-14:31:55.053961 3 7FC1F33C9701 sade:VC: 5:[cava-smb] 0 Dateien, die von den AV-Threads verarbeitet werden.

Cause

Wenn ein Dienst gestartet wird, teilt der Dienst dem Dienststeuerungs-Manager mit, wie lange der Dienst gestartet werden muss (der Timeoutzeitraum für den Dienst). Wenn der Dienststeuerungs-Manager innerhalb dieses Timeoutzeitraums keine Benachrichtigung vom Dienst erhält, beendet der Dienststeuerungs-Manager den Prozess, der den Dienst hostet. Dieser Timeout-Zeitraum beträgt in der Regel weniger als 30 Sekunden.

NET Framework-Systemanforderungen für Windows 8 und Windows Server 2012 Windows 8 und Windows Server 2012 installieren und aktivieren standardmäßig .NET Framework 4.5. Das CEE-Framework "cava.exe" ist jedoch ein .NET Framework 3.5-Dienst. Sie müssen .NET Framework 3.5 aktivieren. Anweisungen zum Aktivieren von .NET Framework 3.5 unter Windows 8 und Windows 2012 finden Sie unter: http://msdn.microsoft.com/ens/library/hh506443.aspx

Resolution

Installieren oder aktivieren Sie .NET Framework 3.5 unter Windows 10, Windows 8.1 und Windows 8
https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10

Sobald .NET Framework 3.5 ausgeführt wird und der CAVA-Service ordnungsgemäß gestartet wurde.
Data Mover kann CAVA-Server erkennen.

Affected Products

VNX/VNXe

Products

Celerra, Dell EMC Unity Family, VNX/VNXe
Article Properties
Article Number: 000065188
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.