Unity/VNX/Celerra: No se puede iniciar el servicio CAVA en el servidor de Windows (corregible por el usuario)

Summary: Cuando se intenta iniciar el servicio CAVA en el servidor de Windows, el servicio no se puede iniciar.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



En el servidor de Windows, se encuentran los siguientes mensajes:

Windows no pudo iniciar el servicio CAVA de EMC en la computadora
local Error 1053: el servicio no respondió a la solicitud de inicio o control de manera oportuna.

En el registro de eventos de Windows:
se agotó el tiempo de espera alcanzado los 30 000 milisegundos mientras se esperaba que se conectara el servicio CAVA de EMC.


En el administrador de transferencia de datos, se encuentran los siguientes mensajes de error generales:
[Ejemplos de VNX/Celerra]

[nasadmin@VNX01CS0 ~]$ server_viruschk server_2
server_2 :
10 hilos iniciados.
2 Dirección(es) IP del verificador:
10.xx.136.xxx OFFLINE at Fri Sep 15 02:01:41 2017 (GMT+10:00)
Protocolo desconocido, versión CAVA:
Motor AV:
Nombre del servidor:
10.xx.136.xxx Sin fecha

de firma 10.xx.136.xxx OFFLINE en Fri Sep 15 02:01:51 2017 (GMT+10:00)
Protocolo desconocido, versión de CAVA:
AV Engine:
Nombre del servidor:
10.xx.136.xxx Sin fecha

de firma 2 Máscara(s) de archivo:
*.* =.*
No se excluye ningún archivo.
Comparta \\nas01\CHECK$.
Tiempo de espera agotado de solicitud RPC = 25 000 milisegundos.
Tiempo de espera de reintento de RPC = 5000 milisegundos.
Marca de agua alta = 200.
Marca de agua baja = 50.
Analice todos los programas antivirus cada 10 segundos.
Cuando todos los programas antivirus estén offline:
continúe trabajando con la comprobación de virus y CIFS.
Escaneo en deshabilitación de lectura.
Controlador de estado de alarma registrado para 65 fragmentos.
Usuario de MS-RPC: NAS01$
MS-RPC ClientName: nas01.xxx.xxx.xxx

[nasadmin@VNX01CS0 ~]$ nas_logviewer /nas/log/sys_log | grep -i VC
14 de septiembre 12:34:25 2017:DART:VC:NOTICE:17:Slot 2:::1505356456:Se ha iniciado el programa antivirus.
Sep 14 12:34:35 2017:DART:VC:ERROR:33:Slot 2:::1505356466:Error en el servidor CAVA 10.xx.136.xxx: SIN CONEXIÓN.
Sep 14 12:34:45 2017:DART:VC:ERROR:33:Slot 2:::1505356476:Error en el servidor CAVA 10.xx.136.xxx: SIN CONEXIÓN.
Sep 14 12:34:45 2017:DART:VC:ERROR:4:Slot 2:::1505356476:No hay servidor de programa antivirus disponible.
Sep 14 12:43:45 2017:DART:VC:NOTICE:16:Slot 2:::1505357023:El programa antivirus está detenido.
~~
Sep 14 12:46:35 2017:DART:VC:NOTICE:16:Slot 2:::1505357191:El programa antivirus está detenido.
Sep 14 14:13:35 2017:DART:VC:NOTICE:17:Slot 2:::1505362408:Se ha iniciado el programa antivirus.
Sep 14 14:13:45 2017:DART:VC:ERROR:33:Slot 2:::1505362418:Error en el servidor CAVA 10.xx.136.xxx: SIN CONEXIÓN.
Sep 14 14:13:55 2017:DART:VC:ERROR:33:Slot 2:::1505362428:Error en el servidor CAVA 10.xx.136.xxx: SIN CONEXIÓN.
Sep 14 14:13:55 2017:DART:VC:ERROR:4:Slot 2:::1505362428:No hay servidor de programa antivirus disponible.

[Ejemplos de Unity]

14:26:30 service@VIRT1615YRRR08-spa spa:~> svc_cava cava-smb cava-smb
: comandos procesados:
La salida correcta de 1 comando
se completó

1507818392: VC: 5: VDM cava-smb: Habilitado e iniciado.
1507818392: VC: 5: 1 dirección(es) IP del verificador:
1507818392: VC: 5: 5.6.7.246 OFFLINE at Thu Oct 12 14:26:29 2017 (GMT-00:00)
1507818392: VC: 5:                                                HTTP, versión de CAVA: , httpStatus: 1006 Conexión desconectada
1507818392: VC: 5:                                                Motor AV:
1507818392: VC: 5:                                                Nombre del servidor: 5.6.7.246
1507818392: VC: 5:                                                Sin fecha
de firma 1507818392: VC: 5:
1507818392: VC: 5: 1 Máscara(s) de archivo:
1507818392: VC: 5: *.*
1507818392: VC: 5: No se excluyó ningún archivo.
1507818392: VC: 5: Recurso compartido \\5.6.7.56\CHECK$.
1507818392: VC: 5: Tiempo de espera agotado de solicitud RPC = 25 000 milisegundos.
1507818392: VC: 5: Tiempo de espera de reintento de RPC = 5000 milisegundos.
1507818392: VC: 5: Marca de agua alta = 200.
1507818392: VC: 5: Marca de agua baja = 50.
1507818392: VC: 5: Analice todos los programas antivirus cada 10 segundos.
1507818392: VC: 5: Cuando todos los programas antivirus están offline:
1507818392: VC: 5: Continúe trabajando con la comprobación de virus y CIFS.
1507818392: VC: 5: Escaneo en deshabilitación de lectura.
1507818392: VC: 5: Usuario de MS-RPC: CAVA-SMB$
1507818392: VC: 5: Nombre de cliente de MS-RPC: cava-smb. ASOMA. LAB
1507818392: ADMIN: 6: El comando se ejecutó correctamente:  viruschk
14:26:32 service@VIRT1615YRRR08-spa spa:~>

[/EMC/C4Core/log/c4_safe_ktrace.log]

2017/10/12-14:31:55.028840 582 7FC1F33C9701 sade:VC: 5:[cava-smb] Habilite la 536870934 del sistema de archivos para la comprobación de virus.
2017/10/12-14:31:55.028879 36 7FC1F33C9701 sade:VC: 5:[cava-smb] Habilite la 536870933 del sistema de archivos para la comprobación de virus.
2017/10/12-14:31:55.028947 66 7FC1F33C9701 sade:VC: 5:17:[cava-smb] Se inicia el programa antivirus.
2017/10/12-14:31:55.053859 24K 7FC1F33C9701 sade:VC: 3:34:[cava-smb] Se produjo un error en el servidor del programa antivirus 5.6.7.246 y ya no funciona. (Error: OFFLINE,2017
/10/12-14:31:55.053864 4 7FC1F33C9701 sade:VC: 3:34:[cava-smb] httpEstado: 1006 Conexión desconectada)
2017/10/12-14:31:55.053879 13 7FC1F33C9701 sade:VC: 3: 4:[cava-smb] No hay ningún servidor de programa antivirus disponible.
2017/10/12-14:31:55.053888 7 7FC1F33C9701 sade:VC: 5:[cava-smb] Total de solicitudes: 0.2017
/10/12-14:31:55.053893 3 7FC1F33C9701 sade:VC: 5:[cava-smb]
2017/10/12-14:31:55.053899 4 7FC1F33C9701 sade:VC: 5:[cava-smb] NO HAY RESPUESTA de los servidores del programa antivirus: 0.2017
/10/12-14:31:55.053932 31 7FC1F33C9701 sade:VC: 5:[cava-smb] ERROR_SETUP: 0.2017
/10/12-14:31:55.053938 5 7FC1F33C9701 sade:VC: 5:[cava-smb] FALLA: 0.2017
/10/12-14:31:55.053945 4 7FC1F33C9701 sade:VC: 5:[cava-smb] TIEMPO DE espera: 0.2017
/10/12-14:31:55.053949 2 7FC1F33C9701 sade:VC: 5:[cava-smb]
2017/10/12-14:31:55.053956 4 7FC1F33C9701 sade:VC: 5:[cava-smb] 0 archivos en la cola del recopilador.
2017/10/12-14:31:55.053961 3 7FC1F33C9701 sade:VC: 5:[cava-smb] 0 archivos procesados por los subprocesos de AV.

Cause

Cuando se inicia un servicio, este comunica al administrador de control de servicios cuánto tiempo debe tener para iniciarse el servicio (el período de tiempo de espera agotado para el servicio). Si el administrador de control de servicios no recibe un aviso de "servicio iniciado" del servicio dentro de este período de espera, el administrador de control de servicios finalizará el proceso que aloja el servicio. Por lo general, este período de tiempo de espera es inferior a 30 segundos.

Requisitos del sistema de NET Framework para Windows 8 y Windows Server 2012 Windows 8 y Windows Server 2012 instala y habilita de forma predeterminada .NET Framework 4.5. Sin embargo, CEE Framework, "cava.exe", es un servicio de .NET Framework 3.5. Debe habilitar .NET Framework 3.5. El sitio web de Microsoft contiene instrucciones sobre cómo habilitar .NET Framework 3.5 en Windows 8 y Windows 2012 en: http://msdn.microsoft.com/ens/library/hh506443.aspx

Resolution

Instale o habilite .NET Framework 3.5 en Windows 10, Windows 8.1 y Windows 8
https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10

una vez que .NET Framework 3.5 esté en ejecución y el servicio CAVA se haya iniciado correctamente.
El administrador de transferencia de datos puede detectar el servidor CAVA en buen estado.

Affected Products

VNX/VNXe

Products

Celerra, Dell EMC Unity Family, VNX/VNXe
Article Properties
Article Number: 000065188
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.