Unity/VNX/Celerra. Не удается запустить службу CAVA на сервере Windows (исправляется пользователем)

Summary: При попытке запустить службу CAVA на сервере Windows будет невозможно запустить службу.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



На сервере Windows отображаются следующие сообщения:

Window не удалось запустить службу EMC CAVA на локальном компьютере
Ошибка 1053: служба своевременно не ответила на запрос запуска или управления.

Из журнала событий Windows:
истекло время ожидания подключения сервиса EMC CAVA — 30 000 млн. сек.


В модуле переноса данных отображаются следующие сообщения об общих ошибках:
[Примеры VNX/Celerra]

[nasadmin@VNX01CS0 ~]$ server_viruschk server_2
server_2 :
10 потоков запущено.
2 IP-адрес(и) чекера:
10.xx.136.xxx OFFLINE at Fri Sep 15 02:01:41 2017 (GMT+10:00)
Неизвестный протокол, версия CAVA:
AV Engine:
Server Name:
10.xx.136.xxx Нет даты

подписания 10.xx.136.xxx OFFLINE в Пт Сен 15 02:01:51 2017 (GMT+10:00)
Неизвестный протокол, CAVA Версия:
AV Engine:
Server Name:
10.xx.136.xxx Нет даты

подписи 2 Маска(и) файла:
*.* =.*Файл
не исключен.
Общий ресурс \\nas01\CHECK$.
Время ожидания запроса RPC=25000 мс.
Время ожидания повторной попытки RPC=5000 мс.
Верхнее пороговое значение=200.
Нижняя отметка=50.
Проверять все средства антивирусной проверки каждые 10 секунд.
Когда все средства антивирусной проверки находятся в автономном режиме:
Продолжайте работать с проверкой на вирусы и CIFS.
Сканировать при чтении отключено.
Обработчик критических ошибок зарегистрирован для 65 фрагментов.
Пользователь MS-RPC: NAS01$
MS-RPC ClientName: nas01.xxx.xxx.xxx

[nasadmin@VNX01CS0 ~]$ nas_logviewer /nas/log/sys_log | grep -i VC
Sep 14 12:34:25 2017:DART:VC:NOTICE:17:Слот 2:::1505356456:Запущена антивирусная проверка.
Sep 14 12:34:35 2017:DART:VC:ERROR:33:Slot 2:::1505356466:Ошибка на сервере CAVA 10.xx.136.xxx: АВТОНОМНЫЙ.
Sep 14 12:34:45 2017:DART:VC:ERROR:33:Слот 2:::1505356476:Ошибка на сервере CAVA 10.xx.136.xxx: АВТОНОМНЫЙ.
Sep 14 12:34:45 2017:DART:VC:ERROR:4:Slot 2:::1505356476:Сервер антивирусной проверки недоступен.
14 сентября 12:43:45 2017:DART:VC:NOTICE:16:Слот 2:::1505357023:Средство проверки на вирусы остановлено.
~~
Sep 14 12:46:35 2017:DART:VC:NOTICE:16:Слот 2:::1505357191:Средство проверки на вирусы остановлено.
Sep 14 14:13:35 2017:DART:VC:NOTICE:17:Слот 2:::1505362408:Запущена антивирусная проверка.
Sep 14 14:13:45 2017:DART:VC:ERROR:33:Slot 2:::1505362418:Ошибка на сервере CAVA 10.xx.136.xxx: АВТОНОМНЫЙ.
Sep 14 14:13:55 2017:DART:VC:ERROR:33:Slot 2:::1505362428:Ошибка на сервере CAVA 10.xx.136.xxx: АВТОНОМНЫЙ.
Sep 14 14:13:55 2017:DART:VC:ERROR:4:Slot 2:::1505362428:Сервер антивирусной проверки недоступен.

[Примеры Unity]

14:26:30 service@VIRT1615YRRR08-spa spa:~> svc_cava cava-smb
cava-smb : обработано команд:
Вывод 1 команды(ов) успешно
выполнен

1507818392: Виртуальный канал: 5. VDM cava-smb: Включено и запущено.
1507818392: Виртуальный канал: 5. 1 IP-адрес(а) чекера:
1507818392: Виртуальный канал: 5. 5.6.7.246 OFFLINE в Чт Окт 12 14:26:29 2017 (GMT-00:00)
1507818392: Виртуальный канал: 5.                                                Версия HTTP, CAVA: , httpStatus: 1006 Подключение отключено
1507818392: Виртуальный канал: 5.                                                AV Engine:
1507818392: Виртуальный канал: 5.                                                Имя сервера: 5.6.7.246
1507818392: Виртуальный канал: 5.                                                Нет даты
подписания 1507818392: Виртуальный канал: 5:
1507818392: Виртуальный канал: 5. 1 Маска файла:
1507818392: Виртуальный канал: 5. *.*
1507818392: Виртуальный канал: 5. Нет исключенных файлов.
1507818392: Виртуальный канал: 5. Общий ресурс \\5.6.7.56\CHECK$.
1507818392: Виртуальный канал: 5. Время ожидания запроса RPC=25000 мс.
1507818392: Виртуальный канал: 5. Время ожидания повторной попытки RPC=5000 мс.
1507818392: Виртуальный канал: 5. Верхнее пороговое значение=200.
1507818392: Виртуальный канал: 5. Нижняя отметка=50.
1507818392: Виртуальный канал: 5. Проверять все средства антивирусной проверки каждые 10 секунд.
1507818392: Виртуальный канал: 5. Когда все средства антивирусной проверки находятся в автономном режиме:
1507818392: Виртуальный канал: 5. Продолжайте работу с антивирусной проверкой и CIFS.
1507818392: Виртуальный канал: 5. Сканировать при чтении отключено.
1507818392: Виртуальный канал: 5. Пользователь MS-RPC: CAVA-SMB$
1507818392: Виртуальный канал: 5. Имя клиента MS-RPC: cava-smb. ВЫГЛЯДЫВАЕТ. ЛАБОРАТОРНАЯ 1507818392
: АДМИНИСТРАТОРА: 6: Команда выполнена успешно:  viruschk
14:26:32 service@VIRT1615YRRR08-spa spa:~>

[/EMC/C4Core/log/c4_safe_ktrace.log]

2017/10/12-14:31:55.028840 582 7FC1F33C9701 sade:VC: 5:[cava-smb] Включение 536870934 файловой системы для проверки на вирусы.
2017/10/12-14:31:55.028879 36 7FC1F33C9701 sade:VC: 5. [cava-smb] Включение 536870933 файловой системы для проверки на вирусы.
2017/10/12-14:31:55.028947 66 7FC1F33C9701 sade:VC: 5:17:[cava-smb] Запущено средство антивирусной проверки.
2017/10/12-14:31:55.053859 24К 7FC1F33C9701 sade:VC: 3:34:[cava-smb] На сервере антивирусной проверки 5.6.7.246 произошла ошибка, и он больше не работает. (Ошибка: ОФФЛАЙН,
2017/10/12-14:31:55.053864 4 7FC1F33C9701 sade:VC: 3:34:[cava-smb] httpStatus: 1006 Соединение отключено)
2017/10/12-14:31:55.053879 13 7FC1F33C9701 sade:VC: 3. 4:[cava-smb] Сервер антивирусной проверки недоступен.
2017/10/12-14:31:55.053888 7 7FC1F33C9701 sade:VC: 5:[cava-smb] Всего запросов: 0.2017
/10/12-14:31:55.053893 3 7FC1F33C9701 sade:VC: 5:[cava-smb]
2017/10/12-14:31:55.053899 4 7FC1F33C9701 sade:VC: 5:[cava-smb] НЕТ ОТВЕТА от серверов антивирусной проверки: 0.2017
/10/12-14:31:55.053932 31 7FC1F33C9701 sade:VC: 5:[CAVA-SMB] ERROR_SETUP: 0.2017
/10/12-14:31:55.053938 5 7FC1F33C9701 sade:VC: 5:[cava-smb] FAIL: 0.2017
/10/12-14:31:55.053945 4 7FC1F33C9701 sade:VC: 5:[cava-smb] ТАЙМ-АУТ: 0.2017
/10/12-14:31:55.053949 2 7FC1F33C9701 sade:VC: 5:[cava-smb]
2017/10/12-14:31:55.053956 4 7FC1F33C9701 sade:VC: 5:[cava-smb] 0 файлов в очереди сборщика.
2017/10/12-14:31:55.053961 3 7FC1F33C9701 sade:VC: 5:[cava-smb] 0 файлов, обработанных потоками антивирусной защиты.

Cause

Когда служба запускается, она сообщает диспетчеру управления службами о том, как долго служба должна быть запущена (период ожидания для службы). Если диспетчер управления службами не получает уведомления «служба запущена» в течение этого периода ожидания, диспетчер управления службами завершает процесс, в котором размещена служба. Обычно этот интервал ожидания составляет менее 30 секунд

. NET Framework для Windows 8 и Windows Server 2012 Windows 8 и Windows Server 2012 устанавливают и активируют .NET Framework 4.5 по умолчанию. Однако платформа CEE, «cava.exe», является службой .NET Framework 3.5. Необходимо включить .NET Framework 3.5. На веб-сайте Microsoft содержатся инструкции по включению .NET Framework 3.5 в Windows 8 и Windows 2012 по адресу: http://msdn.microsoft.com/ens/library/hh506443.aspx

Resolution

Установка или включение .NET Framework 3.5 в Windows 10, Windows 8.1 и Windows 8
https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10

После запуска .NET Framework 3.5 и правильного запуска сервиса CAVA.
Модуль переноса данных может обнаружить сервер CAVA OK.

Affected Products

VNX/VNXe

Products

Celerra, Dell EMC Unity Family, VNX/VNXe
Article Properties
Article Number: 000065188
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.