NetWorker: Problemen met 'Time-out bij inactiviteit' oplossen

Summary: Back-ups mislukken met time-outfouten voor inactiviteit.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Symptomen

  • Fout: Inactivity timeout
  • Back-ups mislukken door time-outfout bij inactiviteit
  • Back-ups afgebroken vanwege time-outfout bij inactiviteit
  • Fout: (client):(save set) has been inactive for (number) minutes
  • Fout: SYSTEM STATE:\ aborted due to inactivity
  • Fout: nsrexec: clientname has been abandoned by nsrexec
  • Fout: nsrexecd: Recvd signal to kill process group - aborted due to inactivity
  • Fout: nsrexec: Attempting a kill on remote save
  • Back-ups mislukken met time-outfouten bij inactiviteit
  • Fout: inactivity timeout Tijdens incrementele back-up
  • Fout: No full backups of this save set were found in the media database; performing a full backup
  • Incrementele back-ups mislukken
  • Slaat op, reageert niet meer

Cause

NetWorker biedt de kenmerken 'Time-out inactiviteit' op verschillende locaties:

  • Time-out bij inactiviteit NetWorker-servertaak:
    Time-out bij inactiviteit van taak 
OPMERKING: De time-out voor inactiviteit van taak geeft aan hoe lang NetWorker wacht op een taakreactie. Als er niet op tijd een antwoord komt, beëindigt de server de taak. De time-out voor inactiviteit van de taak is van toepassing op alle acties die in alle werkstromen in een beleid zijn gedefinieerd. De standaardinstelling is nul (geen time-out).
 
  • Time-out voor inactiviteit bij actie:
    Time-out wegens inactiviteit van actie 
OPMERKING: Dit geeft het maximale aantal minuten aan dat een taak die wordt uitgevoerd door een actie kan proberen te reageren op de server. Als een taak niet op tijd reageert, markeert de server deze als mislukt. NetWorker probeert het onmiddellijk opnieuw om tijdverlies door de fout te voorkomen. Inactiviteit kan optreden voor back-ups van grote opslagsets, back-ups van opslagsets met grote schaarse bestanden en incrementele back-ups van veel kleine statische bestanden. De time-outoptie voor inactiviteit is van toepassing op testacties en de back-upacties voor de actietypen Traditioneel en Momentopname. Als u een waarde opgeeft voor deze optie in andere acties, negeert NetWorker de waarde.


De NetWorker Administration Guide bevat aanvullende informatie over de instellingen voor "Time-out bij inactiviteit": NetWorker documentatie

Resolution

Over het algemeen kan een time-out bij inactiviteit verschillende oorzaken hebben.

Time-outfouten bij inactiviteit treden vaak op wanneer de client een groot bestandssysteem scant. Als er weinig bestanden zijn gewijzigd, kan de volgende opslagstream aanzienlijk worden vertraagd. Deze situatie kan worden opgelost door de waarde van het kenmerk 'Inactivity Timeout' te verhogen voor de NetWorker-back-upactie die de fout meldt. Stel de waarde in op 0 om de time-out uit te schakelen. Let vervolgens op de duur van de opslagset en stel de time-out voor inactiviteit in op dat aantal minuten of meer.

Als de time-out niet het gevolg is van de hierboven vermelde reden, bevestig dan de volgende items:

  1. Controleer of de NetWorker-client niet is uitgeschakeld en de netwerkkabel is aangesloten.
  2. Nieuwe pogingen van back-ups mislukken altijd.
  3. Alle naamresoluties tussen de NetWorker-client en de back-upserver zijn succesvol: NetWorker: Best practices voor het oplossen van problemen met naamresolutie
  4. Controleer of alle bekende aliassen voor de NetWorker-client zijn ingevoerd in het alias-attribuut van de NetWorker-clientresource.
  5. Alle netwerkkaarten en switches hebben dezelfde duplex-, snelheids-, MTU- en andere instellingen.
  6. De instellingen voor parallellisme zijn correct gedefinieerd. Raadpleeg de NetWorker Performance Optimization and Planning Guide: NetWorker documentatie
  7. Controleer de instelbare TCP/IP-parameter. Raadpleeg de NetWorker Performance Optimization and Planning Guide: NetWorker documentatie
Als alle bovenstaande beweringen waar zijn, controleer dan de volgende, ook bekende factoren die dit probleem kunnen veroorzaken.

Firewalls:
Als een firewall de NetWorker-server en de client van elkaar scheidt, moet u voldoende poorten binnen het NetWorker-verbindingsbereik openen om goede communicatie mogelijk te maken. De NetWorker-server kan de client bereiken, maar de client kan nieuwe poorten niet openen om te reageren. NetWorker-processen en -poorten

OPMERKING: Overleg met uw netwerk- of beveiligingsteam om het firewallverkeer tijdens de actie te controleren die mislukt met time-outfouten, en controleer op eventuele communicatieproblemen.

NetWorker-configuratie:
 
Er is gezien waar een onjuist geconfigureerd kenmerk 'Uitvoeringspad' voor de resource van de NetWorker-client deze time-outfouten voor inactiviteit heeft veroorzaakt. Configureer het attribuut 'Execution Path' correct of laat het leeg.
 
Corruptie:
  1. Dit probleem werd veroorzaakt door beschadiging van bestanden op de schijf. Controleer de checksum of datum van de bestanden om hun integriteit te garanderen. Verwijder, verplaats of repareer het beschadigde bestand of gebruik de NetWorker-instructie om het over te slaan.
  2. Beschadiging van het NetWorker-resourcebestand, met name de back-up- of kloonactieresource, veroorzaakt af en toe time-outfouten bij inactiviteit. Probeer de bron van de mislukte back-up- of kloonactie te verwijderen en opnieuw te maken. U kunt ook proberen het NetWorker-resourcebestand te herstellen van een tijd voordat de fouten begonnen. Dit vereist meestal de betrokkenheid van NetWorker-support om NetWorker Server Disaster Recovery (NSRDR) uit te voeren
  3. Het is bekend dat beschadiging van NetWorker-clientbestandsindexen of mediadatabase leidt tot time-outfouten bij inactiviteit. Voer nsrck -L6 om te proberen indexen te herstellen of nsrck -L7 om indexen te herstellen. Voor de mediadatabase kan beschadiging worden opgelost door een oudere mediadatabase te herstellen. Dit vereist meestal de betrokkenheid van NetWorker-support om NetWorker Server Disaster Recovery (NSRDR) uit te voeren.
Wanneer alle bovenstaande aanbevelingen zijn uitgeput en voordat u naar andere probleemoplossing gaat, wordt het ten zeerste aanbevolen om:
  • Start NetWorker-daemons opnieuw om caches te wissen die mogelijk verouderd zijn.
Linux: 
nsr_shutdown
systemctl start networker

OR

/etc/init.d/networker start
Windows:
net stop nsrexecd /y

For NetWorker servers:
net start nsrd

For NetWorker Management Console Servers:
net start nsrexecd
net start gstd

For NetWorker client systems:
net start nsrexecd
  • Start de server en client opnieuw op, waardoor het geheugen wordt gewist van alle fragmenten van dode code en initialiseer alle applicaties en het besturingssysteem opnieuw.

Additional Information

   Raadpleeg voor aanvullende referenties voor configuratie- en prestatieanalyse van NetWorker:

General NetWorker:
NetWorker Server afstemmen voor optimale prestaties  KB-205851
Multihomed NetWorker-back-ups configureren (in het Engels)  KB-204258
Een BIGASM-test uitvoeren (in het Engels)  KB-205896
Parallellisme en doelsessies KB-202942

Netwerk-DNS:
Problemen met DNS en naamomzetting oplossen (in het Engels)  KB-125514
Hoe DNS Forward & Reverse Lookup Zones te configureren  KB-198676
DNS - Supportvoorwaarden en tools voor diagnose  KB-197647
DNS - Network Connection Settings  KB-198751

Netwerkpoorten en firewalls:
NetWorker-poortbereiken berekenen en configureren KB-173639
De opdracht 'nsrrpcinfo' van NetWorker gebruiken  KB-199703
NetWorker Firewall Port Settings KB-203593

Affected Products

NetWorker

Products

NetWorker Series
Article Properties
Article Number: 000068580
Article Type: Solution
Last Modified: 23 Sep 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.