Root-акаунт VMware ESXi заблоковано на 900 секунд після невдалих спроб входу
Summary: У цій статті наведено розв'язання, коли віддалений доступ до кореня локального облікового запису ESXi блокується на 900 секунд після невдалих спроб входу. Підключіться до консолі iDRAC, щоб отримати доступ до оболонки ESXi, а потім виконайте команду скидання. ...
Symptoms
Кореневий обліковий запис одного або кількох ESXi-хостів заблокований через кілька невдалих спроб входу.
Не можу підключитися до вузла через SSH або веб-інтерфейс
.Підтверджуйте проблему через консоль iDRAC для ESXi shell.
У vCenter показується попереджувальне повідомлення, подібне до наступного:
Remote access for ESXi local user account 'root' has been locked for 900s after 14 failed login attempts.

Рисунок 1: Віддалений доступ заблоковано.
Журнали, схожі на наступні, знаходяться на ураженому хості:
/var/log/vobd.log
2020-04-03T17:27:58.790Z: [GenericCorrelator] 8202447897096us: [vob.user.account.locked] Remote access for ESXi local user account 'root' has been locked for 900 seconds after 32 failed login attempts.
2020-04-03T17:27:58.790Z: [UserLevelCorrelator] 8202447897096us: [vob.user.account.locked] Remote access for ESXi local user account 'root' has been locked for 900 seconds after 32 failed login attempts.
2020-04-03T17:27:58.791Z: [UserLevelCorrelator] 8202447897325us: [esx.audit.account.locked] Remote access for ESXi local user account 'root' has been locked for 900 seconds after 32 failed login attempts.
/var/log/auth.log
2020-04-03T17:29:06Z sshd[701694298]: Connection from 192.168.100.40 port 55682
2020-04-03T17:29:06Z sshd[701333862]: pam_tally2(sshd:auth): user root (0) tally 34, deny 5
2020-04-03T17:29:08Z sshd[701694298]: error: PAM: Authentication failure for root from 192.168.100.40
2020-04-03T17:29:08Z sshd[701694492]: pam_tally2(sshd:auth): user root (0) tally 35, deny 5
2020-04-03T17:29:08Z sshd[701694492]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.100.40 user=root
2020-04-03T17:29:10Z sshd[701694298]: error: PAM: Authentication failure for root from 192.168.100.40
2020-04-03T17:29:10Z sshd[701694298]: error: Received disconnect from 192.168.100.40 port 55682:3: com.jcraft.jsch.JSchException: Auth cancel [preauth]
2020-04-03T17:29:10Z sshd[701694298]: Disconnected from authenticating user root 192.168.100.40 port 55682 [preauth]
Cause
.Це спричиняє кілька невдалих входів (іноді сотні, а іноді й тисячі). Це блокує root-акаунт на 15 хвилин, що призводить до неможливості SSH до вузла або входу в веб-інтерфейс вузла.
Ви можете увійти через DCUI та ESXi shell.
Починаючи з vSphere 6.0, підтримується блокування облікового запису для доступу через SSH та через SDK веб-сервісів vSphere. Інтерфейс Direct Console (DCUI) та оболонка ESXi не підтримують блокування акаунта. За замовчуванням дозволяється максимум п'ять невдалих спроб до блокування акаунта. Обліковий запис за замовчуванням розблоковується через 15 хвилин.
Resolution
- Підключіть до консолі iDRAC , а потім до оболонки ESXi.
- Увімкніть оболонку , увійшовши в DCUI та увімкнувши ESXi shell у налаштуваннях усунення несправностей.
- Ви також можете зробити
Cntrl-Alt-F1щоб отримати доступ до оболонки. - Після підключення до оболонки ESXi виконайте наведені нижче команди. Вихід має збігатися зі скріншотом нижче, але в записі «From» написано «невідомо».
#pam_tally2 --user root #pam_tally2 --user root --reset #pam_tally2 --user root
Рисунок 2: Команди та виведення ESXi
- Після виконання вищезазначених команд увійдіть у веб-інтерфейс вузла ESXi.
- Перейдіть у Монітор , а потім у Події. Ви повинні побачити IP-адресу, яка намагалася увійти, але вказана як невдала.
- Ви повинні ідентифікувати заявку за IP-адресою, наведеною тут. Або зупинити це, або налаштувати з правильними обліковими даними.
Additional Information
Детальніше дивіться статтю VMware «ESXi Passwords and Account Lockout».
Дивіться це відео про ESXi Break Fix Unlock root User Account.
Тривалість: 00:04:56 (hh:mm:ss)
Коли доступно, налаштування мови субтитрів (субтитри) можна вибрати за допомогою іконки Settings або CC на цьому відеоплеєрі.