Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell Storage: VMware ESXi-hosts voorbereiden om te koppelen aan SCv20x0, SCv30x0, SC4020, SC5020 SAS arrays

Summary: Volg de onderstaande instructies om uw wmESXi te maken om aan SAS arrays te koppelen.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Instructions
Dit artikel bevat informatie over:   
  • VMware ESXi-hosts voorbereiden om te koppelen aan de SCv20x0, Scv30X0, SC4020 SC5020 arrays
  • Compatibiliteit met Stuurprogramma's met front-end SAS connectiviteit

  1. VMware ESXi-hosts voorbereiden om te koppelen aan de SCv20x0, Scv30X0, SC4020 SC5020 arrays

Zie KB-artikel 000147092 Dell Storage Compatibility Matrix voor het ondersteunde stuurprogramma en de firmware

  • Voor ESXi 5.5 en 6.0 hebt u de "mpt3sas" driver nodig die u kunt downloaden van de VMware-website.
    • De aangepaste Dell ESX 5.5 & 6.0 ISO's zullen niet automatisch de juiste SAS HBA-driver laden. De driver moet worden bijgewerkt.
    • Als u de native inbox-driver gebruikt, is het voor de HBA('s) niet mogelijk om de volumes in ESX te zien.
  • Voor ESXi 6.5 hebt u de "lsi_msgpt3" driver nodig en kunt u de inbox-driver gebruiken. Standaard gebruiken verschillende ISO-images verschillende drivers.
    • Dell EMC raadt aan om de aangepaste Dell ISO voor VMware op Dell EMC PowerEdge servers te gebruiken. U vindt de ISO onder het gedeelte Oplossing voor bedrijven op de pagina Drivers en downloads van de website van Dell.
    • De aangepaste Dell ESX 6.5 ISO zal automatisch de juiste SAS HBA-driver laden.
    • Als u de standaard VMware ESX 6.5 ISO gebruikt, moet u de juiste SAS HBA inbox-driver inschakelen.
Deze procedures komen overeen met de stappen in stap 4 van de installatieposter die bij de SCv20x0 is meegeleverd of hoofdstuk 3 in de implementatiehandleiding.
 
Als u een ESX host met SAS HBA's aan de Storage Center array wilt koppelen, moet u de DSM Data Collector gebruiken.  Rechtstreekste aansluitingen van de DSM Client op de array worden momenteel niet ondersteund.

Bepalen welke driver is ingeschakeld:  
  1. Schakel SSH ins op de ESXi host:
    1. Meld u aan bij de ESXi host met vSphere Client
    2. Selecteer het tabblad 'Configuration' (Configuratie) en selecteer vervolgens 'Security Profile’ (Beveiligingsprofiel) in het menu Software.
    3. In het gedeelte Services, selecteert u 'Properties’ (Eigenschappen).
    4. Selecteer 'SSH' en klik vervolgens op de knop 'Options’ (Opties).
    5. Klik op 'Start' en bevestig met 'OK'.
  2. Maak verbinding met de ESXi host via een SSH client (zoals Putty).
  3. Bepaal welke driver wordt uitgevoerd. U kunt dit doen door de volgende opdracht te typen: "esxcfg-scsidevs-a"                                                       
HOW11081_en_US__1ESX_SAS_esxcfg-scsidevs-a
 
  1. Als u een standaard ESX 6.5 ISO image gebruikt, kunt u de "mpt3sas" driver uitschakelen en de "lsi_msgpt3" driver met deze opdrachten inschakelen:  
  • esxcfg-module -d mpt3sas
  • esxcfg-module -e lsi_msgpt3
  1. Voor ESX 5.5 & 6.0: Als u de verkeerde driver hebt, gaat u naar stap 5a. Als u de juiste driver ziet, gaat u naar stap 5b.
    1. Schakel de verkeerde driver uit met behulp van de volgende opdracht
  • esxcli system module set --enabled=false --module=lsi_msgpt3. Ga naar stap 6
HOW11081_en_US__2ESX_SAS_esxcli_system_module_set (1)
  1. Controleren of de versie van het stuurprogramma overeenkomt met die van het KB-artikel 000147092 compatibiliteitsdiagram van Dell Storage: met behulp van de volgende opdracht:
  • Voor de mpt3sas driver typt u "vmkload_mod -s mpt3sas |grep Version
HOW11081_en_US__3ESX_SAS_vmkload_mod
  Driver bijwerken:  
  1. Haal alle VM's van de host, ga naar de onderhoudsmodus.
  2. Download de juiste versie van het stuurprogramma zoals vermeld in KB-artikel 000147092. compatibiliteitsdiagram van Dell Storage: : (Met ingang van dit artikel is de versie van de driver 04.00.00.00.1vmw voor ESX 5.5 U2). De driver kunt u vinden op de VMware-website.
  3. Pak het ".VIB"-bestand uit van het gedownloade 'ZIP'-pakket met drivers.
  4. Upload het ".VIB"-bestand naar de ESXi host.
    1. In de interface van de ESXi host, selecteert u het tabblad ‘Configuration’ (Configuratie).
    2. Selecteer 'Storage' in het menu Configuration (configuratie) en vervolgens een datastore voor het uploaden van het ".VIB”-bestand. 
      (Als er geen datastore beschikbaar is, kunt u een willekeurige FTP-client gebruiken en naar de map /tmp uploaden.)
    3. Blader door uw datastore (klik met de rechtermuisknop), “Browse Datastore”.
    4. Selecteer het pictogram “upload a file” (een bestand uploaden) om het ".VIB"-bestand te uploaden.
  5. Installeer het nieuwe stuurprogramma (u moet het pad en de bestandsnaam dienovereenkomstig aanpassen) door de volgende opdracht te typen: "esxcli software VIB install-v/vmfs/volumes/esxi01-local/scsi-mpt3sas-04.00.00.00.1vmw-1OEM.500.0.0.472560.x86_64. VIB"
HOW11081_en_US__4ESX_SAS_esxcli_software_vib
 
  1. Start de VMware ESXi host opnieuw op.
  2. De juiste driver moet nu in de HBA('s) zijn geladen en goed met het Storage Center kunnen functioneren. U kunt dit controleren door stap 5b hierboven te herhalen.
De HBA-firmware moet ook worden bijgewerkt met behulp van de iDRAC.
  1. Compatibiliteit met Stuurprogramma's met front-end SAS Connectivity2

In de Dell EMC Storage Compatibility Matrix wordt de 6.5 VMWare ESXi versie getest/ondersteund met SAS front-end-connectiviteit. SAS-driver 'lsi-msgpt3' versie 12 en Storage Center OS (SCOS)-versies 7.2.x en 7.3.x zijn opgenomen in deze geteste en ondersteunde oplossing. Upgrades naar VMWare ESXi 6.5 U1, 6.5 U2 en 6.7 installeren echter automatisch bijgewerkte lsi-msgpt3 SAS drivers, zoals versie 16.  Zonder handmatige configuratie van een moduleparameter voor de driver werken lsi-msgpt3 versies hoger dan versie 12 niet naar behoren (na opnieuw opstarten van de host ziet u bijvoorbeeld een LUN-capaciteit van 0 bytes, hebt u geen toegang meer tot SAS front-end-volumes na failover van de controller en PSOD-kerneldump) met ESXi-versies die deze bijgewerkte driver en SCOS gebruiken. Dit heeft vooral betrekking op ESXi 6.5 en 6.7; echter, als deze nieuwere driver wordt gebruikt op ESXi 6.0 (dit is niet de standaarddriver), dan is dit ook van toepassing.

Aanbevelingen: 

Als u SAS-verbinding gebruikt tussen Storage Center en ESXi-hosts die de lsi-msgpt3-driver gebruiken (ESXi 6.5+ doorgaans), kunt u het beste de moduleparameter wijzigen, zoals hieronder beschreven voor alle versies van de lsi-msgpt3 SAS-driver.  Dit is vereist voor alle versies hoger dan versie 12.  Deze bijgewerkte aanbevolen instellingen zijn te vinden in Dell EMC SC serie aanbevolen werkwijzen met VMware vSphere 5.x–6.x (in het Engels). Houd er rekening mee dat deze wijziging vereist dat de host opnieuw wordt opgestart.

Stappen voor de configuratie van de moduleparameter voor de SAS driver 

  1. Geef de waarden van de moduleparameter weer
esxcli system module parameters list -m lsi_msgpt3
 
SLN313031_en_US__1image (7172)
  1. Wijzig de moduleparameter issue_scsi_cmd_to_bringup_drive
esxcli system module parameters set -p issue_scsi_cmd_to_bringup_drive=0 -m lsi_msgpt3
  1. Controleer of de waarde van de moduleparameter is gewijzigd door de list-opdracht in stap 1.
SLN313031_en_US__2image (7173)
  1. Start de ESXi host opnieuw op om de gewijzigde waarde te activeren. 
 

Article Properties


Affected Product

Dell Compellent SC4020, Dell Storage SCv2000, Dell Storage SCv2020, Dell Storage SCv2080, Dell Storage SC5020

Product

Storage

Last Published Date

21 Feb 2021

Version

6

Article Type

How To