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Réparation d’un chargeur de démarrage EFI sur un disque dur GPT pour Windows 7, 8, 8.1 et 10 sur votre ordinateur Dell

Summary: Cet article fournit des informations sur la manière de résoudre les problèmes liés au chargeur de démarrage EFI qui ne démarre pasSee more

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Article Content


Symptoms

Cause

Introduction

 

La plupart des personnes qui rencontrent des problèmes de démarrage sous des systèmes d’exploitation Windows choisissent de réinstaller le système d’exploitation plutôt que de tenter de résoudre le problème de démarrage proprement dit.

Cet article explique comment réparer le chargeur de démarrage EFI (Extensible Firmware Interface) sur un disque dur GPT (GUID (Globally Unique Identifiers) Partition Table).

Cela ne fonctionne que pour les systèmes d’exploitation installés sur un BIOS (Basic Input/Output System) UEFI (Unified Extensible Firmware Interface).


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Resolution

Réparation de votre chargeur de démarrage EFI

 

Windows 7, 8 et 8.1 peuvent être installés sur un BIOS hérité à l’aide d’un MBR. Cependant, Windows 8, 8.1 et 10 ont été conçus pour être installés sur le BIOS UEFI à l’aide du chargeur de démarrage EFI et du GPT.

Remarque : si vous tentez de réparer la racine d’un disque dur, vous risquez de perdre toutes les données du disque que vous n’avez pas encore sauvegardées. Il est conseillé de toujours effectuer une sauvegarde complète avant d’intervenir sur un disque ou sur son système d’exploitation.

La structure GPT traite d’un grand nombre des problèmes résolus par la commande Bootsect dans le MBR. Si vous devez cependant réparer le chargeur de démarrage EFI, suivez les instructions ci-dessous :

Windows 7

Si vous disposez du support d’installation :

  1. Insérez le support (DVD/USB) dans votre ordinateur personnel et redémarrez.

  2. Démarrez à partir du support.

  3. Cliquez sur Réparer l’ordinateur.

  4. Sélectionnez le système d’exploitation, puis cliquez sur Suivant.

  5. Sélectionnez Invite de commandes dans le menu :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  6. Vérifiez que la partition EFI (EPS, EFI System Partition) utilise le système de fichiers FAT32. Attribuez-lui une lettre de lecteur qui n’est pas encore utilisée :

    1. Saisissez et exécutez la commande suivante :

      sel vol <number of volume>

    2. Saisissez et exécutez la commande suivante :

      assign letter=<drive letter>:

    3. Saisissez et exécutez la commande suivante :

      exit

  7. Pour réparer l’enregistrement de démarrage :

    1. Saisissez et exécutez la commande suivante :

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

Si vous ne disposez pas du support d’installation :

  1. Redémarrez votre ordinateur personnel.

  2. Appuyez rapidement sur la touche <F8> une fois l’ordinateur sous tension, mais avant que l’écran de démarrage Windows ne s’affiche.

  3. Sélectionnez Réparer votre ordinateur dans le menu qui s’affiche.

  4. Sélectionnez Invite de commandes dans les Options de récupération.

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  5. Vérifiez que la partition EFI (EPS) utilise le système de fichiers FAT32 et attribuez-lui une lettre de lecteur qui n’est pas déjà utilisée.

    1. Saisissez et exécutez la commande suivante :

      sel vol <number of volume>

    2. Saisissez et exécutez la commande suivante :

      assign letter=<drive letter>:

    3. Saisissez et exécutez la commande suivante :

      exit

  6. Pour réparer l’enregistrement de démarrage :

    1. Saisissez et exécutez la commande suivante :

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

Windows 8 et Windows 8.1

Si vous disposez du support d’installation :

  1. Insérez le support (DVD/USB) dans votre ordinateur personnel et redémarrez.

  2. Démarrez à partir du support.

  3. Cliquez sur Réparer l’ordinateur.

  4. Sélectionnez Résolution des problèmes.

  5. Sélectionnez Invite de commandes dans le menu :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  6. Vérifiez que la partition EFI (EPS, EFI System Partition) utilise le système de fichiers FAT32. Attribuez-lui une lettre de lecteur qui n’est pas encore utilisée :

    1. Saisissez et exécutez la commande suivante :

      sel vol <number of volume>

    2. Saisissez et exécutez la commande suivante :

      assign letter=<drive letter>:

    3. Saisissez et exécutez la commande suivante :

      exit

  7. Pour réparer l’enregistrement de démarrage :

    1. Saisissez et exécutez la commande suivante :

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

Si vous ne disposez pas du support d’installation :

  1. Redémarrez votre ordinateur personnel.

  2. Appuyez rapidement sur la touche <F8> une fois l’ordinateur sous tension, mais avant que l’écran de démarrage Windows ne s’affiche.

    Plusieurs tentatives peuvent être nécessaires. Le temps alloué pour cette opération a été réduit par rapport à Windows 7.

  3. Sélectionnez Réparer votre ordinateur dans le menu qui s’affiche.

  4. Sélectionnez Invite de commande dans l’écran Résolution des problèmes :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  5. Vérifiez que la partition EFI (EPS) utilise le système de fichiers FAT32. Attribuez-lui une lettre de lecteur qui n’est pas encore utilisée :

    1. Saisissez et exécutez la commande suivante :

      sel vol <number of volume>

    2. Saisissez et exécutez la commande suivante :

      assign letter=<drive letter>:

    3. Saisissez et exécutez la commande suivante :

      exit

  6. Pour réparer l’enregistrement de démarrage :

    1. Saisissez et exécutez la commande suivante :

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

Windows 10

Si vous disposez du support d’installation :

  1. Insérez le support (DVD/USB) dans votre ordinateur personnel et redémarrez.

  2. Démarrez à partir du support.

  3. Cliquez sur Réparer l’ordinateur.

  4. Sélectionnez Résolution des problèmes.

  5. Sélectionnez Options avancées.

  6. Sélectionnez Invite de commandes dans le menu :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  7. Vérifiez que la partition EFI (EPS, EFI System Partition) utilise le système de fichiers FAT32. Attribuez-lui une lettre de lecteur qui n’est pas encore utilisée :

    1. Saisissez et exécutez la commande suivante :

      sel vol <number of volume>

    2. Saisissez et exécutez la commande suivante :

      assign letter=<drive letter>:

    3. Saisissez et exécutez la commande suivante :

      exit

  8. Pour réparer l’enregistrement de démarrage :

    1. Saisissez et exécutez la commande suivante :

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

 
Remarque : si le support d’installation de votre système d’exploitation est Windows 10 (version 1709 ou plus récente), veuillez ignorer les commandes de l’étape 8 et passer directement aux informations figurant à la fin de cette section d’instructions.
 

Si vous ne disposez pas du support d’installation :

  1. Redémarrez votre ordinateur personnel.

  2. Appuyez rapidement sur la touche <F8> une fois l’ordinateur sous tension, mais avant que l’écran de démarrage Windows ne s’affiche.

    Plusieurs tentatives peuvent être nécessaires. Le temps alloué pour cette opération a été réduit par rapport à Windows 7.

  3. Sélectionnez Réparer votre ordinateur dans le menu qui s’affiche.

  4. Sélectionnez Invite de commande dans l’onglet Options avancées de l’écran Résolution des problèmes :

    1. Saisissez et exécutez la commande suivante :

      diskpart

    2. Saisissez et exécutez la commande suivante :

      sel disk 0

    3. Saisissez et exécutez la commande suivante :

      list vol

  5. Vérifiez que la partition EFI (EPS) utilise le système de fichiers FAT32 et attribuez-lui une lettre de lecteur (attribuez une lettre qui n’est pas déjà utilisée) :

    1. Saisissez et exécutez la commande suivante :

      sel vol <number of volume>

    2. Saisissez et exécutez la commande suivante :

      assign letter=<drive letter>:

    3. Saisissez et exécutez la commande suivante :

      exit

  6. Pour réparer l’enregistrement de démarrage :

    1. Saisissez et exécutez la commande suivante :

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. Saisissez et exécutez la commande suivante :

      bootrec /FixBoot

L’étape suivante est la même pour tous les systèmes d’exploitation :

  1. Reconstruisez le magasin BCD.

    1. Commencez par exécuter la commande ci-dessous pour sauvegarder l’ancien BCD :

      ren BCD BCD.old

    2. Recréez-le ensuite à l’aide de la commande suivante :

      bcdboot c:\Windows /l en-us /s <boot letter>: All

Remarque : si vous créez les entrées de démarrage sur une clé USB ou un autre lecteur externe, ajoutez /f entre : et ALL. N’oubliez pas que <lettre lecteur démarrage> est remplacé par la lettre du lecteur à partir duquel vous démarrez (Par exemple, C:\, D:\)
 
Remarque : si votre support de système d’exploitation est Windows 10 (version 1709 ou plus récente), utilisez la commande suivante au lieu de la dernière série d’étapes :
  • c:\Windows /s <boot letter>: /f UEFI
 


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Réparation de votre MBR (enregistrement de démarrage principal)

 

Ces étapes s’appliquent à tout disque existant, utilisé comme disque de démarrage sur un système d’exploitation Windows récent.

  1. Pour accéder au menu de démarrage, appuyez sur la touche F12 quand l’écran de démarrage Dell s’affiche. Ce menu vous permet de démarrer à partir du support d’installation de Windows, d’un disque amorçable ou d’un lecteur Flash.

  2. Cliquez sur le lien Réparer votre ordinateur en bas de l’écran Installer maintenant.

  3. Cliquez sur Dépanner.

  4. Sélectionnez Invite de commandes.

  5. Saisissez les trois commandes suivantes tour à tour, puis, après chacune d’elle, appuyez sur la touche Entrée :

    bootrec /fixmbr

    bootrec /fixboot

    bootrec /rebuildbcd

  6. Redémarrez l’ordinateur après avoir retiré le support d’installation pour vérifier si la réparation a fonctionné.

 

Si vous avez besoin d’une aide supplémentaire, contactez le support technique.

 

  Contactez-nous  


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Additional Information


Support hors garantie Hors garantie ? Aucun problème. Consultez le site Web Dell.com/support, puis saisissez votre numéro de série Dell et consultez nos offres.

Remarque : les offres sont uniquement disponibles pour les clients qui possèdent un ordinateur personnel aux États-Unis, au Canada, au Royaume-Uni, en France, en Allemagne et en Chine. Serveur et stockage non applicable.

Article Properties


Affected Product

Inspiron, Latitude, Vostro, XPS, Fixed Workstations

Last Published Date

18 Jun 2021

Version

10

Article Type

Solution

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