Exception Activating PBA - CreateDataBaseFailed - Hynix SC300 M.2 Hard Drive
Summary: Computers with Hynix SC300 M.2 hard drives may not be able to activate PBA, and they also receive an Exception activating PBA - CreateDataBaseFailed message in log files.
Symptoms
Affected Products:
- Dell Data Protection | Encryption
Affected Versions:
- v8.X
Affected Operating Systems:
- Windows 7, 8, 8.1, and 10
While attempting to enable the PBA on a machine that is equipped with the following hard drive:
- SK Hynix SC300 SATA - M.2
An issue may be reported where the PBA cannot be activated.
In the agent logs several entries similar to the following are reported:
2017.03.30 18:36:28 E Pba : exception activating PBA - PbaProxy.CreateDatabase failed – CreateDataBaseFailed
The Dellcommon logs have several input/output errors present:
[2017.03.30 18:33:06][162A8CCE40][6008][3700][W:](opal_send_StartSess) Unable to open session, LOCKING_SP is not activated [2017.03.30 18:33:06][162A9DFA1A][6008][3700][E:](SedDatastoreConnect) DiskId=0, Unable to connect to Datastore [2017.03.30 18:33:06][162AAD7947][6008][3700][E:](SedDataStoreReadRaw) DiskId=0, Unable to connect to Datastore [2017.03.30 18:33:06][162ACBF33E][6008][3700][E:](SQLite3DBOpen) disk I/O error (Error code: 10)
Cause
A specific condition of this OPAL disks firmware, where the M.2 drive can enter a lower power state. This is done to lower the overall power consumption of the computer. It is dropping the power consumption of the disk too low, which then causes the OPAL drive to lock up during PBA activation.
Resolution
The following hard drive firmware update resolves this issue:
https://www.dell.com/support/home/Drivers/DriversDetails?driverId=754Y5
To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
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