Dell Encryption Enterprise nécessite System32 . Fichiers EXE à exclure
Summary: Des exclusions Dell Encryption Enterprise (anciennement Dell Data Protection Enterprise Edition) peuvent être ajoutées pour System32 . exe en suivant ces instructions.
Symptoms
Produits concernés :
- Dell Encryption Enterprise
- Dell Data Protection | Enterprise Edition
Versions concernées :
- v7.0.x et versions ultérieures
Microsoft a récemment modifié le processus de mise à jour Windows pour modifier les fichiers du répertoire \Windows\System32 avant le chargement des pilotes Dell Encryption Enterprise. Cela peut entraîner le remplacement des fichiers exécutables chiffrés SDE (.exe) dans le dossier System32 par un fichier en texte clair (non chiffré) sans que Dell Encryption Enterprise n’en informe Dell Encryption Enterprise.
Cause
Cela entraîne la tentative de déchiffrement d’un fichier non chiffré par Dell Encryption Enterprise, ce qui entraîne un écran bleu.
Resolution
Comment puis-je savoir si je suis concerné ?
Ce problème concerne uniquement les utilisateurs de Dell Encryption Enterprise avec System Data Encryption (SDE). Cliquez sur la version de votre Dell Security Management Server pour déterminer si le problème est présent dans votre environnement.
- Connectez-vous à Dell Data Protection Remote Management Console (RMC).
- Dans le volet du menu de gauche, cliquez sur Populations.

Figure 1 : (En anglais uniquement) Populations
- Cliquez sur Enterprise, Endpoint Groups ou Endpoints. Cette option dépend de l’endroit où les règles SDE sont modifiées dans votre organisation.

Figure 2 : (En anglais uniquement) Choisissez Enterprise, Groupe de points de terminaison ou Points de terminaison
- Cliquez sur File/Folder Encryption (FFE).

Figure 3 : (En anglais uniquement) Chiffrement des fichiers/dossiers (FFE)
- Vérifiez si la case Cryptage SDE activé (SDE Encrypted Enabled) est cochée.

Figure 4 : (En anglais uniquement) Vérifier l’activation du chiffrement SDE
- Sous Règles de chiffrement SDE, recherchez
%ENV:SYSTEMROOT%\SYSTEM32\;exeouC:\Windows\System32\;exesans un-Symbole.
Exemple d’une stratégie rencontrant le problème :
C:\Windows\System32\;exe @C:\Windows\System32\;exe %ENV:SYSTEMROOT%\System32\;exe @%ENV:SYSTEMROOT%\System32\;exe
^, ^2 ou ^3 Symbole.
Si vous ne parvenez pas à trouver une syntaxe similaire aux exemples ci-dessus, cela ne vous affecte pas. Si vous trouvez une syntaxe similaire à l’exemple ci-dessus, accédez à : Comment puis-je résoudre le problème ?
- Connectez-vous à Dell Data Protection Remote Management Console (RMC).
- Dans le volet de menu de gauche, sélectionnez Entreprise, Groupes de points de terminaison ou Points de terminaison. Cette option dépend de l’endroit où les règles SDE sont modifiées dans votre organisation.

Figure 5 : (En anglais uniquement) Choisissez Enterprise, Endpoint Groups, Endpoints
Exemple d’une stratégie rencontrant le problème :
^, ^2 ou ^3 Symbole.
Si vous ne parvenez pas à trouver une syntaxe similaire aux exemples ci-dessus, ce problème ne vous affecte pas. Si vous trouvez une syntaxe similaire à l’exemple ci-dessus, accédez à : Comment puis-je résoudre le problème ?
- Sélectionnez l'onglet Security Policies.

Figure 6 : (en anglais uniquement) Security Policies
- Si le menu du modèle s’affiche, cliquez sur Remplacer , puis passez à l’étape 5.

Figure 7 : (En anglais uniquement) Substituer
- Dans le menu déroulant Catégorie de politique (Policy Category), sélectionnez Cryptage Windows (Windows Encryption).

Figure 8 : (En anglais uniquement) Sélectionnez Windows Encryption
- Développez Stockage fixe (Fixed Storage).

Figure 9 : (En anglais uniquement) Stockage fixe
- Vérifiez si l’option Cryptage SDE activé (SDE Encryption Enabled) est définie sur vrai (true). Si l’option Chiffrement SDE activé est définie sur False, vous êtes concerné par ce problème.
- Sous Règles de chiffrement SDE, recherchez
%ENV:SYSTEMROOT%\SYSTEM32\;exeouC:\Windows\System32\;exesans un-Symbole.
C:\Windows\System32\;exe @C:\Windows\System32\;exe %ENV:SYSTEMROOT%\System32\;exe @%ENV:SYSTEMROOT%\System32\;exe
Comment résoudre ce problème ?
Cliquez sur la version de votre serveur Dell Data Security / Dell Data Protection Server correspondant à la solution.
- Reconnectez-vous à RMC et accédez à la section Règles de chiffrement SDE (voir Comment savoir si je suis concerné ?).
- Ajoutez un symbole « - » (moins) à la syntaxe en question.
Exemple de changement :

Figure 10 : (En anglais uniquement) Avant

Figure 11 : (En anglais uniquement) Après
- Dans le menu supérieur droit, cliquez sur Enregistrer.

Figure 12 : (En anglais uniquement) Sauvegarder
- Dans le volet du menu de gauche, cliquez sur Gestion.

Figure 13 : (En anglais uniquement) Managment
- Cliquez sur Valider (Commit).

Figure 14 : (En anglais uniquement) Commettre
- Dans le menu Valider, saisissez éventuellement des commentaires sur la modification de la politique, puis appuyez sur Valider la politique.
- Les points de terminaison utilisant Dell Encryption Enterprise recevront la nouvelle modification de règle lors de la prochaine interrogation de règle et commenceront à déchiffrer les .exe dans le dossier System32.
Cela peut entraîner un écran bleu si .exe extensions sont chiffrées avec SDE (System Data Encryption), Common ou User.
- Reconnectez-vous à RMC et accédez à la section Règles de chiffrement SDE (voir Comment savoir si je suis concerné ?).
- Ajouter un
-(moins) à la syntaxe en question.
Exemple de changement :

Figure 15 : (En anglais uniquement) Avant

Figure 16 : (En anglais uniquement) Après
- Dans le coin inférieur droit, cliquez sur Enregistrer.

Figure 17 : (En anglais uniquement) Sauvegarder
- Dans le volet du menu de gauche, cliquez sur Valider les stratégies (Commit Policies) (sous Actions).

Figure 18 : (en anglais uniquement) Commit Policies
- Vous pouvez éventuellement entrer un commentaire sur la modification de la stratégie avant de cliquer sur Appliquer les modifications (Apply Changes).
- Points de terminaison utilisant Dell Data Protection | Enterprise Edition détectera la nouvelle modification de règle lors de la prochaine interrogation et commencera à déchiffrer les .exe dans le dossier System32.
Pour contacter le support technique, consultez l’article Numéros de téléphone du support international Dell Data Security.
Accédez à TechDirect pour générer une demande de support technique en ligne.
Pour plus d’informations et de ressources, rejoignez le Forum de la communauté Dell Security.