Constant Reboot Prompts on Dell Encryption Enterprise Shield or Dell Data Protection Enterprise Edition Shield

Summary: Dell Encryption (formerly Dell Data Protection | Encryption) causes constant reboot prompts.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Data Protection | Encryption

Dell Encryption displays a toaster dialog box on endpoints due to encryption policies needing a restart of the device before they can take effect, or to gain access to in-use or locked files. In 8.9.3 or later, these prompts may be more frequent due to a change in the way the encryption processes place items on a retry list. Previously, Dell Encryption would silently place items that did not get encrypted through the initial sweep (due to in use or access denied, and so on) on a silent retry list that would attempt on the next reboot. In newer versions, Dell Encryption prompts for that reboot to ensure that the device is protected.

Dell Data Protection | Encryption reboot prompt
Figure 1: (English Only) Dell Data Protection | Encryption reboot prompt

 
Note: These policies are in the Remote Management Console and must be changed in the Management Studio.

Cause

Changes to software has caused this issue.

Resolution

The policy that is labeled Force Reboot on Update controls whether we get reboot prompts when a key type must change or when a key file that is required to encrypt cannot be accessed due to it being in-use or locked. When we are unable to access data, we add that file to a retry list, which is processed on the next boot sequence.

Force Reboot on Update
Figure 2: (English Only) Force Reboot on Update

The policy that is labeled Force Logoff/Reboot on Policy Update triggers when the client consumes a new policy, and a reboot is required for that policy to become active.

Force Logoff/Reboot on Policy Updates
Figure 3: (English Only) Force Logoff/Reboot on Policy Updates


To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.

Affected Products

Dell Encryption
Article Properties
Article Number: 000126661
Article Type: Solution
Last Modified: 03 Oct 2023
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.