Microsoft-Sicherheitslückenaktualisierungen können zu Kommunikationsfehlern in Dell Encryption führen.
Summary: Updates für Sicherheitslücken von Microsoft können zu Kommunikationsfehlern in Dell Encryption (früher Dell Data Protection | Encryption) führen.
Symptoms
Betroffene Produkte:
- Dell Encryption
- Dell Data Protection | Encryption
Cause
Nachdem Microsoft Sicherheitsupdates zur Behebung von Schwachstellen versendet hat, haben wir festgestellt, dass diese Updates die Kommunikation von Dell Encryption beeinträchtigen. In Umgebungen, in denen Diffie-Hellman Export (DHE)-Cipher Suites auf dem Dell Security Management Server (ehemals Dell Data Protection | Enterprise Edition)-Server, das folgende Verhalten kann nach der Installation von Microsoft-Updates auftreten:
In diesem Beispiel schlugen die Aktivierungen fehl. Im Shield-Protokoll wurden die folgenden Meldungen angezeigt:
[07.08.16 11:54:38:824 CredantServerIn: 211] [ERROR] SSL request failed.. HTTP error An error occurred in the secure channel support [MS ec=12157]. [07.08.16 11:54:38:824 CredantServerIn: 211] [ERROR] HTTP error. HTTP error A security error occurred [MS ec=12175].
und
[07.08.16 11:54:38:864 XmlRpcActivate: 128] Activating user... [07.08.16 11:54:38:924 XmlRpcActivate: 415] SSL Failure status code. HTTP error(-2147483648) - [07.08.16 11:54:38:934 XmlRpcActivate: 415] SSL request failed.. HTTP error(12157) - An error occurred in the secure channel support [07.08.16 11:54:38:934 XmlRpcActivate: 415] HTTP error. HTTP error(12175) - A security error occurred [07.08.16 11:54:38:934 XmlRpcActivate: 148] Activation request failed [code:0x2f8f]: [07.08.16 11:54:38:934 Activator: 709] [SUPPORT] [W] Activation - Unable to activate new user XXXXXXX [error = 0x2f8f] [07.08.16 11:54:38:934 Activator: 711] Activation - Verify that the CMG Shield is properly installed. [07.08.16 11:54:38:934 Activator: 716] Activation - Verify network connectivity to the CMG Server at "XXXXXXX" and CMG Device Server at [07.08.16 11:54:38:934 ] - Device Server Connection error (12175)
Der Endpunkt kann den Server anpingen und erfolgreich über Telnet auf den Port zugreifen. Sogar einige Browser wie Chrome können die Website aufrufen, der IE hingegen nicht.
In den Windows-Systemereignisprotokollen sind Einträge für die SChannel-Komponente vorhanden:
- 36888 0 2 0 0 0x8000000000000000 19178 System XXXXXXXXXXXXXXX.com - 40 808
Resolution
Wenn diese Verhaltensweisen auftreten, überprüfen Sie, welche Microsoft-Aktualisierungen auf den Endpunkt angewendet wurden. Zwei Aktualisierungen, die zu Problemen führen konnten, sind:
- Microsoft-Sicherheitsupdate MS15-055/KB3061518
- Microsoft Sicherheitsupdate-KB3161608
Eines der Updates ändert auf dem Endpunkt die minimale DHE-Schlüssellänge von 512 Bit auf 1024 Bit. Standardmäßig ermöglicht der Dell Security Management Server die Verwendung von 768-Bit-DHE-Gruppen, was dazu führt, dass der SSL- oder TLS-Handshake fehlschlägt, nachdem diese Aktualisierungen angewendet wurden. Um den Endpunkt so umzustellen, dass er die Verwendung von DHE-Schlüsseln mit einer Mindestlänge von 512 Bit zulässt, müssen Sie die Registrierung auf dem Endpunkt aktualisieren. Suchen Sie in der Registrierung den folgenden Unterschlüssel:
- Sichern Sie die Registrierung, bevor Sie fortfahren. Lesen Sie How to Back Up and Restore the Registry in Windows (Anleitung zum Sichern und Wiederherstellen der Registrierung in Windows
).
- Das Bearbeiten der Registrierung kann dazu führen, dass der Computer beim nächsten Neustart nicht mehr reagiert.
- Wenden Sie sich an die Telefonnummern des internationalen Supports von Dell Data Security, um Unterstützung zu erhalten, wenn Sie Bedenken hinsichtlich der Durchführung dieses Schritts haben.
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\KeyExchangeAlgorithms\Diffie-Hellman
- Fügen Sie dann DWord ClientMinKeyBitLength hinzu und setzen Sie den Wert auf 00000200.
Nutzen Sie zur Kontaktaufnahme mit dem Support die internationalen Support-Telefonnummern von Dell Data Security.
Gehen Sie zu TechDirect, um online eine Anfrage an den technischen Support zu erstellen.
Zusätzliche Einblicke und Ressourcen erhalten Sie im Dell Security Community Forum.