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Dell Digital Delivery User Guide

Summary: The following article provides a user guide to the Dell Digital Delivery application.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms


Table of Contents:

  1. What is Dell Digital Delivery and how does it work?
  2. How do I uninstall or reinstall the Dell Digital Delivery Application and service?
  3. How do I retrieve my Dell Digital Delivery Software, Entitlement, and/or License Key?
  4. Dell Digital Delivery Warranty and Licensing
  5. Frequently Asked Questions (FAQ)
    1. When I receive the message, "There was a problem, Please reinstall," are there any other options before reinstalling?
    2. I receive the message, "Dell Digital Delivery has not been able to connect to the Internet. Please make sure you are connected and try again"
    3. Dell Digital Delivery has not been able to connect to the Internet
    4. Logs are being requested so that analysis can be done?
  6. Glossary
  7. Software Vendor Links, and Articles
    1. Adobe
    2. Cyberlink
    3. McAfee
    4. Foxit
    5. Miscellaneous other software vendors
  8. Microsoft Office Links, and Articles
  9. Troubleshooting Help

What is Dell Digital Delivery and how does it work?

 

Dell Digital Delivery (DDD) is a service which enables you to purchase software at the time you order your computer. You can download and install it once you receive the computer and connect to the Internet.

Here is how it works:

When you order Optional software to be Digitally Delivered with your computer. You will not receive physical media (CD's or DVD's, paper license keys, or printed documentation) for these Digitally Fulfilled applications.

When your new computer is powered on for the first time, you will be walked through the regular computer setup including connecting to the Internet.

After you have connected your computer to the Internet. The Dell Digital Delivery application that is already installed on your computer will run automatically within 30 minutes after the OS activation. When Dell Digital Delivery runs, it will alert you that it is ready to download and install any software that you may have purchased. 

You will be presented with one of two possible displays depending on the version of Microsoft Windows that is installed on your computer:

  • Windows 10 version 1709 and previous versions along with Non-Windows 10 will receive the following walkthrough:

    • You will be presented with the following screen:

      SLN316077_en_US__1DDD_Start_Screen_BK

      (Figure.1 Dell Digital Delivery Start Screen)

      • You can select one of these options: Download Now, Remind Me Later or Do Not Download.

        If you choose to download the software, you can select the software - which will put a checkmark in the selection box. You can then select Download Now. After a successful download, you will receive the following message:

        SLN316077_en_US__2DDD_Purchase_Delivery_BK

        (Figure.2 Dell Digital Delivery Purchase Delivery Screen)

        If you select download later, you will receive a reminder after reboot or every 24 hours until you complete the download.

        Selecting Do Not Download will end the process until you decide to return to the download screen. You can return to the download screen by selecting the Dell Digital Delivery application at the Start Menu.

  • If your computer has an operating system which is Windows 10 version 1803 or newer, you will receive the following walkthrough for downloading your purchased software.

    SLN316077_en_US__3DDD_Dell_Digital_Delivery_BK

    (Figure.3 Dell Digital Delivery Screen)

    At the time Dell Digital Delivery is launched, you can choose Download Now. Alternatively, there are various options for snoozing the download of your purchases.

    SLN316077_en_US__4DDD_Snooze_Screen_BK

    (Figure.4 DDD Snooze Screen)

    If you choose the Snooze, the option to download notice will appear after the selected time option. If you choose Do Not Download, your software will not be downloaded. If you change your mind, you may launch the Dell Digital Delivery application manually at any time. (at the start menu)

    If you click Download Now by opening the application, you will be presented with several options as you download your software:

    • Download All.
    • Review the status of the software Redeemed.
    • Redeem each software individually.
    • Review your license key number.
    • Review the History of your software downloads.
    • Reinstall software from the History Menu.

    Initially, the application will present you with the option to redeem all copies of the software. You only need to select Download All.

    SLN316077_en_US__5DDD_Download_All_BK

    (Figure.5 DDD Download All Screen)

    The Status will be displayed with a Progress Bar for you to review.

    SLN316077_en_US__6DDD_Progress_Screen_BK

    (Figure.6 DDD Progress Screen)

    SLN316077_en_US__7DDD_Available_Screen_BK

    (Figure.7 DDD Available Tab)

    If your preference is to download an individual software, selecting GET will start the process.

    SLN316077_en_US__8DDD_Get_Screen_BK

    (Figure.8 DDD Get)

    You will then select the Redeem software option. If you are interested in reviewing your License Key number? After selecting GET, you will be presented with two options (Redeem software or Copy License Key XXXXX-XXXX-XXXX-XXXX) in which case you will see your license Key.

    SLN316077_en_US__9image(11504)

    (Figure.9 DDD Redeem)

    At any time, you can review the History of your downloaded software via the History Tab within Dell Digital Delivery:

    SLN316077_en_US__10DDD_History_Screen_BK

    (Figure.10 DDD History Tab)

    From the History Tab, you can reinstall your Software. Selecting the downward arrow of the Installed selection allows you to install your software again.

    SLN316077_en_US__11DDD_Install_Again_BK

    (Figure.11 DDD Install Again)

    Dell Digital Delivery will inform you when the installation is complete. If a restart of the computer is needed, you will be prompted to do so. After installation is complete, the installed programs can be found in your Start Menu or All Programs (Windows 7 and 8) or Apps and Features for Windows 10.


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Cause

How do I uninstall or reinstall the Dell Digital Delivery Application and service?

 

To uninstall Dell Digital Delivery for Windows 7 and 8, go to the Control Panel and choose Programs and Features. Select Dell Digital Delivery and follow the computer's instructions to remove and uninstall the program, for Windows 10.

To reinstall Dell Digital Delivery:

Non-UWP (Universal Windows Platform): Dell Support.

UWP: Go to the Windows Store.

 


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How do I retrieve my Dell Digital Delivery Software, Entitlement, and/or License Key?

 

Non-UWP: Dell Support

UWP: From the History Tab.

SLN316077_en_US__10DDD_History_Screen_BK

(Figure.10 DDD History Tab)


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Dell Digital Delivery Warranty and Licensing

 

The entitlement for the license (and download) is kept available for either 8 years or 10 downloads and is not related to the hardware warranty.

Resetting the Dell Digital Delivery Client and Gathering the Logs. (Windows 7 up to Windows 10 version 1803)

DDDFixIt Tool

The DDDFixIt Tool described above will reset the Dell Digital Delivery application and deposit the logs in a DDDFixIt folder on your desktop.

Internal Reset

If Dell Digital Delivery can be launched on your machine, it can be reset internally by clicking Options (the gear icon) and Reset Settings.

For Windows 10 (version 1803 and later) you can reset under the General Tab.

SLN316077_en_US__13DDD_General_Tab_BK

(Figure.12 DDD General Tab)

In the case of a system exchange, the entitlement for Dell Digital Delivery is transferred to the new systems service tag.

 


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Resolution

Frequently Asked Questions (FAQ)

 

 

  1. You can reinstall the software from within Dell Digital Delivery by clicking the Info Icon. It is located at the right of the listing for the application. Select Install this application again.

  2. If that is not successful, you can reset the Dell Digitally Delivered Application by clicking Options (the 'gear' icon) and Reset Settings.

  3. If this is unsuccessful, you may attempt to manually install the software. Open a Windows Explorer window by clicking the folder at the bottom of your desktop and navigate to C:\ProgramData\Dell\DigitalDelivery\Downloads\Software.

 

  1. Close the Dell Digital Delivery application.

  2. Launch a browser such as Internet Explorer and attempt to navigate to any website:

    • If you are successful, start the Dell Digital Delivery application again.

    • If you were unable to navigate to a website, click Start, Control Panel, Network and Sharing Center, and select "Set up a new connection or network." Follow the instructions and once you are connected to the Internet, start the Dell Digital Delivery application again.

 

Run through the following steps to resolve the issue:

  1. Check your firewall settings, adjust them if needed.

  2. Verify your Internet connection by connecting to another secure website such as:

  3. If this works, try connecting to:

  4. If this brings up a secure log-in prompt, try connecting to digital delivery again. If you do not see this prompt or you still cannot connect to digital delivery, your firewall settings may need to be adjusted. Alternatively, the Dell Backend may be down.

  5. Dell Technical Support may be able to make some suggestions in these cases by looking at your main client log files:

    • C:\ProgramData\Dell\Digital Delivery\Logs\Service.Log.

  6. Reset DDD. (Figure.3)

  7. Uninstall and reinstall ADD from the Drivers and Downloads website.

Note: For non-UWP Windows 10 systems, DDDFixIT.exe is a downloadable tool which will attempt to solve any problems and install the latest version of the DDD application.

 

The log files are located at C:\ProgramData\Dell\Digital Delivery\Logs.


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Glossary

 

Term Definition Description
  Cirrus  
DDD Dell Digital Delivery Service for downloading, and installing software that was purchased or came with your PC.
How to access your Dell Digital Locker
DDL Dell Digital Locker Single destination to manage PURCHASED software products:
https://www.dell.com/support/software/Default/QuickStartGuide
How to access your Dell Digital Locker
  Dell Download Center Dell offers different sources for downloading BIOS, Drivers, and Software applications. Reinstall your software or get the last software that you just bought.
https://www.dell.com/support/contents/category/product-support/self-support-knowledgebase/software-and-downloads/download-center/
DEE Digital Entitlement Engine Engine to process the license retrieval request, trigger LKM to generate the license key.
  Entitlement  
  Keys  
LKM License Key Manager License Key Manager (LKM) that helps in managing digital product keys (DPKs) for procurement, allocation, inventory management, returns, account reconciliation, and audits.


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Software Vendor Links, and Articles

 


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Microsoft Office Links, and Articles

 

Microsoft Office:

Microsoft Office

SnP

You can check out third-party software available from Dell on the following link:

Alternatively, you can follow this path from the main site:

  • Dell Shop > For Home > Accessories > Software > Business and Office > Office Applications >

Articles

Title LKB Article
Manually track your Microsoft Office 2016 Licenses. 000178254
Fix Outlook and Office 365 problems with Microsoft Support and Recovery Assistance for Office 365. https://diagnostics.office.com/#/ SLN316077_en_US__15iC_External_Link_BD_v1
 


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Troubleshooting Help

 

Articles


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Article Properties


Affected Product

G Series, Inspiron, Latitude, Vostro, XPS, Tablets, Fixed Workstations

Last Published Date

03 Mar 2022

Version

10

Article Type

Solution